Bug 529245 - No support for proxy
No support for proxy
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: telepathy-gabble (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-15 13:57 EDT by Felipe Contreras
Modified: 2009-10-30 04:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-28 19:23:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 23640 None None None Never

  None (edit)
Description Felipe Contreras 2009-10-15 13:57:54 EDT
The proxy setting must be obtained from GNOME settings. Currently nothing is implemented.
Comment 1 Felipe Contreras 2009-10-15 13:59:16 EDT
Blocks bug #494985.
Comment 2 Brian Pepple 2009-10-28 19:23:32 EDT
If I remember correctly, support for CONNECT proxy *does* exist in Telepathy-Gabble (though it's buggy) via the 'https-proxy*' parameters of the connection manager. It needs to connect to the gconf-configured proxy_https_port instead of 443, and send the correct XMPP server hostname to the proxy.

Closing as NOTABUG since proxy support is available.
Comment 3 Felipe Contreras 2009-10-30 04:32:12 EDT
Well, http proxy definitely doesn't work.

So who should be setting the http-proxy parameters?

Note You need to log in before you can comment on or make changes to this bug.