Bug 52943 - kde doesn't show all translations for KR and JP
kde doesn't show all translations for KR and JP
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kdelibs (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-31 01:44 EDT by Leon Ho
Modified: 2013-01-10 16:37 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-06 07:36:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is default Korean desktop. (Ugly!) (224.31 KB, image/png)
2001-09-04 16:17 EDT, Nakai
no flags Details

  None (edit)
Description Leon Ho 2001-08-31 01:44:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-12 i686)

Description of problem:
When doing the fresh installation with kde, it does not show up all
translations in some of the menus (tested with KR and JP)

Version-Release number of selected component (if applicable):
kdebase-2.2-9

How reproducible:
Always

Steps to Reproduce:
1. Install re0828.2 with KR or JP
2. run kde
3. open main menu
4. opps some of the translations is gone (ie. displays in english)
	

Actual Results:  some of the translation is gone like in main menu or
kcontrol(ie. displays in english)

Expected Results:  shows all the translations

Additional info:

o happens in re0829 too

- When you try to do:
# rpm -e ttfonts-{ko,ja}
# rpm -Uvh ttfonts-{ko,ja}

- restart kde
- the translations will come back


o not working ideas like:
	restart xfs
	xset fp rehash
	restart X
Comment 1 Bill Nottingham 2001-09-04 15:07:52 EDT
Does this work with kdebase-2.2-10 for you?
Comment 2 Nakai 2001-09-04 15:55:04 EDT
kdebase-2.2-10 doesn't fix the problem for Japanese
on my desktop.
Comment 3 Bernhard Rosenkraenzer 2001-09-04 15:56:33 EDT
Does it work if you rm -rf .kde after installing 2.2-10? The problem might 
have been caused by kcontrol writing bad charset information to your 
~/.kde/share/config/* files.

Comment 4 Nakai 2001-09-04 16:12:41 EDT
rm -rf ~/.k* ~/.D*
startkde

but it won't fix.
Comment 5 Nakai 2001-09-04 16:17:10 EDT
Created attachment 30875 [details]
This is default Korean desktop. (Ugly!)
Comment 6 Bill Nottingham 2001-09-04 20:44:37 EDT
What does chkfontpath --list say?
Comment 7 Leon Ho 2001-09-04 21:11:58 EDT
I have similar experience. It is possible that the locale is not ko_KR.eucKR.
KDE will automatically changed all the font configs to first available font in
the font list (ie. batang for KR).

For the actual problem, I am still looking into it - will let you all know the
updates.
Comment 8 Leon Ho 2001-09-05 01:21:01 EDT
Tested throughly on kde - Was trying to back-track the version of kdebase and
kdelibs.
Results:
Installed re0831.0 (kde{base,lib}-2.2-9), jp locale
Login as root
	After kpersonalize, restart X
		Some menu entries are in English
	
	Installed with kde{base,lib}-2.2-9}, rm -rf .kde, restart X
		Same
	
	Installed with 2.2-7, .....
		Same

	Installed with 2.2-6, .....
		After restart X, the menus works fine.

	Reinstall with 2.2-7, .....
		Some menu entries changed back to English

Therefore it's possible the changes from 2.2-6 to 2.2-7 effects. However I was
trying to track down the changes, the only changes that I have found is
exporting $KDEDIR using /etc/profile.d/kde.{sh,csh}. I tried to remove it and
seems it doesn't effect the menus.


Retried using normal username (ie. username = test) with re0831.0
	After kpersonalize, restart X
		The menu works fine

bero, do you have any idea on it? Thanks
Comment 9 Leon Ho 2001-09-05 01:25:40 EDT
BTW, kdebase doesn't effect the outcome. kdelibs is the main package here.
Comment 10 Leon Ho 2001-09-05 02:19:26 EDT
Also please look at "Additional comment by haarbye@online.no" in Bug 35863
Comment 11 Nakai 2001-09-05 11:07:28 EDT
kdelibs-2.2-10 seems to fix this problem but users should logout once to
take effect of the kpersonalizer settings. (And Qt3/KDE future ver. will
improve this inconvinience)
Comment 12 Leon Ho 2001-09-05 21:49:37 EDT
Seems kdelibs-2.2-10 does not works for root user. Some other results that might
narrowed down the bug:

Using re0831.0 with kdelibs-2.2-10 and kdebase-2.2-11
2.2 Way
	Procedure:
		rm -rf .kde*; startx; kpersonalize; exit; startx
	Results:
	- normal user kind of works after a restart (90% of translations), still have
little part of menus that doesn't uses the translation (e.g. in JP locale's main
KDE menu, Control Center, Find Files, Help, Home Directory's translation is
missing)
	- root does not work (50% of translations) (ie. same as after kpersonalize)


Another way (old KDE 2.1 config method)
	Procedure:
		rm -rf .kde*; startx; skip kpersonalize; set language and locale in kcontrol;
restart;
	Results:
	- translation shows on all user (100%) (root and normal)

Seems there are something for lang & locale that kcontrol does but kpersonalize
doesn't.

Looking at the kcontrol methods, kpersonalize methods, and patch while waiting
the sync for latest build.
Comment 13 Bill Nottingham 2001-09-05 23:21:41 EDT
However, in the case where I blow away the .kde* directories, I see a hang next
startx on nspluginscan. Odd.
Comment 14 Bill Nottingham 2001-09-05 23:23:06 EDT
I see this hang for a freshly installed user too. Full install.
Comment 15 Bill Nottingham 2001-09-05 23:25:20 EDT
Removing plugger fixes the nspluginscan hang.
Comment 16 Bernhard Rosenkraenzer 2001-09-06 02:39:32 EDT
notting: The nspluginscan problem (not a bug btw, itjust can't handle 
immensely broken plugins) should already be fixed in kdebase-2.2-11 from 
dist-7.2-HEAD (please verify).

llch: kpersonalizer does not make a difference between root and non-root 
users. Did your diff show up anything, or is it just like yesterday's?
Comment 17 Leon Ho 2001-09-06 02:58:47 EDT
Diffs are just simliar to yesterday. There are no related differences between
using kpersonalize and kcontrol configured.
Comment 18 Satoru SATOH 2001-09-06 05:53:06 EDT
kdebase-2.2.11 + re0905.2 still has the hang-up problem beause of nsplugin.
Comment 19 Leon Ho 2001-09-06 06:14:33 EDT
Installed re0905.2 and install kdebase-2.2-11 on the top

kdebase-2.2-11 still does not solve the problem of nspluginscan, have to delete
/etc/pluggerrc to make it go through (ie. mv /etc/pluggerrc{,.bak} )

Also the translations still having problem as I mention in last test for
kpersonalize and kcontrol.

Also looked at both sources and seem there aren't any different between those
two methods.
Comment 20 Satoru SATOH 2001-09-06 07:36:29 EDT
llch wrote:
> normal user kind of works after a restart (90% of translations), still have
> little part of menus that doesn't uses the translation (e.g. in JP locale's main
> KDE menu, Control Center, Find Files, Help, Home Directory's translation is
missing)


type `(cd /usr/share/applnk && touch *.desktop)` (as root), 
then "Control Center, Home, Help, Find ..." in K menu are localized.

How about the influence of the cache or anything related, of kicker, 
started up at 1st time in C(?) locale before "kpersonalization" ?
Comment 21 Bernhard Rosenkraenzer 2001-09-11 11:10:54 EDT
This is fixed in the current release.

Note You need to log in before you can comment on or make changes to this bug.