Bug 52951 - X messes display: Resetting FIFO
X messes display: Resetting FIFO
Status: CLOSED DUPLICATE of bug 18810
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-31 06:19 EDT by Matt Burke
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-05 08:25:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
X log (21.00 KB, text/plain)
2001-08-31 06:51 EDT, Matt Burke
no flags Details

  None (edit)
Description Matt Burke 2001-08-31 06:19:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.8 i686)

Description of problem:
Occasionally the X desktop will become corrupted - images/windows not
displaying, text appearing in the wrong place, scrolling displays text in
new (semi-random) position without removing old text.

When this happens, "Resetting FIFO" appears in the console output from
'startx'.

/var/log/XFree86.0.log contains:
Resetting FIFO
(II) Open APM successful


Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Power up machine (Dell Precision 220 / Dell Optiplex GX110, both using
onboard intel i810 graphics). This bug seems to be kernel-independant
occuring on both RedHat kernel and 2.4.8

2. Log in as root and ifconfig eth0/lo, add default gw

3. Log in as user and startx

4. Use and wait for it to occur!

5. When it occurs, the screen can be returned to normal by switching to a
console (ctrl-alt-f1) then switching back to x. My need to be repeated a
few times...

Additional info:

processes usually running:

gnome/enlightenment
identd
sshd
xinetd
gpm
crond
xfs
gnome-terminal
licq
xchat
asclock_applet
cpumemusage_applet
deskguide_applet
Comment 1 Matt Burke 2001-08-31 06:42:33 EDT
I'm a spanner.

I forgot to change the XF86Config-4 after changing from a machine with a Banshee
chip, so it's still using the tdfx driver.
Comment 2 Matt Burke 2001-08-31 06:51:18 EDT
Created attachment 30281 [details]
X log
Comment 3 Matt Burke 2001-08-31 06:53:10 EDT
Apologies; I appear to be a bit of a mess this morning - the card is actually a
Banshee.

lspci -vv output:

01:00.0 VGA compatible controller: 3Dfx Interactive, Inc. Voodoo Banshee (rev
03) (prog-if 00 [VGA])
	Subsystem: JOYTECH Computer Co., Ltd.: Unknown device 0009
	Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping-
SERR- FastB2B-
	Status: Cap+ 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort-
<MAbort- >SERR- <PERR-
	Interrupt: pin A routed to IRQ 9
	Region 0: Memory at f8000000 (32-bit, non-prefetchable) [size=32M]
	Region 1: Memory at f4000000 (32-bit, prefetchable) [size=32M]
	Region 2: I/O ports at ec00 [size=256]
	Expansion ROM at 80000000 [disabled] [size=64K]
	Capabilities: [54] AGP version 1.0
		Status: RQ=7 SBA+ 64bit+ FW- Rate=x1
		Command: RQ=0 SBA- AGP- 64bit- FW- Rate=<none>
	Capabilities: [60] Power Management version 1
		Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 PME-Enable- DSel=0 DScale=0 PME-
Comment 4 Mike A. Harris 2001-09-22 08:44:23 EDT
Changing component from XFree86-Servers-3.3.6 to XFree86.

Upgrade your beta to the current Rawhide X, Mesa, and any other
packages that those are dependant on.  Also, use the Red Hat kernel
if encountering any problems.  This is important for DRI.

Also, you have a choice to make - either disable DRI completely by
commenting out the Load line in the config file, or else lower your
maximum resolution down to 1024x768.  You cannot use DRI on a 16Mb
card with 1600x1200 resolution.

Please also attach your config file, and also the output of:
uname -a
Comment 5 Mike A. Harris 2001-11-05 08:25:34 EST
Please attach the requested information.  Thanks.
Comment 6 Mike A. Harris 2002-02-03 09:03:17 EST
Banshee video corruption issues were due to RAM timing being set
incorrectly.  This problem has been long since fixed now.  If you
still have this problem, please upgrade to the latest official updated
packages that have been released for the version of Red hat Linux that
you are currently using.

Thanks.

*** This bug has been marked as a duplicate of 18810 ***

Note You need to log in before you can comment on or make changes to this bug.