Bug 529551 - out of disk space
Summary: out of disk space
Keywords:
Status: CLOSED DUPLICATE of bug 510970
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: anaconda_trace_hash:c4c94e6acf7845fb2...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-18 14:28 UTC by khopper
Modified: 2009-10-21 16:15 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-21 16:15:44 UTC


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (181.86 KB, text/plain)
2009-10-18 14:28 UTC, khopper
no flags Details

Description khopper 2009-10-18 14:28:12 UTC
The following was filed automatically by anaconda:
anaconda 11.5.0.59 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/yuminstall.py", line 767, in run
    self.anaconda.id.storage.fsset.unmountFilesystems(self.anaconda.rootPath)
  File "/usr/lib/anaconda/yuminstall.py", line 1572, in doInstall
    rc = self.ayum.run(self.instLog, cb, anaconda.intf, anaconda.id)
  File "/usr/lib/anaconda/backend.py", line 288, in doInstall
    return anaconda.backend.doInstall(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1339, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 79, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 1360, in handleRenderCallback
    self.currentWindow.renderCallback()
AttributeError: 'FSSet' object has no attribute 'unmountFilesystems'

Comment 1 khopper 2009-10-18 14:28:21 UTC
Created attachment 365164 [details]
Attached traceback automatically from anaconda.

Comment 2 Jerry Vonau 2009-10-18 22:09:06 UTC
This looks to be a dup of 510970.
 
id.backend._loopbackFile: /mnt/sysimage/boot/rhinstall-install.img

So how are people suppose to upgrade with anaconda when their /boot partitions were made by a previous install are smaller that what is required now.

Comment 3 David Lehman 2009-10-21 16:15:44 UTC
It's probably time to resize some partitions or bite the bullet and do a new install.

*** This bug has been marked as a duplicate of bug 510970 ***


Note You need to log in before you can comment on or make changes to this bug.