Bug 529657 - virt-manager accidentally showing tabs in VM details
virt-manager accidentally showing tabs in VM details
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
: 533532 (view as bug list)
Depends On:
Blocks: F12VirtTarget
  Show dependency treegraph
 
Reported: 2009-10-19 07:26 EDT by Michael Monreal
Modified: 2009-12-03 18:50 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-03 18:50:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Monreal 2009-10-19 07:26:28 EDT
In a VM window, the first two buttons of the toolbar just switch between the two available tabs. This looks like a pointless duplication to me... the tabs only take away useful vertical screen space and don't provide any added functionality.

On the other hand, the tabs could be useful for people who turn the toolbar off.

IMHO there should be some option for showing tabs independantly of the toolbar, defaulting to not showing the tabs.
Comment 1 Cole Robinson 2009-10-19 10:13:36 EDT
The tabs aren't supposed to be showing. Can you provide a screenshot of what you are seeing?

Are you using any special desktop settings that might affect this? Another user reported the same thing, but I don't see the same on my box. There must be a switch somewhere that effects this.

Do you see tabbed views in the 'New VM' wizard or 'Add Hardware' wizard?
Comment 2 Michael Monreal 2009-10-19 10:29:41 EDT
> The tabs aren't supposed to be showing.

:D

Well, I was amazed to see the tabs gone today... but I found a way to get them back ;) simply toggle fullscreen and then go back to normal and the tabs appear.
Comment 3 Cole Robinson 2009-10-19 10:48:02 EDT
Ahh, good call! I can reproduce now.
Comment 4 Cole Robinson 2009-10-21 10:19:22 EDT
Fixed upstream:

http://hg.fedorahosted.org/hg/virt-manager/rev/42adf97a009a
Comment 5 Mark McLoughlin 2009-10-29 12:29:47 EDT
Looks trivial to backport, so adding to F12VirtTarget
Comment 6 Cole Robinson 2009-11-16 13:52:23 EST
*** Bug 533532 has been marked as a duplicate of this bug. ***
Comment 7 Cole Robinson 2009-12-03 18:50:52 EST
This should be fixed in virt-manager-0.8.1-1.fc13 which will be in the next rawhide compose.

Note You need to log in before you can comment on or make changes to this bug.