Bug 529745 - Loading modules from a script fails with environment-modules >3.6.8
Loading modules from a script fails with environment-modules >3.6.8
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: environment-modules (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-19 15:28 EDT by Deji Akingunola
Modified: 2009-11-10 12:49 EST (History)
1 user (show)

See Also:
Fixed In Version: 3.2.7b-5.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-10 12:49:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Deji Akingunola 2009-10-19 15:28:00 EDT
Description of problem: Loading modules during a rpm build process fails with the error below;
...
+ . /etc/profile.d/modules.sh
++ export -f module
++ MODULESHOME=/usr/share/Modules
++ export MODULESHOME
++ '[' '' = '' ']'
++ LOADEDMODULES=
++ export LOADEDMODULES
++ '[' /usr/share/Modules/modulefiles:/etc/modulefiles = '' ']'
++ '[' 4 -ge 3 ']'
++ '[' -r /usr/share/Modules/init/bash_completion ']'
++ . /usr/share/Modules/init/bash_completion
/usr/share/Modules/init/bash_completion: line 14: syntax error near unexpected token `('
...

This happens with all environment-modules builds >= ver 3.7.1, downgrading to 
environment-modules-3.2.6-8.fc12.x86_64 works.

Version-Release number of selected component (if applicable):environment-modules-3.2.7b-2.fc12.x86_64


How reproducible: always


Steps to Reproduce:
1. try to rebuild the blacs srpm for instance.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Deji Akingunola 2009-10-25 17:47:44 EDT
Although environment-modules-3.2.7b-4.fc12 fixed this particular issue, it caused another (Bug 530770). I'll leave this open until the other issue is resolved.
Comment 2 Fedora Update System 2009-10-27 02:29:07 EDT
environment-modules-3.2.7b-5.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update environment-modules'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10725
Comment 3 Fedora Update System 2009-11-10 12:49:38 EST
environment-modules-3.2.7b-5.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.