Bug 530770 - environment-modules.i686 0:3.2.7b-4.fc12 breaks (at least) gdm
environment-modules.i686 0:3.2.7b-4.fc12 breaks (at least) gdm
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: environment-modules (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
: 530967 531195 (view as bug list)
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-10-24 17:31 EDT by Bruno Wolff III
Modified: 2009-11-10 12:49 EST (History)
5 users (show)

See Also:
Fixed In Version: 3.2.7b-5.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-26 13:53:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2009-10-24 17:31:24 EDT
Description of problem:
After updating to the 10-24 rawhide, gdm wasn't starting. I eventually found that running the environment-modules script in /etc/profile.d was killing the gdm script. Uninstalling environment-modules got things working again.

Version-Release number of selected component (if applicable):
environment-modules.i686 0:3.2.7b-4.fc12

How reproducible:
I don't know if there are any dependencies on /etc/profile which I changed a while back to put sbin in normal users' paths. (That wouldn't excuse environment-modules, but could potentially be needed to reproduce the problem.)

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Deji Akingunola 2009-10-25 15:54:03 EDT
Me too :). environment-modules-3.2.7b-4.fc12 was supposed to fix Bug 529745 (which it did), but with a rather huge negative impact.
Comment 2 Orion Poplawski 2009-10-26 12:14:45 EDT
So, any idea what the actual problem is?  This is my thought for a fix, but I'm not sure what the real cause is.

shell=`/bin/basename \`/bin/ps -p $$ -ocomm=\``
[ -f /usr/share/Modules/init/$shell ] &&
  . /usr/share/Modules/init/$shell
Comment 3 Orion Poplawski 2009-10-26 12:50:44 EDT
Ah, interesting, /usr/sbin/gdm is a script and it sources the profile.d directory.  Here is my suggested fix:

shell=`/bin/basename \`/bin/ps -p $$ -ocomm=\``
if [ -f /usr/share/Modules/init/$shell ]
then
  . /usr/share/Modules/init/$shell
else
  . /usr/share/Modules/init/sh
fi
Comment 4 Bruno Wolff III 2009-10-26 12:58:21 EDT
I didn't try to figure out what actually broke things. I was just happy I figured out which package broke graphical logins.
Comment 5 Bruno Wolff III 2009-10-26 13:06:13 EDT
I see there is a new build. I'll report back in a few minutes whether or not it solved the problem I was seeing.
Comment 6 Fedora Update System 2009-10-26 13:33:20 EDT
environment-modules-3.2.7b-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/environment-modules-3.2.7b-5.fc11
Comment 7 Bruno Wolff III 2009-10-26 13:36:41 EDT
environment-modules-3.2.7b-5.fc12.x86_64 fixed the problem with gdm.
Comment 8 James 2009-10-26 16:22:03 EDT
*** Bug 530967 has been marked as a duplicate of this bug. ***
Comment 9 Ray Strode [halfline] 2009-10-29 13:29:42 EDT
*** Bug 531195 has been marked as a duplicate of this bug. ***
Comment 10 Fedora Update System 2009-11-10 12:49:28 EST
environment-modules-3.2.7b-5.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.