Bug 529960 - Installing package A shows A as a dependancy of A
Installing package A shows A as a dependancy of A
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
: 532072 (view as bug list)
Depends On:
Blocks: F12Target
  Show dependency treegraph
 
Reported: 2009-10-20 18:03 EDT by Michael Monreal
Modified: 2010-03-23 06:48 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-23 06:48:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (39.78 KB, image/png)
2009-10-20 18:03 EDT, Michael Monreal
no flags Details
proposed fix for 2.28.1 (1.22 KB, patch)
2009-10-26 04:20 EDT, Arenas Belon, Carlo Marcelo
no flags Details | Diff

  None (edit)
Description Michael Monreal 2009-10-20 18:03:32 EDT
Created attachment 365437 [details]
Screenshot

Install a package without dependancy. After hitting apply you will get a confirmation window, telling you that you need to install $packagename as a dependancy for $packagename. This is bogus of course :)

Tested with gnome-packagekit-2.28.1-1.fc12.i686
Comment 1 Arenas Belon, Carlo Marcelo 2009-10-26 04:20:48 EDT
Created attachment 366071 [details]
proposed fix for 2.28.1

to validate, apply patch to fedora rawhide/fc12beta and using gpk-application install mutrace.

expected results :

* package will be installed with no additional questions (except probably missing key)

current results:

* a dialog informing that mutrace is additionally needed will need to be accepted before installation could proceed
Comment 2 Matthias Clasen 2009-10-26 11:39:30 EDT
Looks like an easy fix. I'll ask Richard to look at this when he is back.
Comment 3 Richard Hughes 2009-10-29 06:54:20 EDT
Please can you try the build of gnome-packagekit here: http://koji.fedoraproject.org/koji/taskinfo?taskID=1776154

You will need to log off and back on to ensure the gpk-update-icon process has been restarted. Please provide feedback to whether this build fixes this bug. Thanks.

Richard.
Comment 4 Michael Monreal 2009-10-29 13:10:39 EDT
This seems to fix the problem, thanks!
Comment 5 Matthias Clasen 2009-10-31 00:30:39 EDT
*** Bug 532072 has been marked as a duplicate of this bug. ***
Comment 6 Matthias Clasen 2009-10-31 00:31:21 EDT
Tag has been requested.
Comment 7 Bug Zapper 2010-03-15 08:57:26 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.