Bug 530318 - Duplicate Screensaver Entries in GNOME Menu
Duplicate Screensaver Entries in GNOME Menu
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
13
All Linux
low Severity low
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
: 541235 597620 642343 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-22 06:18 EDT by Daniel Qarras
Modified: 2015-01-14 18:23 EST (History)
10 users (show)

See Also:
Fixed In Version: gnome-screensaver-2.30.0-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-15 08:39:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Working file from F11. (403 bytes, text/plain)
2010-06-18 14:02 EDT, Jason Cross
no flags Details

  None (edit)
Description Daniel Qarras 2009-10-22 06:18:23 EDT
Description of problem:
After installing Fedora 12 Beta I see two Screensaver entires under System->Preferences. Apparently one is for GNOME screensaver and one for X screensavers. However, for an ordinary user this is confusing especially when X screensavers ask something about starting/stopping services.

Ideally these should be combined in one or at least renamed - having two identical entries look like a bug.

Version-Release number of selected component (if applicable):
xscreensaver-gl-extras-5.10-2.fc12.i686
gnome-screensaver-2.28.0-1.fc12.i686
fedora-screensaver-theme-1.0.0-5.fc12.noarch
xscreensaver-base-5.10-2.fc12.i686
xscreensaver-gl-base-5.10-2.fc12.i686

How reproducible:
Always.

Steps to Reproduce:
1. Install the packages mentioned above
2. See System->Preferences
  
Actual results:
Duplicate Screensaver entry

Expected results:
Single Screensaver entry

Additional info:
Comment 1 Mamoru TASAKA 2009-10-22 07:17:07 EDT
gnome-screensaver should take care of this.

It seems that gnome-screensaver-hide-xscreensaver.menu should
be changed: Now xscreensaver-base has 
/usr/share/applications/xscreensaver-properties.desktop (note
that I have not gnome-screensaver installed).
Comment 2 Bug Zapper 2009-11-16 09:02:18 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Mamoru TASAKA 2009-11-25 06:01:36 EST
*** Bug 541235 has been marked as a duplicate of this bug. ***
Comment 4 Kyle VanderBeek 2010-04-13 03:11:56 EDT
I too got the extra icon in the System -> Preferences menu after I installed some of the -extras packages:

[kylev@freebie ~]$ rpm -qa | grep xscreensaver
xscreensaver-extras-gss-5.10-6.1.fc12.1.x86_64
xscreensaver-base-5.10-6.1.fc12.1.x86_64
xscreensaver-gl-extras-5.10-6.1.fc12.1.x86_64
xscreensaver-gl-base-5.10-6.1.fc12.1.x86_64
xscreensaver-extras-5.10-6.1.fc12.1.x86_64
xscreensaver-gl-extras-gss-5.10-6.1.fc12.1.x86_64
Comment 5 Daniel Qarras 2010-04-21 12:37:30 EDT
This is still an issue with F13ß: when one just installs xscreensaver-base after the default Fedora installation, the two Screensaver entries are present in the menu.
Comment 6 Mamoru TASAKA 2010-05-29 22:10:50 EDT
*** Bug 597620 has been marked as a duplicate of this bug. ***
Comment 7 Jason Cross 2010-06-18 14:02:18 EDT
Created attachment 425206 [details]
Working file from F11.
Comment 8 Jason Cross 2010-06-18 14:09:06 EDT
An undocumented change to this file seems to be the problem:
/etc/xdg/menus/preferences-post-merged/gnome-screensaver-hide-xscreensaver.menu

According to the changelog for gnome-screensaver, this fix was added awhile ago:
* Fri Sep 21 2007 Ray Strode <rstrode@redhat.com> - 2.20.0-3
- hide xscreensaver menu if gnome-screensaver is installed
  (bug 300401)

The behavior was correct for me in Fedora 11 with gnome-screensaver-2.26.1-3.fc11.x86_64

Using the /etc/xdg/menus/preferences-post-merged/gnome-screensaver-hide-xscreensaver.menu provided by that package in F13 fixed the problem for me.

From looking at the srpm for gnome-screensaver, that file is provided by fedora and not from upstream.  I attached the working file to this bug (Working file from F11.)

The change doesn't seem to be documented since I can't find any mention of it in the package changelog since it worked in version 2.26.1-3.
Comment 9 Mamoru TASAKA 2010-10-12 13:44:23 EDT
*** Bug 642343 has been marked as a duplicate of this bug. ***
Comment 10 Fedora Update System 2010-10-13 07:38:43 EDT
gnome-screensaver-2.30.0-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/gnome-screensaver-2.30.0-2.fc13
Comment 11 Fedora Update System 2010-10-13 07:38:50 EDT
gnome-screensaver-2.30.2-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/gnome-screensaver-2.30.2-2.fc14
Comment 12 Thomas Spear 2010-10-13 11:11:15 EDT
To be completely honest, I've removed gnome-screensaver and been using xscreensaver since this bug hit me; I actaully prefer xscreensaver, and would rather xscreensaver hide gnome-screensaver, rather than the other way around... Just saying.
Comment 13 Fedora Update System 2010-10-13 17:21:06 EDT
gnome-screensaver-2.30.2-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-screensaver'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/gnome-screensaver-2.30.2-2.fc14
Comment 14 Fedora Update System 2010-10-15 08:39:17 EDT
gnome-screensaver-2.30.2-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2010-10-19 03:02:40 EDT
gnome-screensaver-2.30.0-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.