This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 530450 - duplicate .desktop file for eclipse
duplicate .desktop file for eclipse
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
12
All Linux
low Severity high
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
: 531179 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-22 16:37 EDT by James Cassell
Modified: 2009-11-23 07:41 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-23 07:41:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James Cassell 2009-10-22 16:37:34 EDT
Description of problem:
When eclipse is installed on Fedora 12 (currently rawhide,) two eclipse icons are shown in "Applications -> Programming"

Version-Release number of selected component (if applicable):
eclipse-platform-3.5.1-1.fc12.x86_64

How reproducible:
100%

Steps to Reproduce:
1. install eclipse
2. go to open eclipse from Applications->Programming
3. be confused as to which you should pick
  
Actual results:
There are two Eclipse links in Applications->Programming

Expected results:
there should be only one link to Eclipse from Applications->Programming


Additional info:
[root@localhost ~]# rpm -ql eclipse-platform|grep .desktop
/usr/share/applications/eclipse.desktop
/usr/share/applications/fedora-eclipse.desktop

this isn't so much of a functional problem as much as it is a user confusion problem  (I certainly was confused)
Comment 1 Alexander Kurtakov 2009-10-23 06:58:18 EDT
Thanks for the report. It is fixed in rawhide. I don't consider this critical enough for requesting releng to tag new build and I would also like to add some ppc64 fixes which are not quite ready yet. 
So this will be pushed as an update once Fedora 12 is out.
Comment 2 Alexander Kurtakov 2009-10-27 04:14:10 EDT
*** Bug 531179 has been marked as a duplicate of this bug. ***
Comment 3 Bug Zapper 2009-11-16 09:05:11 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Alexander Kurtakov 2009-11-23 07:41:06 EST
Fixed in eclipse-platform-1:3.5.1-4.fc12.i686.rpm

Note You need to log in before you can comment on or make changes to this bug.