Bug 53054 - ntp: permission denied on /etc/ntp/drift.TEMP
Summary: ntp: permission denied on /etc/ntp/drift.TEMP
Status: CLOSED DUPLICATE of bug 52763
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: ntp   
(Show other bugs)
Version: roswell
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-02 20:10 UTC by Need Real Name
Modified: 2007-04-18 16:36 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-03 17:43:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-09-02 20:10:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010803

Description of problem:
After the most recent release of Roswell updates, bringing ntp to
ntp-4.0.99mrc2-5, ntp generates errors hourly about a permission problem.

Version-Release number of selected component (if applicable):
ntp-4.0.99mrc2-5

How reproducible:
Always

Steps to Reproduce:
1.Upgrade ntp-4.0.99mrc2-2 to ntp-4.0.99mrc2-5
2.
3.
	

Actual Results:  ntp restarts after the upgrade, having added a new user
and group to the system (ntp). The file ntp.TEMP wasn't created by the
installer.
Every hour, ntp attempts, and fails,to write to /etc/ntp/drift.TEMP
Creating that file with owner and group ntp and permissions of 755 or 775
doesn't solve the problem. There is also a log entry saying ntpd: logging
to file p. That seems odd as well. See below.

Expected Results:  ntp should have permission to write to the necessary files.

Additional info:

From the logs:

Sep  1 21:57:59 roswell ntpd: ntpd startup succeeded
Sep  1 21:57:59 roswell ntpd[4499]: ntpd 4.0.99m-rc2 Wed Aug 29 05:17:21
EDT 2001 (1)
Sep  1 21:58:00 roswell ntpd[4499]: precision = 7 usec
Sep  1 21:58:00 roswell ntpd[4499]: kernel time discipline status 0040
Sep  1 21:58:00 roswell ntpd[4499]: frequency initialized -236.105 from
/etc/ntp/drift

Sep  1 22:01:29 roswell ntpd[4499]: kernel time discipline status change 41
Sep  1 22:35:56 roswell ntpd: logging to file p
Sep  1 22:57:59 roswell ntpd[4499]: can't open /etc/ntp/drift.TEMP:
Permission denied

These errors repeat hourly.

The output of ps aux shows a numeric uid for the ntpd process as well. I'd
expected it to show it as ntp, based on the command line.

[root@roswell etc]# ps aux | grep ntp
134767660 4499  0.0  1.9  2012 2004 ?        SL   Sep01   0:00 ntpd -U ntp
root     22957  0.0  0.5  1700  580 pts/0    S    16:11   0:00 grep ntp

Comment 1 Need Real Name 2001-09-03 01:11:44 UTC
This line:
The file ntp.TEMP wasn't created by the
installer.
Should read The file drift.TEMP wasn't created....

Comment 2 Harald Hoyer 2001-09-03 09:38:08 UTC
fixed in 4.1.0-2


Comment 3 Harald Hoyer 2001-09-03 17:44:34 UTC

*** This bug has been marked as a duplicate of 52763 ***


Note You need to log in before you can comment on or make changes to this bug.