Bug 530669 - Fails to activate connection when IPv6 is set to "automatic" and kernel hasn't already configured an address
Fails to activate connection when IPv6 is set to "automatic" and kernel hasn'...
Status: CLOSED DUPLICATE of bug 538499
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks: IPv6Blocker
  Show dependency treegraph
 
Reported: 2009-10-23 22:09 EDT by Tore Anderson
Modified: 2010-04-23 17:49 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-23 17:49:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tore Anderson 2009-10-23 22:09:08 EDT
Description of problem:

If the IPv6 method is set to "automatic", and there's no already configured address on the interface (done by the kernel), the connection fails to activate (even for IPv4).

Version-Release number of selected component (if applicable):

Fedora 12 beta, NetworkManager 0.7.996-4.git20091002.fc12.i686

How reproducible:

100%

Steps to Reproduce:
1. Set up a network with IPv4 DHCP service and IPv6 SLAAC service (I used standard F11 virt-manager, adding an IPv6 address to virbr0 manually afterwards and starting radvd on that interface)
2. Install F12 beta and change the IPv6 method in the connection editor for system eth0 from "ignore" to "automatic" and save/exit (disappointing default by the way).  Due to bug #523288 you'll need to untick "available for all users" for this to take effect.  At this point you should already have an (non-link-local) IPv6 address configured on eth0 by the kernel.
3. Attempt to reconnect to the network by clicking on the network-manager icon and then "system eth0" in the list.
  
Actual results:

NM fails to connect to the network, leaving it as "disconnected" with no IPv6 or IPv4 addresses (except a link-local IPv6 one).  A tcpdump on the KVM host machine reveals that the guest does send out a DHCP request (and receive a reply), but no ICMPv6 router solicitations appear.

Expected results:

NM should have correctly configured the network with a IPv6 address from SLAAC and a IPv4 one from DHCP.

Additional info:

If the kernel has already auto-configured an IPv4 address on the interface, the connection is established like expected.  You can force that to happen with the commands "ip link set dev eth0 down; ip link set dev eth0 up".
Comment 1 Bug Zapper 2009-11-16 09:09:16 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Dan Williams 2010-04-23 17:49:13 EDT

*** This bug has been marked as a duplicate of bug 538499 ***

Note You need to log in before you can comment on or make changes to this bug.