Bug 530670 - NM does not add IPv6 nameservers learned from SLAAC to resolv.conf
NM does not add IPv6 nameservers learned from SLAAC to resolv.conf
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks: IPv6Blocker
  Show dependency treegraph
 
Reported: 2009-10-23 22:31 EDT by Tore Anderson
Modified: 2010-06-10 15:07 EDT (History)
3 users (show)

See Also:
Fixed In Version: NetworkManager-0.8.1-0.1.git20100510.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-04 19:50:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tore Anderson 2009-10-23 22:31:06 EDT
Description of problem:

Router advertisements might contain attributes containing information about what recursive DNS resolvers are to be used (see RFC 5006).  However, NM doesn't add these to /etc/resolv.conf so the

Version-Release number of selected component (if applicable):

Fedora 12 beta, NetworkManager 0.7.996-4.git20091002.fc12.i686

How reproducible:

100%

Steps to Reproduce:
1. Install F12 beta on a IPv6-enabled network where the router advertisements contains RDNSS attributes (radvd can do this).  Change the IPv6 method setting to automatic.
2. Reboot, or re-init the network connection.
  
Actual results:

The /etc/resolv.conf file contains only IPv4 nameserver(s) or no nameservers, depending on the IPv4 environment.

Expected results:

The IPv6 nameservers contained in the router advertisements are added to the resolv.conf file (along with IPv4 nameservers, if any).

Additional info:
Comment 1 Bug Zapper 2009-11-16 09:09:22 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Tore Anderson 2009-11-18 11:30:01 EST
I've been testing a bit more.  Sometimes, but not always, is the RDNSS-announced nameservers added to the resolv.conf file.  I have not yet found out what exactly happens when it works and what happens when it don't...

Tore
Comment 3 Tore Anderson 2009-11-18 11:47:51 EST
I think I've nailed it.  If the kernel is performing SLAAC at the same time as NM is activating an interface, and NM has the IPv6 mode set to "automatic", the IPv6 nameservers are added to /etc/resolv.conf.  If you then disconnect from the network and reconnect, the connection fails completely (because the SLAAC address is removed by NM as the connection is taken down, see bug #530669 - that bug seems very closely related to this one).  You can however work around this by forcing the kernel to re-do SLAAC ("ip link set dev wlan0 down; ip link set dev wlan0 up" while NM is disconnected does the trick for me).

However, if you first connected to the network using IPv6 mode "ignore", then disconnect, change to "automatic" and then reconnect, it will successfully reconnect but _NOT_ add the IPv6 nameservers to /etc/resolv.conf.  I assume this is because when NM is in "ignore" mode it will not remove the SLAAC-configured address when it's disconnecing, so when it reconnects with mode automatic, the already-configured address is enough to make the "automatic" mode not fail, but since SLAAC isn't performed at that point, NM does't pick up the nameservers.

It seems like the kernel will only perform SLAAC automatically when the interface looses its NO-CARRIER flag for the first time after having been set to UP.  So one workaround would be for NM to down/up the interface when it's disconnecting/reconnecting, or to somehow explicitly tell the kernel to perform SLAAC again when it's reconnecting.

Tore
Comment 4 Dan Williams 2010-02-08 20:49:14 EST
Thanks for the analysis, I'll dig into this more and see what we can do to make this work better.
Comment 5 Fedora Update System 2010-04-27 03:55:43 EDT
NetworkManager-0.8.0-8.git20100426.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-8.git20100426.fc13
Comment 6 Fedora Update System 2010-04-27 03:57:04 EDT
NetworkManager-0.8.0-8.git20100426.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-8.git20100426.fc12
Comment 7 Fedora Update System 2010-04-27 21:15:22 EDT
NetworkManager-0.8.0-8.git20100426.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-8.git20100426.fc13
Comment 8 Fedora Update System 2010-04-27 21:20:08 EDT
NetworkManager-0.8.0-8.git20100426.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-8.git20100426.fc12
Comment 9 Fedora Update System 2010-04-30 19:49:28 EDT
NetworkManager-0.8.0-9.git20100429.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-9.git20100429.fc13
Comment 10 Scott Schmit 2010-05-02 18:29:18 EDT
This appears to be 99.99% fixed by NetworkManager-0.8.0-10.git20100502.fc12.x86_64. During my testing, I only once saw NM not add my RDNSS configuration to /etc/resolv.conf. Every other time, it's worked.
Comment 12 Fedora Update System 2010-05-04 02:12:31 EDT
NetworkManager-0.8.0-11.git20100503.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-11.git20100503.fc13
Comment 13 Fedora Update System 2010-05-04 02:14:24 EDT
NetworkManager-0.8.0-11.git20100503.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-11.git20100503.fc12
Comment 14 Fedora Update System 2010-05-04 19:49:54 EDT
NetworkManager-0.8.0-11.git20100503.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2010-05-05 05:15:33 EDT
NetworkManager-0.8.0-12.git20100504.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-12.git20100504.fc13
Comment 16 Fedora Update System 2010-05-05 05:18:18 EDT
NetworkManager-0.8.0-12.git20100504.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-12.git20100504.fc12
Comment 17 Fedora Update System 2010-05-06 03:01:05 EDT
NetworkManager-0.8.0-12.git20100504.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2010-05-11 02:54:07 EDT
NetworkManager-0.8.1-0.1.git20100510.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/NetworkManager-0.8.1-0.1.git20100510.fc12
Comment 19 Fedora Update System 2010-06-10 15:05:41 EDT
NetworkManager-0.8.1-0.1.git20100510.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.