Bug 530764 - 3G connection always fails after disconnect
Summary: 3G connection always fails after disconnect
Keywords:
Status: CLOSED DUPLICATE of bug 541314
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-24 19:50 UTC by Paul Flinders
Modified: 2009-12-01 09:02 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-01 09:02:05 UTC
Type: ---


Attachments (Terms of Use)

Description Paul Flinders 2009-10-24 19:50:15 UTC
Description of problem:
In a clean install of Fedora12 Beta I'm trying to set up a 3G modem (A Huawei E160 using the UK provider T-Mobile). One thing that I've noticed is that if I connect using the gnome panel applet, then disconnect I can't connect again until I've removed the dongle and plugged it back in again. This doesn't happen under the Windows application that T-Mobile supply with the dongle.

Version-Release number of selected component (if applicable):
etworkManager-pptp-0.7.996-4.git20090921.fc12.i686
NetworkManager-glib-0.7.996-5.git20091021.fc12.i686
NetworkManager-vpnc-0.7.996-4.git20090921.fc12.i686
NetworkManager-0.7.996-5.git20091021.fc12.i686
NetworkManager-gnome-0.7.996-5.git20091021.fc12.i686
NetworkManager-openvpn-0.7.996-4.git20090923.fc12.i686


How reproducible:


Steps to Reproduce:
1. Connect to prvider
2. Disconnect
3. Try to connect again
  
Actual results:
First time the ppp link is brought up (doesn't work but that will be a separate bug report when I've got a bit more info), subsequently connection fails.

Expected results:
Repeated connections should work without having to physically unplug the dongle.

Additional info:

Syslog from insertion through initial connection and disconnection
Oct 24 21:27:55 jaffa-cake kernel: usb 1-3: new high speed USB device using ehci_hcd and address 5
Oct 24 21:27:55 jaffa-cake kernel: usb 1-3: New USB device found, idVendor=12d1, idProduct=1003
Oct 24 21:27:55 jaffa-cake kernel: usb 1-3: New USB device strings: Mfr=2, Product=1, SerialNumber=0
Oct 24 21:27:55 jaffa-cake kernel: usb 1-3: Product: HUAWEI Mobile
Oct 24 21:27:55 jaffa-cake kernel: usb 1-3: Manufacturer: HUAWEI Technology
Oct 24 21:27:55 jaffa-cake kernel: usb 1-3: configuration #1 chosen from 1 choice
Oct 24 21:27:55 jaffa-cake kernel: scsi6 : SCSI emulation for USB Mass Storage devices
Oct 24 21:27:55 jaffa-cake kernel: usb 1-3: USB disconnect, address 5
Oct 24 21:28:02 jaffa-cake kernel: usb 1-3: new high speed USB device using ehci_hcd and address 6
Oct 24 21:28:02 jaffa-cake kernel: usb 1-3: New USB device found, idVendor=12d1, idProduct=1003
Oct 24 21:28:02 jaffa-cake kernel: usb 1-3: New USB device strings: Mfr=2, Product=1, SerialNumber=0
Oct 24 21:28:02 jaffa-cake kernel: usb 1-3: Product: HUAWEI Mobile
Oct 24 21:28:02 jaffa-cake kernel: usb 1-3: Manufacturer: HUAWEI Technology
Oct 24 21:28:02 jaffa-cake kernel: usb 1-3: configuration #1 chosen from 1 choice
Oct 24 21:28:02 jaffa-cake kernel: option 1-3:1.0: GSM modem (1-port) converter detected
Oct 24 21:28:02 jaffa-cake kernel: usb 1-3: GSM modem (1-port) converter now attached to ttyUSB0
Oct 24 21:28:02 jaffa-cake kernel: option 1-3:1.1: GSM modem (1-port) converter detected
Oct 24 21:28:02 jaffa-cake kernel: usb 1-3: GSM modem (1-port) converter now attached to ttyUSB1
Oct 24 21:28:02 jaffa-cake kernel: scsi9 : SCSI emulation for USB Mass Storage devices
Oct 24 21:28:02 jaffa-cake kernel: scsi10 : SCSI emulation for USB Mass Storage devices
Oct 24 21:28:02 jaffa-cake modem-manager: (ttyUSB0) opening serial device...


Oct 24 21:28:07 jaffa-cake kernel: scsi 9:0:0:0: CD-ROM            HUAWEI   Mass Storage     2.31 PQ: 0 ANSI: 2
Oct 24 21:28:07 jaffa-cake kernel: scsi 10:0:0:0: Direct-Access     HUAWEI   MMC Storage      2.31 PQ: 0 ANSI: 2
Oct 24 21:28:07 jaffa-cake kernel: sr1: scsi-1 drive
Oct 24 21:28:07 jaffa-cake kernel: sr 9:0:0:0: Attached scsi generic sg2 type 5
Oct 24 21:28:07 jaffa-cake kernel: sd 10:0:0:0: Attached scsi generic sg3 type 0
Oct 24 21:28:08 jaffa-cake kernel: sd 10:0:0:0: [sdb] Attached SCSI removable disk
Oct 24 21:28:15 jaffa-cake modem-manager: (ttyUSB0) closing serial device...
Oct 24 21:28:15 jaffa-cake modem-manager: (Huawei): GSM modem /sys/devices/pci0000:00/0000:00:1d.7/usb1/1-3 claimed port ttyUSB0
Oct 24 21:28:15 jaffa-cake NetworkManager: <info>  (ttyUSB0): new GSM device (driver: 'option1')
Oct 24 21:28:15 jaffa-cake NetworkManager: <info>  (ttyUSB0): exported as /org/freedesktop/NetworkManager/Devices/3
Oct 24 21:28:15 jaffa-cake NetworkManager: <info>  (ttyUSB0): now managed
Oct 24 21:28:15 jaffa-cake NetworkManager: <info>  (ttyUSB0): device state change: 1 -> 2 (reason 2)
Oct 24 21:28:15 jaffa-cake NetworkManager: <info>  (ttyUSB0): deactivating device (reason: 2).
Oct 24 21:28:15 jaffa-cake NetworkManager: flush_routes: assertion `iface_idx >= 0' failed
Oct 24 21:28:15 jaffa-cake NetworkManager: flush_addresses: assertion `iface_idx >= 0' failed
Oct 24 21:28:15 jaffa-cake NetworkManager: <info>  (ttyUSB0): device state change: 2 -> 3 (reason 0)
Oct 24 21:28:18 jaffa-cake modem-manager: (ttyUSB1) opening serial device...
Oct 24 21:28:18 jaffa-cake modem-manager: (ttyUSB1) closing serial device...
Oct 24 21:28:18 jaffa-cake modem-manager: (Huawei): GSM modem /sys/devices/pci0000:00/0000:00:1d.7/usb1/1-3 claimed port ttyUSB1
Oct 24 21:28:30 jaffa-cake NetworkManager: <info>  Activation (ttyUSB0) starting connection 'T-Mobile Default'
Oct 24 21:28:30 jaffa-cake NetworkManager: <info>  (ttyUSB0): device state change: 3 -> 4 (reason 0)
Oct 24 21:28:30 jaffa-cake NetworkManager: <info>  Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) scheduled...
Oct 24 21:28:30 jaffa-cake NetworkManager: <info>  Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) started...
Oct 24 21:28:30 jaffa-cake NetworkManager: <info>  (ttyUSB0): device state change: 4 -> 6 (reason 0)
Oct 24 21:28:30 jaffa-cake NetworkManager: <info>  Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) complete.
Oct 24 21:28:30 jaffa-cake NetworkManager: <info>  Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) scheduled...
Oct 24 21:28:30 jaffa-cake NetworkManager: <info>  Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) started...
Oct 24 21:28:30 jaffa-cake NetworkManager: <info>  (ttyUSB0): device state change: 6 -> 4 (reason 0)
Oct 24 21:28:30 jaffa-cake NetworkManager: <info>  Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) complete.
Oct 24 21:28:30 jaffa-cake modem-manager: (ttyUSB0) opening serial device...
Oct 24 21:28:44 jaffa-cake NetworkManager: <info>  Activation (ttyUSB0) Stage 2 of 5 (Device Configure) scheduled...
Oct 24 21:28:44 jaffa-cake NetworkManager: <info>  Activation (ttyUSB0) Stage 2 of 5 (Device Configure) starting...
Oct 24 21:28:44 jaffa-cake NetworkManager: <info>  (ttyUSB0): device state change: 4 -> 5 (reason 0)
Oct 24 21:28:44 jaffa-cake NetworkManager: <info>  Activation (ttyUSB0) Stage 2 of 5 (Device Configure) successful.
Oct 24 21:28:44 jaffa-cake NetworkManager: <info>  Activation (ttyUSB0) Stage 3 of 5 (IP Configure Start) scheduled.
Oct 24 21:28:44 jaffa-cake NetworkManager: <info>  Activation (ttyUSB0) Stage 2 of 5 (Device Configure) complete.
Oct 24 21:28:44 jaffa-cake NetworkManager: <info>  Activation (ttyUSB0) Stage 3 of 5 (IP Configure Start) started...
Oct 24 21:28:44 jaffa-cake NetworkManager: <info>  (ttyUSB0): device state change: 5 -> 7 (reason 0)
Oct 24 21:28:44 jaffa-cake NetworkManager: <info>  Starting pppd connection
Oct 24 21:28:44 jaffa-cake NetworkManager: <info>  Activation (ttyUSB0) Stage 4 of 5 (IP6 Configure Get) scheduled...
Oct 24 21:28:44 jaffa-cake NetworkManager: <info>  Activation (ttyUSB0) Stage 3 of 5 (IP Configure Start) complete.
Oct 24 21:28:44 jaffa-cake NetworkManager: <info>  Activation (ttyUSB0) Stage 4 of 5 (IP6 Configure Get) started...
Oct 24 21:28:44 jaffa-cake NetworkManager: <info>  Activation (ttyUSB0) Stage 4 of 5 (IP6 Configure Get) complete.
Oct 24 21:28:44 jaffa-cake pppd[2361]: Warning: can't open options file /root/.ppprc: Permission denied
Oct 24 21:28:44 jaffa-cake pppd[2361]: Plugin /usr/lib/pppd/2.4.4/nm-pppd-plugin.so loaded.
Oct 24 21:28:44 jaffa-cake pppd[2361]: pppd 2.4.4 started by root, uid 0
Oct 24 21:28:44 jaffa-cake pppd[2361]: Using interface ppp0
Oct 24 21:28:44 jaffa-cake pppd[2361]: Connect: ppp0 <--> /dev/ttyUSB0
Oct 24 21:28:44 jaffa-cake pppd[2361]: CHAP authentication succeeded
Oct 24 21:28:44 jaffa-cake pppd[2361]: CHAP authentication succeeded
Oct 24 21:28:52 jaffa-cake pppd[2361]: Could not determine remote IP address: defaulting to 10.64.64.64
Oct 24 21:28:52 jaffa-cake pppd[2361]: local  IP address 10.214.218.9
Oct 24 21:28:52 jaffa-cake pppd[2361]: remote IP address 10.64.64.64
Oct 24 21:28:52 jaffa-cake pppd[2361]: primary   DNS address 10.11.12.13
Oct 24 21:28:52 jaffa-cake pppd[2361]: secondary DNS address 10.11.12.14
Oct 24 21:28:52 jaffa-cake NetworkManager: <info>  PPP manager(IP Config Get) reply received.
Oct 24 21:28:52 jaffa-cake NetworkManager: <info>  Activation (ttyUSB0) Stage 4 of 5 (IP4 Configure Get) scheduled...
Oct 24 21:28:52 jaffa-cake NetworkManager: <info>  Activation (ttyUSB0) Stage 4 of 5 (IP4 Configure Get) started...
Oct 24 21:28:52 jaffa-cake NetworkManager: <info>  Activation (ttyUSB0) Stage 5 of 5 (IP Configure Commit) scheduled...
Oct 24 21:28:52 jaffa-cake NetworkManager: <info>  Activation (ttyUSB0) Stage 4 of 5 (IP4 Configure Get) complete.
Oct 24 21:28:52 jaffa-cake NetworkManager: <info>  Activation (ttyUSB0) Stage 5 of 5 (IP Configure Commit) started...
Oct 24 21:28:53 jaffa-cake NetworkManager: <info>  (ttyUSB0): device state change: 7 -> 8 (reason 0)
Oct 24 21:28:53 jaffa-cake NetworkManager: <info>  Policy set 'T-Mobile Default' (ppp0) as default for routing and DNS.
Oct 24 21:28:53 jaffa-cake NetworkManager: <info>  Activation (ttyUSB0) successful, device activated.
Oct 24 21:28:53 jaffa-cake NetworkManager: <info>  Activation (ttyUSB0) Stage 5 of 5 (IP Configure Commit) complete.
Oct 24 21:31:03 jaffa-cake NetworkManager: <info>  (ttyUSB0): device state change: 8 -> 3 (reason 39)
Oct 24 21:31:03 jaffa-cake NetworkManager: <info>  (ttyUSB0): deactivating device (reason: 39).
Oct 24 21:31:03 jaffa-cake NetworkManager: <WARN>  check_one_route(): (ppp0) error -34 returned from rtnl_route_del(): Sucess#012
Oct 24 21:31:03 jaffa-cake pppd[2361]: Terminating on signal 15
Oct 24 21:31:03 jaffa-cake pppd[2361]: Connect time 2.2 minutes.
Oct 24 21:31:03 jaffa-cake pppd[2361]: Sent 8784 bytes, received 9388 bytes.
Oct 24 21:31:03 jaffa-cake pppd[2361]: Connection terminated.
Oct 24 21:31:03 jaffa-cake dbus: Rejected send message, 2 matched rules; type="error", sender=":1.9" (uid=0 pid=1232 comm="NetworkManager) interface="(unset)" member="(unset)" error name="org.freedesktop.DBus.Error.UnknownMethod" requested_reply=0 destination=":1.73" (uid=0 pid=2361 comm="/usr/sbin/pppd))
Oct 24 21:31:03 jaffa-cake dbus: Rejected send message, 2 matched rules; type="error", sender=":1.9" (uid=0 pid=1232 comm="NetworkManager) interface="(unset)" member="(unset)" error name="org.freedesktop.DBus.Error.UnknownMethod" requested_reply=0 destination=":1.73" (uid=0 pid=2361 comm="/usr/sbin/pppd))
Oct 24 21:31:03 jaffa-cake dbus: Rejected send message, 2 matched rules; type="error", sender=":1.9" (uid=0 pid=1232 comm="NetworkManager) interface="(unset)" member="(unset)" error name="org.freedesktop.DBus.Error.UnknownMethod" requested_reply=0 destination=":1.73" (uid=0 pid=2361 comm="/usr/sbin/pppd))
Oct 24 21:31:03 jaffa-cake dbus: Rejected send message, 2 matched rules; type="error", sender=":1.9" (uid=0 pid=1232 comm="NetworkManager) interface="(unset)" member="(unset)" error name="org.freedesktop.DBus.Error.UnknownMethod" requested_reply=0 destination=":1.73" (uid=0 pid=2361 comm="/usr/sbin/pppd))
Oct 24 21:31:03 jaffa-cake pppd[2361]: Exit.
Oct 24 21:31:04 jaffa-cake modem-manager: (ttyUSB0) closing serial device...




Syslog from subsequent attempt to connect
Oct 24 21:31:30 jaffa-cake NetworkManager: <info>  Activation (ttyUSB0) starting connection 'T-Mobile Default'
Oct 24 21:31:30 jaffa-cake NetworkManager: <info>  (ttyUSB0): device state change: 3 -> 4 (reason 0)
Oct 24 21:31:30 jaffa-cake NetworkManager: <info>  Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) scheduled...
Oct 24 21:31:30 jaffa-cake NetworkManager: <info>  Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) started...
Oct 24 21:31:30 jaffa-cake NetworkManager: <info>  (ttyUSB0): device state change: 4 -> 6 (reason 0)
Oct 24 21:31:30 jaffa-cake NetworkManager: <info>  Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) complete.
Oct 24 21:31:30 jaffa-cake NetworkManager: <info>  Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) scheduled...
Oct 24 21:31:30 jaffa-cake NetworkManager: <info>  Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) started...
Oct 24 21:31:30 jaffa-cake NetworkManager: <info>  (ttyUSB0): device state change: 6 -> 4 (reason 0)
Oct 24 21:31:30 jaffa-cake NetworkManager: <info>  Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) complete.
Oct 24 21:31:30 jaffa-cake modem-manager: (ttyUSB0) opening serial device...
Oct 24 21:31:30 jaffa-cake NetworkManager: <WARN>  stage1_prepare_done(): GSM modem connection failed: Sending command failed: device is connected
Oct 24 21:31:30 jaffa-cake NetworkManager: <info>  (ttyUSB0): device state change: 4 -> 9 (reason 1)
Oct 24 21:31:30 jaffa-cake NetworkManager: <info>  Marking connection 'T-Mobile Default' invalid.
Oct 24 21:31:30 jaffa-cake NetworkManager: <info>  Activation (ttyUSB0) failed.
Oct 24 21:31:30 jaffa-cake NetworkManager: <info>  (ttyUSB0): device state change: 9 -> 3 (reason 0)
Oct 24 21:31:30 jaffa-cake NetworkManager: <info>  (ttyUSB0): deactivating device (reason: 0).
Oct 24 21:31:30 jaffa-cake NetworkManager: flush_routes: assertion `iface_idx >= 0' failed
Oct 24 21:31:30 jaffa-cake NetworkManager: flush_addresses: assertion `iface_idx >= 0' failed
Oct 24 21:31:31 jaffa-cake modem-manager: (ttyUSB0) closing serial device...

Comment 1 Paul Howarth 2009-10-24 21:25:50 UTC
Not sure how that got assigned to perl-Algorithm-Diff - switching to NetworkManager.

Comment 2 Dan Williams 2009-11-06 06:24:01 UTC
Is this issue any better with latest rawhide?

Comment 3 Paul Flinders 2009-11-11 19:04:27 UTC
It's no better with the current fc12, I won't have the chance to check with Rawhide for a few days at least

Comment 4 Paul Flinders 2009-11-11 19:06:31 UTC
PS the connection does work though, the point at which I thought it didn't wasn't a clean install.

Comment 5 Bug Zapper 2009-11-16 14:13:29 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 6 robledo 2009-11-25 13:53:25 UTC
I have posted additional information at
https://bugzilla.redhat.com/show_bug.cgi?id=541314

Comment 7 Dan Williams 2009-12-01 09:02:05 UTC

*** This bug has been marked as a duplicate of bug 541314 ***


Note You need to log in before you can comment on or make changes to this bug.