Bug 541314 - unable to reconnect to mobile 3G network via Network Manager with previous manual disconnection
Summary: unable to reconnect to mobile 3G network via Network Manager with previous ma...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 530764 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-25 13:42 UTC by robledo
Modified: 2012-09-11 05:06 UTC (History)
13 users (show)

Fixed In Version: 0.2.997-4.git20091218.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
f12, 32-bit
Last Closed: 2010-01-02 21:28:22 UTC
Type: ---


Attachments (Terms of Use)
log of var/log/messages file (55.79 KB, application/pdf)
2009-11-25 13:42 UTC, robledo
no flags Details
modem-manager-debug-output.txt (11.04 KB, text/plain)
2009-12-01 00:39 UTC, robledo
no flags Details
NetworkManager debug output (29.69 KB, text/plain)
2009-12-01 00:40 UTC, robledo
no flags Details
Modem Manager Debug Terminal Output (5.15 KB, application/octet-stream)
2009-12-01 03:01 UTC, David Batson
no flags Details
Network Manager Debug Terminal Output (12.04 KB, application/octet-stream)
2009-12-01 03:02 UTC, David Batson
no flags Details
NetworkManager --no-daemon with DEBUGs (17.54 KB, text/plain)
2009-12-04 21:59 UTC, Rafał Miłecki
no flags Details
modem-manager --debug (4.50 KB, text/plain)
2009-12-05 09:16 UTC, Rafał Miłecki
no flags Details
NM_PPP_DEBUG=1 NetworkManager --no-daemon (12.93 KB, text/plain)
2009-12-05 09:17 UTC, Rafał Miłecki
no flags Details
NetworkManager debug log. (17.30 KB, application/octet-stream)
2009-12-11 09:18 UTC, Valentin Cobelea
no flags Details
ModemManager debug log. (12.65 KB, application/octet-stream)
2009-12-11 09:19 UTC, Valentin Cobelea
no flags Details
dmesg log (15.71 KB, application/octet-stream)
2009-12-11 09:21 UTC, Valentin Cobelea
no flags Details
Some misc info about my Fedora: kernel version and lsusb output. (738 bytes, application/octet-stream)
2009-12-11 09:22 UTC, Valentin Cobelea
no flags Details
NetworkManager0.8.0-3 repeated disconnection log (43.36 KB, text/plain)
2010-03-27 22:57 UTC, nakieb
no flags Details
output of dmesg (48.48 KB, application/octet-stream)
2010-03-27 22:59 UTC, nakieb
no flags Details
general info (690 bytes, text/plain)
2010-03-27 23:00 UTC, nakieb
no flags Details

Description robledo 2009-11-25 13:42:50 UTC
Created attachment 373742 [details]
log of var/log/messages file

Description of problem: when manually disconnecting mobile connection with Network Manager, manual reconnections are not possible.  However, if the usb-modem is unplugged, and re-plugged, a mobile connection is possible once more.


Version-Release number of selected component (if applicable): 0.7.996


How reproducible: very much  - in various machines


Steps to Reproduce:
1.connect with NM to a mobile connection
2.manually disconnect
3.attempt to reconnect
  
Actual results: nothing (the NM icon "blinks" once)


Expected results: reconnection of mobile connection


Additional info:


in order to facilitate diagnosing the problem, I have inserted comments to the "message" log output as to what I was doing at the Fedora level and with the usb-modems (pluggin, unpluging, etc.). nothing has been deleted. I am posting this here, if anyone can see something. I will also be submitting this to the bug reporting at both


the doc attached has output log after carrying out the following steps
1) deactivate the wifi
2) connect Huawei USB-modem
3) connect successfully to mobile 3G network
4) manually disconnect
5) unsuccessful attempt to re-connect to mobile network using NetworkManager
6) 2nd unsuccessful attempt to re-connect to mobile network using NetworkManager
7) unplug Huawei e220 usb-modem
8) plug-in ZTE MF626 usb-modem
9) eject automatic mount of usb-mass-storage, in order to recognize ZTE usb-modem
10) connect successfully to mobile 3G network
11) manually disconnect
12) unsuccessful attempt to re-connect to mobile network using NetworkManager
13) reactivate successfully wifi with NetworkManager
14) unplug ZTE MF626 usb-modem

The version of my current NetworkManager is 0.7.996 (is this actually 0.7.1.996 ?? from Oct.2009??)

Comment 1 robledo 2009-11-25 13:56:03 UTC
Just found another bug-report that is related
https://bugzilla.redhat.com/show_bug.cgi?id=530764

Comment 2 robledo 2009-11-25 14:11:50 UTC
The issue with modem ZTE MF626, also noted in my trouble-shooting, is also found in the following bug report
https://bugzilla.redhat.com/show_bug.cgi?id=533716

Comment 3 David Batson 2009-11-29 15:27:31 UTC
I appear to be affected by the same bug.  My cellular connection drops out and I am unable to reconnect without a reboot.  I used minicom to change from 3G to 2G, but I still could not reconnect.  Just as the OP stated, the "the NM icon "blinks" once".

I am using a Sierra Wireless 881 PC card.  This is on the AT&T network.

Comment 4 Dan Williams 2009-11-30 18:59:41 UTC
So what I'll need is some modem-manager debug logs as described here:

http://live.gnome.org/NetworkManager/Debugging

under the "Debugging NetworkManager 0.8.x 3G connections" section.  Basically leave modem-manager running with --debug and try to trigger the dropout, then try to reconnect with NetworkManager from the menu and let me see the modem-manager logs.

Comment 5 robledo 2009-12-01 00:39:04 UTC
Created attachment 374934 [details]
modem-manager-debug-output.txt

as requested, and following steps:

Debugging NetworkManager 0.8.x 3G connections

NetworkManager 0.8 and later use ModemManager for 3G device control. To get logs from modem-manager, we use the "--debug" option.

    *

      Stop NetworkManager
    * killall -TERM modem-manager
    * modem-manager --debug
    *

      in another terminal, run NetworkManager like so: 

NM_PPP_DEBUG=1 /usr/sbin/NetworkManager --no-daemon

    * reproduce the problem
    *

      send the modem-manager and NetworkManager logs to the developers

Comment 6 robledo 2009-12-01 00:40:15 UTC
Created attachment 374935 [details]
NetworkManager debug output

as requested, and as described in:
http://live.gnome.org/NetworkManager/Debugging

Debugging NetworkManager 0.8.x 3G connections

Comment 7 David Batson 2009-12-01 02:57:54 UTC
Here are my terminal outputs.

Comment 8 David Batson 2009-12-01 03:01:12 UTC
Created attachment 374950 [details]
Modem Manager Debug Terminal Output

Comment 9 David Batson 2009-12-01 03:02:01 UTC
Created attachment 374951 [details]
Network Manager Debug Terminal Output

Comment 10 Dan Williams 2009-12-01 09:01:40 UTC
Thanks for the logs, both of you.  They are consistent so this points to a general modem-manager/NetworkManager issue and is not hardware dependent.  I will try to reproduce the issue and debug, thanks!

Comment 11 Dan Williams 2009-12-01 09:02:06 UTC
*** Bug 530764 has been marked as a duplicate of this bug. ***

Comment 12 Valentin Cobelea 2009-12-03 07:54:47 UTC
The same issues I've had with a Huawei E220 and Huawei E270 3G modems. I've already discussed with "robledo" on FedoraForum.org , and it looks like we have the same issue.

Comment 13 Dan Williams 2009-12-04 19:36:26 UTC
I know what's going on and have fixed it in upstream ModemManager already.  A few more fixes are required but will show up as a ModemManager update soon.

Comment 14 Rafał Miłecki 2009-12-04 21:59:15 UTC
Created attachment 376222 [details]
NetworkManager --no-daemon with DEBUGs

Dan: Unfortunately I use openSUSE 11.2 which contains old NetworkManager (0.7.x). So it may of course contains more bugs and less meaningful debug logs. However I see very similar issue (stage1_prepare_done()) with my Huawei E800.

Are you able to check if this is the same issue or other (and I should update & create new report)?

Comment 15 Dan Williams 2009-12-04 23:14:42 UTC
(In reply to comment #14)
> Created an attachment (id=376222) [details]
> NetworkManager --no-daemon with DEBUGs
> 
> Dan: Unfortunately I use openSUSE 11.2 which contains old NetworkManager
> (0.7.x). So it may of course contains more bugs and less meaningful debug logs.
> However I see very similar issue (stage1_prepare_done()) with my Huawei E800.
> 
> Are you able to check if this is the same issue or other (and I should update &
> create new report)?  

You might try NM 0.7.2 which has a specific fix for one issue that could cause your problem.  The issues described in this bug however are specific to NetworkManager 0.8 snapshots and ModemManager and wouldn't apply to NM 0.7.x.

Comment 16 Rafał Miłecki 2009-12-05 09:14:13 UTC
OK, instead of poking with/in old NetworkManager I'll just focus on 0.8. I've downloaded Fedora 12 and tried to connect using LiveCD and my E800. I got some problem with connecting (didn't even try to debug that yet) and second try failed on warn stage1_prepare_done. Could you check once again my logs, please? Is that the same issue this bug is about?

Comment 17 Rafał Miłecki 2009-12-05 09:16:21 UTC
Created attachment 376293 [details]
modem-manager --debug

Comment 18 Rafał Miłecki 2009-12-05 09:17:03 UTC
Created attachment 376294 [details]
NM_PPP_DEBUG=1 NetworkManager --no-daemon

Comment 19 Dan Williams 2009-12-07 07:41:49 UTC
(In reply to comment #16)
> OK, instead of poking with/in old NetworkManager I'll just focus on 0.8. I've
> downloaded Fedora 12 and tried to connect using LiveCD and my E800. I got some
> problem with connecting (didn't even try to debug that yet) and second try
> failed on warn stage1_prepare_done. Could you check once again my logs, please?
> Is that the same issue this bug is about?  

Again, I know what the problem is in NetworkManager 0.8, and I'm working on it.  It's already been fixed in the 'states' branch of modem-manager upstream, and I need to do some more testing of that code before I roll out a modem-manager update this week.

Comment 20 Rafał Miłecki 2009-12-07 13:37:47 UTC
(In reply to comment #19)
> (In reply to comment #16)
> > OK, instead of poking with/in old NetworkManager I'll just focus on 0.8. I've
> > downloaded Fedora 12 and tried to connect using LiveCD and my E800. I got some
> > problem with connecting (didn't even try to debug that yet) and second try
> > failed on warn stage1_prepare_done. Could you check once again my logs, please?
> > Is that the same issue this bug is about?  
> 
> Again, I know what the problem is in NetworkManager 0.8, and I'm working on it.

I just didn't know if I hit the same bug. OK, but it sounds now I do :)

Comment 21 Dan Williams 2009-12-08 08:29:02 UTC
https://admin.fedoraproject.org/updates/NetworkManager-0.7.997-1.fc12,ModemManager-0.2.997-1.fc12

Try at least ModemManager from that update.  If for some reason you still have problems reconnecting after a disconnection, I'll need the 'modem-manager --debug' logs.  That ModemManager update definitely fixes the "port already connected" problem, but there could be unrelated issues that cause a reconnection failure (for example, some modems seem to want the init string sent twice after a disconnect, and that's only done for ZTE devices at this time).  Then we'll diagnose and possibly open a different bug if it's a different problem.

Comment 22 Dan Williams 2009-12-08 08:29:36 UTC
NetworkManager-0.7.997-1.fc12,ModemManager-0.2.997-1.fc12 has been submitted as
an update for Fedora 12.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.997-1.fc12,ModemManager-0.2.997-1.fc12

Comment 23 David Batson 2009-12-09 02:05:16 UTC
Just ran Software Update.  Problem appears to be solved on my system. :=)

Thanks for the work on resolving this issue!

Comment 24 Fedora Update System 2009-12-10 04:24:31 UTC
NetworkManager-0.7.997-1.fc12, ModemManager-0.2.997-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager ModemManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13012

Comment 25 David Batson 2009-12-10 16:11:51 UTC
FWIW, I installed the following files using Software Update on 12/08/09 and this resolved this bug for me.  Nevertheless I see these are not the latest updates listed above.  I have not enabled the testing repositories to date.

Dec 08 18:35:01 Updated: 1:NetworkManager-glib-0.7.996-7.git20091113.fc12.i686
Dec 08 18:35:03 Updated: 1:net-snmp-libs-5.4.2.1-19.fc12.i686
Dec 08 18:35:05 Updated: ModemManager-0.2-4.20091105.fc12.i686
Dec 08 18:35:09 Updated: 1:NetworkManager-0.7.996-7.git20091113.fc12.i686
Dec 08 18:35:10 Updated: libfprint-0.1.0-14.pre2.fc12.i686
Dec 08 18:35:11 Updated: gmime-2.4.11-1.fc12.i686
Dec 08 18:35:12 Updated: libnetfilter_conntrack-0.0.100-1.fc12.i686
Dec 08 18:35:14 Updated: gstreamer-plugins-bad-0.10.17-2.fc12.i686
Dec 08 18:35:15 Updated: lockdev-1.0.1-19.fc12.i686
Dec 08 18:35:16 Updated: gpm-libs-1.20.6-8.fc12.i686
Dec 08 18:35:17 Updated: iptstate-2.2.2-4.fc12.i686
Dec 08 18:35:28 Updated: 1:NetworkManager-gnome-0.7.996-7.git20091113.fc12.i686
Dec 08 18:35:30 Updated: 1:net-snmp-5.4.2.1-19.fc12.i686
Dec 08 18:35:31 Updated: 1:telepathy-mission-control-5.2.6-1.fc12.i686
Dec 08 18:35:32 Updated: rsync-3.0.6-4.fc12.i686
Dec 08 18:35:33 Updated: telepathy-gabble-0.8.8-2.fc12.i686
Dec 08 18:35:35 Updated: nano-2.0.9-4.fc12.i686
Dec 08 18:35:37 Updated: nspluginwrapper-1.3.0-10.fc12.i686
Dec 08 18:35:59 Updated: selinux-policy-3.6.32-55.fc12.noarch
Dec 08 18:35:59 Updated: vlgothic-fonts-common-20091202-1.fc12.noarch
Dec 08 18:36:01 Updated: kernel-firmware-2.6.31.6-162.fc12.noarch
Dec 08 18:36:04 Updated: vlgothic-fonts-20091202-1.fc12.noarch
Dec 08 18:36:43 Updated: selinux-policy-targeted-3.6.32-55.fc12.noarch
Dec 08 18:36:44 Updated: perf-2.6.31.6-162.fc12.noarch
Dec 08 18:36:45 Updated: flash-plugin-10.0.42.34-release.i386
Dec 08 18:37:26 Installed: kernel-2.6.31.6-162.fc12.i686
Dec 08 18:37:28 Updated: libdrm-2.4.15-6.fc12.i686
Dec 08 18:37:31 Updated: setroubleshoot-plugins-2.1.35-1.fc12.noarch
Dec 08 18:37:33 Updated: setroubleshoot-server-2.2.50-1.fc12.i686
Dec 08 18:37:35 Updated: setroubleshoot-2.2.50-1.fc12.i686

Comment 26 Valentin Cobelea 2009-12-11 09:16:38 UTC
Hello, I've updated NetworkManager to version 0.7.997-1 and ModemManager to version 0.2.997-1 , but I still have the same problem. The modem is not mounted and the 3G connection is still not established. I'll attach the logs for NM, MM, dmesg and some misc information.

Comment 27 Valentin Cobelea 2009-12-11 09:18:00 UTC
Created attachment 377695 [details]
NetworkManager debug log.

Comment 28 Valentin Cobelea 2009-12-11 09:19:07 UTC
Created attachment 377696 [details]
ModemManager debug log.

Comment 29 Valentin Cobelea 2009-12-11 09:21:17 UTC
Created attachment 377697 [details]
dmesg log

Comment 30 Valentin Cobelea 2009-12-11 09:22:52 UTC
Created attachment 377698 [details]
Some misc info about my Fedora: kernel version and lsusb output.

Comment 31 David Batson 2009-12-11 14:02:36 UTC
Based on the following thread, I believe Valentin is encountering a different bug than this bug report is about.
http://forums.fedoraforum.org/showthread.php?t=234332

Comment 32 Valentin Cobelea 2009-12-11 14:12:26 UTC
Then, as Dan said, another bug should be created with the logs I've provided.

Comment 33 Dan Williams 2009-12-11 19:52:14 UTC
Yeah, if you can create another bug.  The issue you're having appears to be ModemManager not correctly handling probing when a PIN is required in some cases.

Comment 34 Valentin Cobelea 2009-12-12 17:34:24 UTC
I'm having some trouble accessing the "add new bug" page. Please feel free to create another one with the logs I've provided, this issue is starting to be very annoying.....I have to use 'windowz' to do all the internet related stuff. Thank you!

Comment 35 Stefan Becker 2009-12-14 20:57:40 UTC
ModemManager-0.7.997-1.fc12 seems to work much better now (tested with Nokia E72 & N900). I can connect, disconnect & reconnect from nm-applet at will now.


I'm not sure if this is related to this bug, but it is *HIGHLY* advisable to follow these steps during disconnecting the device:

    * "Disconnect" the broadband connection in nm-applet
    * disconnect the USB cable

Otherwise NM or MM keeps a lock on /dev/ttyACMx so that it does not disappear when the USB connection is severed. This is kind of strange, because NM says that it is cleaning up the device but there are some dbus error messages:

Dec 14 22:45:38 localhost pppd[2922]: Exit.
Dec 14 22:45:38 localhost NetworkManager: <info>  (ttyACM3): now unmanaged
Dec 14 22:45:38 localhost NetworkManager: <info>  (ttyACM3): device state change: 3 -> 1 (reason 36)
Dec 14 22:45:38 localhost NetworkManager: <info>  (ttyACM3): cleaning up...
Dec 14 22:45:38 localhost NetworkManager: <info>  (ttyACM3): taking down device.
Dec 14 22:45:38 localhost dbus: Rejected send message, 3 matched rules; type="error", sender=":1.9" (uid=0 pid=1244 comm="/usr/sbin/modem-manager) interface="(unset)" member="(unset)" error name="org.freedesktop.DBus.Error.UnknownMethod" requested_reply=0 destination=":1.7" (uid=0 pid=1238 comm="NetworkManager))
Dec 14 22:45:38 localhost nm-dispatcher.action: Error in get_property: Method "Get" with signature "ss" on interface "org.freedesktop.DBus.Properties" doesn't exist#012
Dec 14 22:45:38 localhost dbus: Rejected send message, 3 matched rules; type="error", sender=":1.9" (uid=0 pid=1244 comm="/usr/sbin/modem-manager) interface="(unset)" member="(unset)" error name="org.freedesktop.DBus.Error.UnknownMethod" requested_reply=0 destination=":1.7" (uid=0 pid=1238 comm="NetworkManager))

Comment 36 Fedora Update System 2009-12-14 22:49:42 UTC
NetworkManager-0.7.997-2.git20091214.fc12,ModemManager-0.2.997-2.git20091214.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.997-2.git20091214.fc12,ModemManager-0.2.997-2.git20091214.fc12

Comment 37 Valentin Cobelea 2009-12-15 08:42:02 UTC
Thank you. These kind of actions worked on older versions of NM (connect/disconnect at will), but now the issue is that the 3G modem is not seen as a modem. The 'usbmodeswitch' did not work either. I'm some how stuck and I'm not willing to use Fedora 12 as virtual machine (in a windowz host) just becuase of this error. I hope the 0.7.997-2 versions for NM and MM will fix what I've reported/have.

Comment 38 Fedora Update System 2009-12-16 01:09:03 UTC
NetworkManager-0.7.997-2.git20091214.fc12, ModemManager-0.2.997-2.git20091214.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager ModemManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13165

Comment 39 Jonathan Colon 2009-12-17 17:09:10 UTC
cannot connect to cdma network with  sprint compass 597U using this update

Error -----

NetworkManager: <info>  Activation (ttyUSB0) starting connection 'Sprint connection'
NetworkManager: <info>  (ttyUSB0): device state change: 3 -> 4 (reason 0)
NetworkManager: <info>  Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) scheduled...
NetworkManager: <info>  Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) started...
NetworkManager: <info>  Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) complete.
NetworkManager: <info>  Activation (ttyUSB0) Stage 2 of 5 (Device Configure) scheduled...
NetworkManager: <info>  Activation (ttyUSB0) Stage 2 of 5 (Device Configure) starting...
NetworkManager: <info>  (ttyUSB0): device state change: 4 -> 5 (reason 0)
NetworkManager: <info>  Activation (ttyUSB0) Stage 2 of 5 (Device Configure) successful.
NetworkManager: <info>  Activation (ttyUSB0) Stage 3 of 5 (IP Configure Start) scheduled.
NetworkManager: <info>  Activation (ttyUSB0) Stage 2 of 5 (Device Configure) complete.
NetworkManager: <info>  Activation (ttyUSB0) Stage 3 of 5 (IP Configure Start) started...
NetworkManager: <info>  (ttyUSB0): device state change: 5 -> 7 (reason 0)
NetworkManager: <info>  Starting pppd connection
NetworkManager: <debug> [1261069555.812687] nm_ppp_manager_start(): Command line: /usr/sbin/pppd nodetach lock nodefaultroute ttyUSB0 noipdefault noauth usepeerdns lcp-echo-failure 0 lcp-echo-interval 0 ipparam /org/freedesktop/NetworkManager/PPP/2 plugin /usr/lib/pppd/2.4.4/nm-pppd-plugin.so
NetworkManager: <debug> [1261069555.815682] nm_ppp_manager_start(): ppp started with pid 1901
NetworkManager: <info>  Activation (ttyUSB0) Stage 4 of 5 (IP6 Configure Get) scheduled...
NetworkManager: <info>  Activation (ttyUSB0) Stage 3 of 5 (IP Configure Start) complete.
NetworkManager: <info>  Activation (ttyUSB0) Stage 4 of 5 (IP6 Configure Get) started...
NetworkManager: <info>  Activation (ttyUSB0) Stage 4 of 5 (IP6 Configure Get) complete.
/usr/sbin/pppd: Plugin /usr/lib/pppd/2.4.4/nm-pppd-plugin.so is for pppd version 2.4.4, this is 2.4.5
NetworkManager: <WARN>  ppp_exit_code(): ppp pid 1901 exited with error: pppd options error
NetworkManager: <debug> [1261069555.823423] ppp_watch_cb(): ppp pid 1901 cleaned up
NetworkManager: <info>  (ttyUSB0): device state change: 7 -> 9 (reason 14)
NetworkManager: <info>  Marking connection 'Sprint connection' invalid.
NetworkManager: <info>  Activation (ttyUSB0) failed.
NetworkManager: <info>  (ttyUSB0): device state change: 9 -> 3 (reason 0)
NetworkManager: <info>  (ttyUSB0): deactivating device (reason: 0).

Comment 40 Dan Williams 2009-12-17 17:14:49 UTC
(In reply to comment #39)
> cannot connect to cdma network with  sprint compass 597U using this update

Lets open a new bug for this problem please.

Comment 41 Fedora Update System 2009-12-18 04:27:00 UTC
ModemManager-0.2.997-3.git20091216.fc12, NetworkManager-0.7.997-2.git20091214.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ModemManager NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13165

Comment 42 Valentin Cobelea 2009-12-18 07:51:29 UTC
These updates still did not resolve my issue. I'm not able to connect at all with the Huawei 3G modem E220 on Vodafone RO broadband network.

Comment 43 Valentin Cobelea 2009-12-18 09:55:22 UTC
I've updated to firmware 11.117.10.03.99. Now the problem is this way:
- the 3G modem is mounted correctly as a CD/usb storage;
- but when I try to connect to the "Vodafone Default" (connection that I've created correctly with the proper APN/password) I get: the icon of the NetworkManager is showing that tries to connect (the two circles become green) but instantly it shows back the NM default icon.
- in all this time the modem remains mounted (this did not happened on the old firmware).

Comment 44 Jonathan Colon 2009-12-18 14:09:47 UTC
the same this happens to me!!!! pppd options error. works using wvdial

NetworkManager: <info>  Activation (ttyUSB0) starting connection 'Sprint
connection'
NetworkManager: <info>  (ttyUSB0): device state change: 3 -> 4 (reason 0)
NetworkManager: <info>  Activation (ttyUSB0) Stage 1 of 5 (Device Prepare)
scheduled...
NetworkManager: <info>  Activation (ttyUSB0) Stage 1 of 5 (Device Prepare)
started...
NetworkManager: <info>  Activation (ttyUSB0) Stage 1 of 5 (Device Prepare)
complete.
NetworkManager: <info>  Activation (ttyUSB0) Stage 2 of 5 (Device Configure)
scheduled...
NetworkManager: <info>  Activation (ttyUSB0) Stage 2 of 5 (Device Configure)
starting...
NetworkManager: <info>  (ttyUSB0): device state change: 4 -> 5 (reason 0)
NetworkManager: <info>  Activation (ttyUSB0) Stage 2 of 5 (Device Configure)
successful.
NetworkManager: <info>  Activation (ttyUSB0) Stage 3 of 5 (IP Configure Start)
scheduled.
NetworkManager: <info>  Activation (ttyUSB0) Stage 2 of 5 (Device Configure)
complete.
NetworkManager: <info>  Activation (ttyUSB0) Stage 3 of 5 (IP Configure Start)
started...
NetworkManager: <info>  (ttyUSB0): device state change: 5 -> 7 (reason 0)
NetworkManager: <info>  Starting pppd connection
NetworkManager: <debug> [1261069555.812687] nm_ppp_manager_start(): Command
line: /usr/sbin/pppd nodetach lock nodefaultroute ttyUSB0 noipdefault noauth
usepeerdns lcp-echo-failure 0 lcp-echo-interval 0 ipparam
/org/freedesktop/NetworkManager/PPP/2 plugin
/usr/lib/pppd/2.4.4/nm-pppd-plugin.so
NetworkManager: <debug> [1261069555.815682] nm_ppp_manager_start(): ppp started
with pid 1901
NetworkManager: <info>  Activation (ttyUSB0) Stage 4 of 5 (IP6 Configure Get)
scheduled...
NetworkManager: <info>  Activation (ttyUSB0) Stage 3 of 5 (IP Configure Start)
complete.
NetworkManager: <info>  Activation (ttyUSB0) Stage 4 of 5 (IP6 Configure Get)
started...
NetworkManager: <info>  Activation (ttyUSB0) Stage 4 of 5 (IP6 Configure Get)
complete.
/usr/sbin/pppd: Plugin /usr/lib/pppd/2.4.4/nm-pppd-plugin.so is for pppd
version 2.4.4, this is 2.4.5
NetworkManager: <WARN>  ppp_exit_code(): ppp pid 1901 exited with error: pppd
options error
NetworkManager: <debug> [1261069555.823423] ppp_watch_cb(): ppp pid 1901
cleaned up
NetworkManager: <info>  (ttyUSB0): device state change: 7 -> 9 (reason 14)
NetworkManager: <info>  Marking connection 'Sprint connection' invalid.
NetworkManager: <info>  Activation (ttyUSB0) failed.
NetworkManager: <info>  (ttyUSB0): device state change: 9 -> 3 (reason 0)
NetworkManager: <info>  (ttyUSB0): deactivating device (reason: 0).

Comment 45 Valentin Cobelea 2009-12-18 14:21:22 UTC
Yeap, the wvdial could do the trick, but for my network Vodafone RO (Romania), I don't know the sequence of these AT commands that needs to be added in the /etc/wvdial.conf . I'm sure that they are the same as those that NM uses, but here is the problem: I don't know them either.

Comment 46 Jonathan Colon 2009-12-18 14:40:22 UTC
create new bug for my sierra wireless compass 597U

https://bugzilla.redhat.com/show_bug.cgi?id=548760

Comment 47 Fedora Update System 2009-12-22 04:49:18 UTC
ModemManager-0.2.997-4.git20091218.fc12, NetworkManager-0.7.997-2.git20091214.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ModemManager NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13165

Comment 48 RudraB 2009-12-27 09:03:25 UTC
I have almost similar problem. My problem is I always have to shut down and restart my machine to connect internet if somehow i get disconnected!
Hope this will help!

I have
$ lsusb
Bus 002 Device 005: ID 12d1:1001 Huawei Technologies Co., Ltd. E620 USB Modem
$ uname -a
Linux roddur 2.6.31.9-174.fc12.i686.PAE #1 SMP Mon Dec 21 06:04:56 UTC 2009 i686 i686 i386 GNU/Linux
$ rpm -qa|grep ModemManager
ModemManager-0.2.997-1.fc12.i686
$ rpm -qa|grep NetworkManager
NetworkManager-gnome-0.7.997-1.fc12.i686
NetworkManager-glib-0.7.997-1.fc12.i686
NetworkManager-0.7.997-1.fc12.i686

and the files as the output are posted here:

# modem-manager --debug
** Message: Loaded plugin Option High-Speed
** Message: Loaded plugin Sierra
** Message: Loaded plugin Gobi
** Message: Loaded plugin MotoC
** Message: Loaded plugin Generic
** Message: Loaded plugin Novatel
** Message: Loaded plugin Nokia
** Message: Loaded plugin Ericsson MBM
** Message: Loaded plugin Option
** Message: Loaded plugin Huawei
** Message: Loaded plugin ZTE
** Message: (ttyUSB0) opening serial device...
** (modem-manager:2792): DEBUG: (ttyUSB0): probe requested by plugin 'Huawei'
** (modem-manager:2792): DEBUG: (Huawei): (ttyUSB2) deferring support check
** (modem-manager:2792): DEBUG: (Huawei): (ttyUSB1) deferring support check
** (modem-manager:2792): DEBUG: (ttyUSB0): --> 'AT+GCAP<CR>'
** (modem-manager:2792): DEBUG: (ttyUSB0): <-- 'AT+GCAP<CR><CR><LF>+CME ERROR: SIM busy<CR><LF>'
** (modem-manager:2792): DEBUG: (ttyUSB2): re-checking support...
** (modem-manager:2792): DEBUG: (Huawei): (ttyUSB2) deferring support check
** (modem-manager:2792): DEBUG: (ttyUSB1): re-checking support...
** (modem-manager:2792): DEBUG: (Huawei): (ttyUSB1) deferring support check
** (modem-manager:2792): DEBUG: (ttyUSB0): --> 'AT+GCAP<CR>'
** (modem-manager:2792): DEBUG: (ttyUSB0): <-- 'AT+GCAP<CR><CR><LF>+GCAP: +CGSM,+DS,+ES<CR><LF><CR><LF>OK<CR><LF>'
** Message: (ttyUSB0) closing serial device...
** Message: (Huawei): GSM modem /sys/devices/pci0000:00/0000:00:1d.7/usb2/2-2 claimed port ttyUSB0
** (modem-manager:2792): DEBUG: Added modem /sys/devices/pci0000:00/0000:00:1d.7/usb2/2-2
** (modem-manager:2792): DEBUG: Exported modem /sys/devices/pci0000:00/0000:00:1d.7/usb2/2-2 as /org/freedesktop/ModemManager/Modems/0
** (modem-manager:2792): DEBUG: (ttyUSB2): re-checking support...
** Message: (ttyUSB2) opening serial device...
** (modem-manager:2792): DEBUG: (ttyUSB1): re-checking support...
** Message: (ttyUSB1) opening serial device...
** (modem-manager:2792): DEBUG: (ttyUSB2): <-- '<CR><LF>^BOOT:30991692,0,0,0,87<CR><LF><CR><LF>^SRVST:1<CR><LF><CR><LF>^MODE:5,4<CR><LF><CR><LF>^SIMST:1<CR><LF><CR><LF>^SRVST:2<CR><LF>'
** Message: (ttyUSB2) closing serial device...
** Message: (Huawei): GSM modem /sys/devices/pci0000:00/0000:00:1d.7/usb2/2-2 claimed port ttyUSB2
** Message: (ttyUSB1) closing serial device...
** Message: (ttyUSB1) opening serial device...
** (modem-manager:2792): DEBUG: (ttyUSB1): probe requested by plugin 'Generic'
** (modem-manager:2792): DEBUG: (ttyUSB1): --> 'AT+GCAP<CR>'
** (modem-manager:2792): DEBUG: (ttyUSB1): --> 'AT+GCAP<CR>'
** (modem-manager:2792): DEBUG: (ttyUSB1): --> 'AT+GCAP<CR>'
** Message: (ttyUSB1) closing serial device...
** Message: (ttyUSB0) opening serial device...
** Message: Modem /org/freedesktop/ModemManager/Modems/0: state changed (disabled -> enabling)
** (modem-manager:2792): DEBUG: (ttyUSB0): --> 'ATZ E0 V1 +CMEE=1<CR>'
** (modem-manager:2792): DEBUG: (ttyUSB0): <-- 'ATZ E0 V1 +CMEE'
** (modem-manager:2792): DEBUG: (ttyUSB0): <-- '=1'
** (modem-manager:2792): DEBUG: (ttyUSB0): <-- '<CR>'
** (modem-manager:2792): DEBUG: (ttyUSB0): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:2792): DEBUG: (ttyUSB0): --> 'ATE0 +CMEE=1<CR>'
** (modem-manager:2792): DEBUG: (ttyUSB0): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:2792): DEBUG: (ttyUSB0): --> 'ATX4 &C1<CR>'
** (modem-manager:2792): DEBUG: (ttyUSB0): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:2792): DEBUG: (ttyUSB0): --> 'AT+CREG=0<CR>'
** (modem-manager:2792): DEBUG: (ttyUSB0): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:2792): DEBUG: (ttyUSB0): --> 'AT+CFUN=1<CR>'
** (modem-manager:2792): DEBUG: (ttyUSB0): <-- '<CR><LF>OK<CR><LF>'
** Message: Modem /org/freedesktop/ModemManager/Modems/0: state changed (enabling -> enabled)
** (modem-manager:2792): DEBUG: (ttyUSB0): --> 'AT+CPIN?<CR>'
** (modem-manager:2792): DEBUG: (ttyUSB0): <-- '<CR><LF>+CPIN: READY<CR><LF><CR><LF>OK<CR><LF>'
** (modem-manager:2792): DEBUG: (ttyUSB0): --> 'AT+COPS=0,,<CR>'
** (modem-manager:2792): DEBUG: (ttyUSB0): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:2792): DEBUG: (ttyUSB0): --> 'AT+CREG?<CR>'
** (modem-manager:2792): DEBUG: (ttyUSB0): <-- '<CR><LF>+CREG: 0,5<CR><LF><CR><LF>OK<CR><LF>'
** (modem-manager:2792): DEBUG: Registration state changed: 5
** Message: Modem /org/freedesktop/ModemManager/Modems/0: state changed (enabled -> registered)
** (modem-manager:2792): DEBUG: (ttyUSB0): --> 'AT+COPS=3,2;+COPS?<CR>'
** (modem-manager:2792): DEBUG: (ttyUSB0): <-- '<CR><LF>+COPS: 0,2,"24005",2<CR><LF><CR><LF>OK<CR><LF>'
** (modem-manager:2792): DEBUG: (ttyUSB0): --> 'AT+COPS=3,0;+COPS?<CR>'
** (modem-manager:2792): DEBUG: (ttyUSB0): <-- '<CR><LF>+COPS: 0,0,"Sweden 3G",2<CR><LF><CR><LF>OK<CR><LF>'
** (modem-manager:2792): DEBUG: (ttyUSB0): --> 'AT+CSQ<CR>'
** (modem-manager:2792): DEBUG: (ttyUSB0): <-- '<CR><LF>+CSQ: 7,99<CR><LF><CR><LF>OK<CR><LF>'
** (modem-manager:2792): DEBUG: (ttyUSB0): --> 'AT+CGDCONT?<CR>'
** (modem-manager:2792): DEBUG: (ttyUSB0): <-- '<CR><LF>+CGDCONT: 1,"IP","data.comviq.se","0.0.0.0",0,0<CR><LF>+CGDCONT: 2,"IP","internet.tele2.se","0.0.0.0",0,0<CR><LF><CR><LF>OK<CR><LF>'
** Message: Modem /org/freedesktop/ModemManager/Modems/0: state changed (registered -> connecting)
** (modem-manager:2792): DEBUG: (ttyUSB0): --> 'ATD*99***1#<CR>'
** (modem-manager:2792): DEBUG: (ttyUSB0): <-- '<CR><LF>NO CARRIER<CR><LF>'
** (modem-manager:2792): DEBUG: Got failure code 3: No carrier
** (modem-manager:2792): DEBUG: (ttyUSB0): --> 'AT+CEER<CR>'
** (modem-manager:2792): DEBUG: (ttyUSB0): <-- '<CR><LF>+CEER: No cause information available<CR><LF><CR><LF>OK<CR><LF>'
** Message: Modem /org/freedesktop/ModemManager/Modems/0: state changed (connecting -> registered)
** Message: Modem /org/freedesktop/ModemManager/Modems/0: state changed (registered -> disabling)
** Message: (ttyUSB0) closing serial device...
** Message: Modem /org/freedesktop/ModemManager/Modems/0: state changed (disabling -> disabled)


# NM_PPP_DEBUG=1 /usr/sbin/NetworkManager --no-daemon
NetworkManager: <info>  starting...
NetworkManager: <info>  modem-manager is now available
NetworkManager: Loaded plugin ifcfg-rh: (c) 2007 - 2008 Red Hat, Inc.  To report bugs please use the NetworkManager mailing list.
NetworkManager: <info>  Found radio killswitch rfkill0 (at /sys/devices/virtual/rfkill/rfkill0) (driver <unknown>)
NetworkManager: <info>  Wireless enabled by radio killswitch; enabled by state file
NetworkManager:    ifcfg-rh: parsing /etc/sysconfig/network-scripts/ifcfg-eth0 ... 
NetworkManager:    ifcfg-rh:     read connection 'System eth0'
NetworkManager:    ifcfg-rh: parsing /etc/sysconfig/network-scripts/ifcfg-lo ... 
NetworkManager: <info>  (eth0): carrier is OFF
NetworkManager: <info>  (eth0): new Ethernet device (driver: 'sky2')
NetworkManager: <info>  (eth0): exported as /org/freedesktop/NetworkManager/Devices/0
NetworkManager: <info>  (eth0): now managed
NetworkManager: <info>  (eth0): device state change: 1 -> 2 (reason 2)
NetworkManager: <info>  (eth0): bringing up device.
NetworkManager: <info>  (eth0): preparing device.
NetworkManager: <info>  (eth0): deactivating device (reason: 2).
NetworkManager: <WARN>  device_creator(): /sys/devices/virtual/net/pan0: couldn't determine device driver; ignoring...
-- Error received: File exists
-- Original message: type=0x14 length=56 flags=<REQUEST,ACK,ATOMIC> sequence-nr=1261903136 pid=4197194
NetworkManager: <info>  (ttyUSB0): new GSM device (driver: 'option1')
NetworkManager: <info>  (ttyUSB0): exported as /org/freedesktop/NetworkManager/Devices/1
NetworkManager: <info>  (ttyUSB0): now managed
NetworkManager: <info>  (ttyUSB0): device state change: 1 -> 2 (reason 2)
NetworkManager: <info>  (ttyUSB0): deactivating device (reason: 2).
NetworkManager: <info>  (ttyUSB0): device state change: 2 -> 3 (reason 0)
NetworkManager: <info>  Activation (ttyUSB0) starting connection 'Tele2/Comviq connection'
NetworkManager: <info>  (ttyUSB0): device state change: 3 -> 4 (reason 0)
NetworkManager: <info>  Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) scheduled...
NetworkManager: <info>  Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) started...
NetworkManager: <info>  Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) complete.
NetworkManager: <WARN>  stage1_prepare_done(): GSM modem connection failed: No cause information available
NetworkManager: <info>  (ttyUSB0): device state change: 4 -> 9 (reason 1)
NetworkManager: <info>  Marking connection 'Tele2/Comviq connection' invalid.
NetworkManager: <info>  Activation (ttyUSB0) failed.
NetworkManager: <info>  (ttyUSB0): device state change: 9 -> 3 (reason 0)
NetworkManager: <info>  (ttyUSB0): deactivating device (reason: 0).

Comment 49 Fedora Update System 2010-01-02 21:27:41 UTC
ModemManager-0.2.997-4.git20091218.fc12, NetworkManager-0.7.997-2.git20091214.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 50 Valentin Cobelea 2010-01-02 21:50:24 UTC
Nope, it still doe not work. The issue persist (as mentioned in the attached logs + the above comment).

Comment 51 nakieb 2010-01-09 11:37:17 UTC
I am having the same problem with network manager 0.7.996 and ZTE MF626 3G USB modem . Iwill try to update and see what happens .

Comment 52 nakieb 2010-01-22 20:42:29 UTC
after update the problem still there but not always .it appears 1 of 3 times

Comment 53 nakieb 2010-01-22 20:44:22 UTC
2 other issues happened after the update: usb modem powers off after a while happens ocassionaly (2 times in 2 days ) , and gnome crash while connecting ( happened only once )

Comment 54 nakieb 2010-01-22 20:48:58 UTC
I tried network manager in another distro , it only worked if usb modem is connected while . thanks, this is not the case in fedora . I tried using Knetworkmanager but i couldn't connect even after writing dial no and APN .

Comment 55 Shadab I. Wadiwala 2010-03-17 09:25:32 UTC
I also updated both NetworkManager and ModemManager to the latest stable available verion in the repository, but still the problem persists.


Regards,
Shadab

Comment 56 nakieb 2010-03-18 05:51:29 UTC
(In reply to comment #55)
> I also updated both NetworkManager and ModemManager to the latest stable
> available verion in the repository, but still the problem persists.
Can you please run this command and post the results :
rpm -q NetworkManager ModemManager

Comment 57 Dan Williams 2010-03-19 01:06:17 UTC
Also, following the directions here:

http://live.gnome.org/NetworkManager/Debugging

specifically the section about "Debugging NetworkManager 0.8.x 3G connections" and getting modem-manager debug output.


Valentin Cobelea; your logs indicate that your device is roaming at the time you make the connection; the roaming provider may not allow your IMEI or have a roaming agreement with your actual provider, in which case the PPP session will fail or the dial will fail, which it looks like it did.

nakieb@gmail: I'd like to get some modem-manager debug logs from your device to see what's going on.  I also have a ZTE MF626 which works OK for me, so I assume it's just some random bug that we can fix.

Comment 58 Shadab I. Wadiwala 2010-03-19 16:13:15 UTC
(In reply to comment #56)
> (In reply to comment #55)
> > I also updated both NetworkManager and ModemManager to the latest stable
> > available verion in the repository, but still the problem persists.
> Can you please run this command and post the results :
> rpm -q NetworkManager ModemManager  

[shadab@IBM-THINKPAD ~]$ rpm -q NetworkManager ModemManager
NetworkManager-0.7.998-2.git20100106.fc12.i686
ModemManager-0.3-2.git20100211.fc12.i686

Regards,
Shadab

Comment 59 nakieb 2010-03-27 22:57:12 UTC
Created attachment 403051 [details]
NetworkManager0.8.0-3 repeated disconnection log

Comment 60 nakieb 2010-03-27 22:59:33 UTC
Created attachment 403053 [details]
output of dmesg

Comment 61 nakieb 2010-03-27 23:00:34 UTC
Created attachment 403054 [details]
general info

Comment 62 Dan Williams 2010-03-30 18:44:21 UTC
nakieb: There is a specific problem here that's unrelated this this bug though, so I've opened bug 578280 for it.


Note You need to log in before you can comment on or make changes to this bug.