Bug 530941 - Keyboard layout selected is wrong after install & resets to USA after logout/reboot
Keyboard layout selected is wrong after install & resets to USA after logout/...
Status: CLOSED DUPLICATE of bug 530452
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Control Center Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-26 04:12 EDT by Jóhann B. Guðmundsson
Modified: 2009-10-26 10:02 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-26 09:43:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jóhann B. Guðmundsson 2009-10-26 04:12:11 EDT
Description of problem:

After install the keyboard layout selected during install is not honored it defaults to USA even if you selected a non USA keyboard layout during install.  
( Anaconda/X bug ?)

After you create a user in firstboot and after you login as that user and 
select keyboard layout via System --> preference --keyboard and choose a none USA layout and make that the default and remove the USA entry in layouts.

Then you logout log back in ( or reboot ) the USA layout reappears in "Keyboard preference" and is the default however the default in Keyboard preference is shown to be the one ( non USA ) that user selected. 

Version-Release number of selected component (if applicable):

2.28.1-1

How reproducible:

Always

Steps to Reproduce:
1. Select a non USA keyboard 
2. Make that the default remove the USA entry
3. Logout/Login
  
Actual results:

Keyoard layout set to USA and the USA entry reappeared in Keyboard preference --> layouts 

Expected results:

The keyboard layout be as the logged in user selected it to be. 

Additional info:

It would be a good to know how all this hangs together ( keyboard layout + X + Gnome ) so we can setup a testcase for this in autoQA.
Comment 1 James Laska 2009-10-26 07:26:30 EDT
Dup of bug#530452?  Please retest with gdm-2.28.1-7.fc12 (http://koji.fedoraproject.org/koji/buildinfo?buildID=138008) and CLOSE as DUPLICATE if resolved.
Comment 2 Jóhann B. Guðmundsson 2009-10-26 09:43:59 EDT
Fixes Keyboard preference in gdm/gnome but it looks like the keyboard defaults 101 instead of 105 keys in X ( runlevel 3 or tty2 in runlevel 5 ) we had something similar happen in what f9 rather than f8 cycle when I press the letter Þ ( / I think in USA 105 layout, the key closest to shift ) I get a box symbol instead. If I open up a terminal in gnome and press the key it correctly displays the letter instead of the boxed symbol.

*** This bug has been marked as a duplicate of bug 530452 ***
Comment 3 Jóhann B. Guðmundsson 2009-10-26 10:02:20 EDT
ignore the X remark it somehow magically fixed it self after I booted with nomodeset then again without nomodeset to confirm that nomodeset fixed it.

Note You need to log in before you can comment on or make changes to this bug.