Bug 530967 - gdm not starting, seems to dislike /etc/profile
gdm not starting, seems to dislike /etc/profile
Status: CLOSED DUPLICATE of bug 530770
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-26 06:27 EDT by James
Modified: 2014-03-16 23:20 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-26 16:22:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James 2009-10-26 06:27:42 EDT
Description of problem:
gdm is not starting and presenting a login screen. Running /etc/X11/prefdm by hand just exits, as does /usr/sbin/gdm. However, I can get gdm to work by commenting out the line

   test -f /etc/profile && . /etc/profile

in /usr/sbin/gdm. Leaving this in, the script seems to terminate before the binary is invoked. (Of course, this leaves things like the language unset.)

This started after a recent update, but I don't know the precise component causing the trouble.

Version-Release number of selected component (if applicable):
gdm-2.28.1-7.fc12.x86_64
xorg-x11-server-Xorg-1.7.0-5.fc12.x86_64
initscripts-9.00-1.x86_64
setup-2.8.9-1.fc12.noarch

How reproducible:
Always.

Actual results:
No automatic gdm start. Have to log in on a VT as root and run gdm-binary by hand.

Expected results:
Graphical login.
Comment 1 iarly selbir 2009-10-26 10:04:49 EDT
are you getting errors when running /etc/profile directly?

--
Fedora BugZappers Team Member
Comment 2 James 2009-10-26 10:23:00 EDT
Can't see anything particularly wrong (at least when run as an unprivileged user):

[james@rhapsody ~]$ source /etc/profile ; echo $?
0
[james@rhapsody ~]$
Comment 3 iarly selbir 2009-10-26 13:24:08 EDT
I can't reproduce here, I updated my gdm but was installed the version 2.28.1-5, looking at koji I noticed that next version than you have installed mentions about "- Attempt to fix crash some users see." maybe your problem... try get and update it

--
Fedora BugZappers Team Member
Comment 4 Bill Nottingham 2009-10-26 15:08:06 EDT
Do you have environment-modules installed?
Comment 5 Bill Nottingham 2009-10-26 15:16:19 EDT
See bug 530770.
Comment 6 James 2009-10-26 15:22:33 EDT
Yes:

[james@rhapsody ~]$ rpm -q environment-modules
environment-modules-3.2.7b-4.fc12.x86_64

(Extra note. This particular machine was upgraded from Fedora 11 via preupgrade, and worked fine afterwards. It's only been since this morning that this started.)

I'll try the update mentioned in Bug 530770.
Comment 7 James 2009-10-26 16:21:30 EDT
Fixed by new environment-modules package. Marking as duplicate and closing.
Comment 8 James 2009-10-26 16:22:03 EDT

*** This bug has been marked as a duplicate of bug 530770 ***

Note You need to log in before you can comment on or make changes to this bug.