Bug 53101 - Nautilus crashes on startup
Nautilus crashes on startup
Status: CLOSED DUPLICATE of bug 56506
Product: Red Hat Public Beta
Classification: Retired
Component: nautilus (Show other bugs)
roswell
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-03 12:45 EDT by adam.huffman
Modified: 2007-04-18 12:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-09 08:04:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description adam.huffman 2001-09-03 12:45:05 EDT
Description of Problem:

Nautilus crashes with a segmentation fault upon startup.
It fails to start during initialisation of the gnome session, and I am
unable to start it thereafter.

Version-Release number of selected component (if applicable):

1.0.4-39

How Reproducible:

Every time

Steps to Reproduce:
1. nautilus&
2. 
3. 

Actual Results:

crashes with seg. fault

Expected Results:

Nautilus should start and produce the desktop icons.

Additional Information:
Comment 1 Havoc Pennington 2001-09-03 16:19:47 EDT
Will need a backtrace (ideally with debug symbols) to get anywhere with this.
Not crashing on most machines.

I'll try making a package with symbols and put it up for download.
Comment 2 Havoc Pennington 2001-09-03 16:51:23 EDT
Can you install the RPMs at 
 http://people.redhat.com/~hp/test-packages/

then try running "gdb nautilus" and when it crashes type "backtrace" at the gdb
prompt and attach the resulting output to this bug report?

Thanks much!
Comment 3 adam.huffman 2001-09-05 06:11:21 EDT
It was working yesterday, but crashed today:

(gdb) r
Starting program: /usr/bin/nautilus 
[New Thread 1024 (LWP 1768)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1024 (LWP 1768)]
0x4042434c in _init () from /usr/lib/libeel.so.0
(gdb) bt
#0  0x4042434c in _init () from /usr/lib/libeel.so.0
#1  0x40973196 in __libc_start_main (main=0x8070cf0 <main>, argc=1, 
    ubp_av=0xbffffaa4, init=0x805f228 <_init>, fini=0x80b4230 <_fini>, 
    rtld_fini=0x4000cff8 <_dl_fini>, stack_end=0xbffffa9c)
    at ../sysdeps/generic/libc-start.c:129
Comment 4 Havoc Pennington 2001-09-05 10:43:57 EDT
Did you run the prelinker? That backtrace is before control flow ever hits the
Nautilus code.
Comment 5 adam.huffman 2001-09-05 11:12:15 EDT
I hadn't run the prelinker, no.  Just tried gdb nautilus having run prelink
and the backtrace is exactly the same.
Comment 6 Havoc Pennington 2001-09-05 13:02:37 EDT
Hrm. I'm clueless basically. Nautilus main() hasn't even been called in that
backtrace - so Nautilus code hasn't even had a chance to run. So it can't be
causing the segfault, I don't think. 

Maybe gdb is confused and the backtrace is bogus, the linker is broken and
crashes loading libeel, ... something bizarre like that.

I'm not able to reproduce the problem, so it's hard to debug further.
Comment 7 Geo. Anderson 2001-11-09 08:04:28 EST
I am seeing the same problem.  Relative Linux newbie, installing the shrinkwrap
7.2 just bought at Best Buy.  This after a few hours of experience playing with
7.1 and about 30 years working with computers as a machine designer and system
programmer.

Have also seen a scenario where the Panel app segfaults when Gnome is started
up.  (Gnome endlessly tries to restart Panel, so it does no good to ack the
error messages.  A new one just pops up.)  When the Panel is dead, Nautilus
seems to be o.k. and vice-versa.
Comment 8 Havoc Pennington 2002-02-27 11:26:08 EST

*** This bug has been marked as a duplicate of 56506 ***

Note You need to log in before you can comment on or make changes to this bug.