Bug 56506 - nautilus segfaults on brand new installed machine.
nautilus segfaults on brand new installed machine.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: nautilus (Show other bugs)
7.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: Alexander Larsson
Aaron Brown
:
: 37292 53101 57125 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-20 03:07 EST by Cristian Gafton
Modified: 2005-10-31 17:00 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-16 05:44:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rpm -qa on the affected system (11.87 KB, text/plain)
2001-11-20 03:09 EST, Cristian Gafton
no flags Details
Anaconda kickstart file created by the new install (3.27 KB, text/plain)
2001-11-20 03:11 EST, Cristian Gafton
no flags Details

  None (edit)
Description Cristian Gafton 2001-11-20 03:07:30 EST
Description of Problem:

7.2, semi-everything install (all components selected, but "Everything" not
selected). Finish install okay, machine reboots at gdm prompt, log into an
account created during install, and the panel starts, but no icons show up
on the GNOME desktop.

Open shell window, try to start Nautilus and it doesn't look happy:

[gafton@dual gafton]$ rpm -q nautilus
nautilus-1.0.4-43
[gafton@dual gafton]$ nautilus
Segmentation fault
[gafton@dual gafton]$ 


Version-Release number of selected component (if applicable):
nautilus-1.0.4-43

How Reproducible:
always
Comment 1 Cristian Gafton 2001-11-20 03:09:02 EST
Created attachment 38003 [details]
rpm -qa on the affected system
Comment 2 Cristian Gafton 2001-11-20 03:11:27 EST
Created attachment 38004 [details]
Anaconda kickstart file created by the new install
Comment 3 Cristian Gafton 2001-12-20 04:35:51 EST
Okay, redid the installation four times since and this is still happening. What
do I need to do to get some action on this baby?
Comment 4 Havoc Pennington 2002-02-26 18:05:19 EST
nautilus-segvs-on-fresh-install is not a super-common bug but there are a few
dups in here.

For most people it happens to, it always happens, even when reinstalling.

Usually people say a fresh install, so the contents of home dir can't be the
problem.

Perhaps it's some detail of partitioning or hardware...

A backtrace with symbols is probably necessary.
Comment 5 Havoc Pennington 2002-02-27 11:26:03 EST
*** Bug 53101 has been marked as a duplicate of this bug. ***
Comment 6 Sergio Perani 2002-02-27 12:27:06 EST
I do not know if this could help, I submit comments for bug 57698 and 
I found a similar behaviour, but not always reproducible. 
Starting the kernel with the option "ide=nodma" solved the problem.
Comment 7 Havoc Pennington 2002-02-27 14:57:33 EST
*** Bug 57125 has been marked as a duplicate of this bug. ***
Comment 8 Havoc Pennington 2002-02-27 14:59:05 EST
*** Bug 57125 has been marked as a duplicate of this bug. ***
Comment 9 Havoc Pennington 2002-02-27 15:01:20 EST
A couple of the dups have backtraces or straces that indicate nautilus dies
before entering main(), during libc initialization. The last system call is
sysctl() to find out the kernel version (I think, something like that).

Dups mention that ide=nodma may have helped.

The pattern seems to be that the bug is reproduceable on a specific
machine/hardware, but never happens on other machines/hardware. Do not yet know
which hardware causes issues.
Comment 10 Havoc Pennington 2002-02-27 16:27:08 EST
Suggestion was made to try running Nautilus with LD_DEBUG=all and attach the
resulting output. That would be useful if anyone has a chance.
Comment 11 Havoc Pennington 2002-03-04 14:49:33 EST
*** Bug 37292 has been marked as a duplicate of this bug. ***
Comment 12 Need Real Name 2002-03-11 02:59:53 EST
Hi!

I am too a sigsegv of nautilus, but not in a fresh install.
It's when I install the nvidia drivers that nautilus doesn't start.
There's another strange thing: If nautilus successfully start, the bar at the
bottom doesn't start, and a large amount of error messages appears.
But I think it's the same problem cause when I do an strace of this, the last
thing started is the sysctl(). 
Do I need to use the nodma?
Do the result of the strace need to be posted here to help resolving this bug?

Thanks for any help.
Comment 13 Havoc Pennington 2002-03-11 08:37:22 EST
Rafael, if it's really the nvidia drivers that are responsible, that's not
something we can debug; nvidia drivers are closed source code we don't have
access too, and they modify both the kernel and the X server, which can easily
result in system crashes and other badness.

If I had an idea what to suggest for debugging these reports, I would.
Unfortunately I think in some or all of these cases something is wrong on a
deeper level than Nautilus - maybe hardware, maybe kernel, maybe X. The reason I
think that is that the bug happens consistently on some machines but is totally
unreproduceable otherwise.

Nautilus probably also has some startup bugs if you have certain things
on your filesystem or in fstab or who knows, but for most of these reports
Nautilus is dying before it really starts up, so I don't think those are 
being triggered in these reports.
If other people seeing this also have nvidia drivers, that would be useful 
info; please add comments to that effect. In fact the most detailed description
each reporter can offer of their hardware might be useful.
Comment 14 Preston Brown 2002-03-19 12:04:43 EST
If Cristian can reproduce the problem at will, let's get a version of nautilus with
debugging symbols installed on that machine and dig deeper.  Right?
Comment 15 Need Real Name 2002-10-18 16:20:47 EDT
7.3 running Linux version 2.4.18-17.7.xsmp (bhcompile@daffy.perf.redhat.com)
(gcc version 2.96 20000731 (Red Hat Linux 7.3 2.96-112)) #1 SMP Tue Oct 8
12:37:04 EDT 2002
After installing Nvidia's graphics card drivers, nautilus wont start
nautilus tried to start, desktop background bounces between the image I had set
and solid color white.
Nvidia kernel 3123 
Nvidia GLX 3123
Nvidia Gforce 2 GTS
Gnome nautilus 1.0.6
Comment 16 Alexander Larsson 2003-01-16 05:44:08 EST
This seems to be a very stange bug that depends on some strange interaction
between hardware, kernel, libc and nautilus. Since all of these have changed a
lot since 7.2 and we haven't gotten any more reports like this for later version
i assume that it has been fixed.

Note You need to log in before you can comment on or make changes to this bug.