Bug 531109 - Hibernate failure:
Hibernate failure:
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: DeviceKit-power (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-10-26 18:14 EDT by Michael De La Rue
Modified: 2009-10-30 03:47 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-29 07:36:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
tarball with all /var/log from system (1.98 MB, application/octet-stream)
2009-10-26 18:26 EDT, Michael De La Rue
no flags Details

  None (edit)
Description Michael De La Rue 2009-10-26 18:14:57 EDT
Description of problem:
System refuses to hibernate and gives messages like the following:

Oct 26 22:27:50 ivortest gnome-session[1868]: devkit-power-gobject-WARNING: Couldn't hibernate: Swap space is encrypted
Oct 26 22:27:50 ivortest gnome-session[1868]: WARNING: Unexpected hibernate failure: Swap space is encrypted

Version-Release number of selected component (if applicable):
kernel-2.6.31.5-96.fc12.x86_64


How reproducible:
multilple times with rebots between.  

Steps to Reproduce:
1. install fedora 12 beta
2. boot up 
3. try to hibernate
  
Actual results:
the hibernate fails leaving a blank screen.
There is are some messages in the log: 
Oct 26 22:27:50 ivortest gnome-session[1868]: devkit-power-gobject-WARNING: Couldn't hibernate: Swap space is encrypted
Oct 26 22:27:50 ivortest gnome-session[1868]: WARNING: Unexpected hibernate failure: Swap space is encrypted

Expected results:
system should hibernate as normal.

Additional info:
sosreport doesn't work for me so I attach various logs in a tarball.  
See also Bug 530899 but I think that's masked by the current bug.
Comment 1 Michael De La Rue 2009-10-26 18:26:16 EDT
Created attachment 366166 [details]
tarball with all /var/log from system

system didn't have any encrypted swap.  /proc swaps looks like

Filename				Type		Size	Used	Priority
/dev/mapper/VolGroup00-LogVol01         partition	5111800	0	-1
/dev/mapper/VolGroup01-LogVol03         partition	2031608	0	-2
/dev/mapper/VolGroup03-LogVol01         partition	4095992	0	-3
Comment 2 Gianluca Sforna 2009-10-28 19:55:31 EDT
I think I'll propose this as a blocker. We are touting suspend/hibernate works out of the box even with nouveau; I updated to F12Beta just to test it on my laptop and it fails...
Comment 3 Matthias Clasen 2009-10-29 07:36:00 EDT
This is fixed in DeviceKit-power-012-2.fc12
Comment 4 Michael De La Rue 2009-10-30 03:47:40 EDT
This particular problem does seem to be fixed (the system now hibernates and the power goes off) so I'm back to having Bug 530899 and other similar fun.  

thanks..

Note You need to log in before you can comment on or make changes to this bug.