Bug 531195 - [gdm] fails to start (probably due to update)
Summary: [gdm] fails to start (probably due to update)
Keywords:
Status: CLOSED DUPLICATE of bug 530770
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm
Version: rawhide
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: jmccann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F12Blocker, F12FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2009-10-27 08:20 UTC by Joachim Frieben
Modified: 2015-01-14 23:23 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-29 17:29:42 UTC


Attachments (Terms of Use)

Description Joachim Frieben 2009-10-27 08:20:33 UTC
Description of problem:
After a fresh install from the Fedora "rawhide" tree on 2009-10-25, the GDM login manager seems to work correctly. It's (probably) after updating to a later Koji version, that it does not start up anymore after rebooting the system.

Version-Release number of selected component (if applicable):
gdm-2.28.1-7.fc12.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Install current Fedora "rawhide".
2. Update package gdm to later Koji version.
3. Restart system.
  
Actual results:
System starts up but X does not get started when entering runlevel 5.

Expected results:
X and GDM start up as expected.

Additional info:
A suspicious entry appears in /var/log/secure related to the update of package gdm:

  "localhost useradd[2459]: failed adding user 'gdm', data deleted"

Comment 1 Matthew Miller 2009-10-27 14:46:07 UTC
Same here. If run from the command line as root afterward, gdm just exits silently.

I have the same log entry in /var/log/secure.

The gdm user *does* exist, with what looks like the correct information (uid 42, home dir /var/lib/gdm, shell /sbin/nologin).

I don't have a koji version, though -- just what's in rawhide right now.

gdm-2.28.1-5.fc12.x86_64

Comment 2 Joachim Frieben 2009-10-27 15:34:01 UTC
(In reply to comment #1)
Issue seems to have been fixed by today's "rawhide" update including a fair number of GNOME updates - can you confirm? Also gone are erratically missing sound and flickering keyboard lights apparently related to this bug.

Comment 3 Matthew Miller 2009-10-27 15:40:33 UTC
Joachim -- I see only gdm-2.28.1-5.fc12 in rawhide right now, and that's what's not working for me.

Comment 4 Ray Strode [halfline] 2009-10-27 21:22:18 UTC
perhaps a transient selinux bug?

Comment 5 Matthew Miller 2009-10-27 22:41:47 UTC
Not here -- selinux is disabled on this box after running into eighteen too many times when that *was* the case. :)

Comment 6 Ray Strode [halfline] 2009-10-27 23:20:04 UTC
It sounds like this may not be related to gdm, though.  Can you try doing a full rawhide update?

Might be gnome-settings-daemon or something else...

Comment 7 Ray Strode [halfline] 2009-10-27 23:20:41 UTC
Also, Matt, do you have nvidia hardware?

Comment 8 Matthew Miller 2009-10-27 23:58:44 UTC
ATI Radeon M76XT. This happened after yum upgrade to rawhide this morning and reboot. Oh, and installed the koji kernel to fix from bug #517625.

I'll try again tomorrow. Nothing is logged and the binary just exits. Nothing is apparently logged. I switched to kdm as a workaround, but I'm happy to try any diagnostics you want. I'm actually using xfce as the desktop once logged in.

Comment 9 Alexey Torkhov 2009-10-29 10:56:48 UTC
I'm not sure, if this is the same issue or not, but my gdm also has similar simptoms with fail to start. But it is able to start when called with "sh /usr/sbin/gdm".

Log from wrapper script if set -x added to it:
http://atorkhov.fedorapeople.org/gdm-set-x.log

Log from sh -x gdm:
http://atorkhov.fedorapeople.org/gdm-sh-x.log

As seen, when called directly, it stops at ". /etc/profile.d/modules.sh". If called via sh, it continues though that call. Very weird.

Comment 10 Matthew Miller 2009-10-29 11:10:34 UTC
Ah -- it hadn't even occurred to me to check if the gdm binary was a script. I also have environment-modules installed. I'll poke around today and see where that gets me.

Comment 11 Adam Williamson 2009-10-29 17:07:02 UTC
I'm setting this as a blocker to be reviewed tomorrow, as it's a worrying looking bug.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 12 Joachim Frieben 2009-10-29 17:24:25 UTC
(In reply to comment #1)
Matt, as stated in a previous comment, the issue is gone for me. I should add though that as long as GDM failed to start up as expected, I was nevertheless able to bring it up by executing 'gdm-binary' from a root shell. Have you tried that one, too? I haven't seen GDM exit silently then as you seem to observe. It is also true however, that I was unable to find any trace of the previous failed attempt in any log file.

Comment 13 Ray Strode [halfline] 2009-10-29 17:29:42 UTC
Looking at the changelog for environment-modules, this is already fixed.

*** This bug has been marked as a duplicate of bug 530770 ***

Comment 14 Adam Williamson 2009-10-29 17:39:45 UTC
whoops, I should've caught that, sorry Ray.

Matthew, can you confirm that it works if you update to environment-modules-3.2.7b-5.fc12 ?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 15 Matthew Miller 2009-10-29 17:49:59 UTC
Yes, just got to testing this, and it does indeed work with the updated environment-modules package. Thanks guys.


Note You need to log in before you can comment on or make changes to this bug.