Bug 531204 - ocaml-docs doesn't install info files because using wrong args to install-info
Summary: ocaml-docs doesn't install info files because using wrong args to install-info
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: ocaml
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Richard W.M. Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 520971 (view as bug list)
Depends On:
Blocks: 531206
TreeView+ depends on / blocked
 
Reported: 2009-10-27 09:58 UTC by Richard W.M. Jones
Modified: 2010-06-16 14:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 531206 (view as bug list)
Environment:
Last Closed: 2009-10-27 10:23:32 UTC
Type: ---


Attachments (Terms of Use)

Description Richard W.M. Jones 2009-10-27 09:58:29 UTC
Description of problem:

Although ocaml-docs comes with info files, these are never
installed because we call /sbin/install-info with old-style
Debian args, and install-info doesn't really work properly
when you use those.

Version-Release number of selected component (if applicable):

ocaml-docs-3.11.1-4.fc13.x86_64
and all previous versions

How reproducible:

Always.

Steps to Reproduce:
1. Install ocaml.
2. Run 'info' or 'info ocaml'
3.
  
Actual results:

When running 'info' you'll see the OCaml page is missing from
the info directory.

When running 'info ocaml' you'll see the man page which is the
info fallback position when it thinks that there is no info
file installed.

Expected results:

Should show real OCaml info page.  Should be in directory.

Additional info:

The correct parameters which install ocaml.info are:

/sbin/install-info --entry="* ocaml: (ocaml).   The Objective Caml compiler and programming environment" --section="Programming" /usr/share/info/ocaml.info /usr/share/info/dir

Comment 1 Richard W.M. Jones 2009-10-27 10:06:09 UTC
Build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1771902

Comment 2 Matt McCutchen 2010-06-16 14:10:12 UTC
*** Bug 520971 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.