Bug 531219 - internal LCD under the closed lid used as primary display
internal LCD under the closed lid used as primary display
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
card_965GM
: Triaged
Depends On:
Blocks: 595644
  Show dependency treegraph
 
Reported: 2009-10-27 07:09 EDT by Dan Horák
Modified: 2010-05-25 05:27 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 595644 (view as bug list)
Environment:
Last Closed: 2010-04-16 08:33:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg.log from GDM (108.92 KB, text/plain)
2009-10-27 07:09 EDT, Dan Horák
no flags Details

  None (edit)
Description Dan Horák 2009-10-27 07:09:39 EDT
Created attachment 366235 [details]
Xorg.log from GDM

Description of problem:
X starts with the internal (but the lid is closed) LCD as primary and external LCD as secondary. I need to open the lid, now see the gdm login page there and then some flickering occurs and then both displays have the same content (internal is cloned after external). No xorg.conf is used.

Version-Release number of selected component (if applicable):
xorg-x11-drv-intel-2.9.0-2.fc12.x86_64
kernel-2.6.31.5-96.fc12.x86_64

also tried
xorg-x11-drv-intel-2.9.1-1.fc12
kernel-2.6.31.5-96.fc12.x86_64

How reproducible:
always


Steps to Reproduce:
1. start the computer
  
Actual results:
gdm login screen shown on the internal LCD


Expected results:
gdm login screen shown on the external LCD


Additional info:
The machine is Lenovo T61 placed in the docking station, external LCD is connected via DVI.
Comment 1 Dan Horák 2009-10-27 07:15:23 EDT
The system was recently upgraded to F-12 from F-10, where the displays worked as expected.
Comment 2 Matěj Cepl 2009-11-05 12:19:26 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages (at least F12Beta, but even better if the very latest versions).

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 3 Dan Horák 2009-11-06 11:33:00 EST
I have fully updated my laptop today and there is no change in the described behaviour.
Comment 4 Bug Zapper 2009-11-16 09:24:31 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Joel Uckelman 2009-11-20 22:09:45 EST
I'm seeing precisely the same problem with F12 and a docked Thinkpad T61 with an external CRT. In F11 and before, if I booted with the laptop in the dock and the lid closed, the CRT would be made the sole display. In F12 what I'm seeing is that both the CRT and laptop panel are active, with the laptop panel as the primary display, despite that the lid is closed. Afterwards, when I try to close the lid, my laptop goes into suspend (!) which never happened before when an external monitor was connected.

Possibly related is the fact the detection of the resolution capabilities of my external monitor also broken when I upgraded from F11 to F12, which I've reported as Bug 539785.

If there's any more information I can provide, please let me know. These two problems combined are making work with my laptop rather unpleasant.
Comment 6 Timo Sorvoja 2010-04-09 15:27:54 EDT
I can confirm that this also happens with Dell Latitude D610 wih docking station.
Comment 7 Dan Horák 2010-04-16 08:10:05 EDT
The issue was probably resolved with the update to xorg-x11-server-Xorg-1.7.6-1.fc12, because it doesn't happen with an up-to-date laptop anymore.
Comment 8 Joel Uckelman 2010-04-16 08:23:17 EDT
I'm not seeing this problem anymore with the current xorg.
Comment 9 Dan Horák 2010-04-16 08:33:52 EDT
Switching to xorg-x11-server and closing.

Note You need to log in before you can comment on or make changes to this bug.