Bug 531226 - cannot hibernate because of encrypted swap
cannot hibernate because of encrypted swap
Status: CLOSED DUPLICATE of bug 530913
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-27 07:57 EDT by Stefan Assmann
Modified: 2009-10-27 14:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-27 14:26:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Assmann 2009-10-27 07:57:34 EDT
Description of problem:
System assumes that swap is encrypted but it is not.

The relevant lines from /var/log/messages
Oct 27 12:27:01 localhost gnome-session[1464]: devkit-power-gobject-WARNING: Couldn't hibernate: Swap space is encrypted
Oct 27 12:27:01 localhost gnome-session[1464]: WARNING: Unexpected hibernate failure: Swap space is encrypted
Oct 27 12:27:01 localhost kernel: integrated sync not supported

[root@eeepc ~]# cat /proc/swaps 
Filename                                Type            Size    Used    Priority
/dev/sda2                               partition       2048276 0       -1
[root@eeepc ~]# cat /etc/crypttab 
luks-9df791c5-5ea2-44d4-b5f0-d21a0c0e0d0a UUID=9df791c5-5ea2-44d4-b5f0-d21a0c0e0d0a none
[root@eeepc ~]# ls -al /dev/disk/by-uuid/
total 0
drwxr-xr-x 2 root root 100 2009-10-27 12:10 .
drwxr-xr-x 5 root root 100 2009-10-27 12:10 ..
lrwxrwxrwx 1 root root  10 2009-10-27 12:10 2510f757-712d-4c68-a238-7be8ea25b0e1 -> ../../sda2
lrwxrwxrwx 1 root root  10 2009-10-27 12:10 6ab71ff2-1df4-4c9e-9bd9-4980bfe87680 -> ../../sda1
lrwxrwxrwx 1 root root  10 2009-10-27 12:10 9df791c5-5ea2-44d4-b5f0-d21a0c0e0d0a -> ../../sda3

How reproducible:
always

Steps to Reproduce:
1. try to hibernate
  
Actual results:
hibernate fails

Expected results:
hibernate successfully
Comment 1 Matthias Clasen 2009-10-27 14:26:00 EDT

*** This bug has been marked as a duplicate of bug 530913 ***

Note You need to log in before you can comment on or make changes to this bug.