Bug 530913 - Couldn't hibernate: Swap space is encrypted
Couldn't hibernate: Swap space is encrypted
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: DeviceKit-power (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
: 531226 531497 (view as bug list)
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-10-25 21:27 EDT by Mads Kiilerich
Modified: 2009-10-29 07:16 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-29 06:36:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2009-10-25 21:27:18 EDT
Description of problem:

Hibernate used to work on my machine. But now after todays yum update I get

Oct 26 02:14:26 localhost gnome-session[11541]: devkit-power-gobject-WARNING: Couldn't hibernate: Swap space is encrypted
Oct 26 02:14:26 localhost gnome-session[11541]: WARNING: Unexpected hibernate failure: Swap space is encrypted

But I am pretty sure that my swap space is _not_ encrypted:

[root@localhost ~]# cat /proc/swaps 
Filename				Type		Size	Used	Priority
/dev/mapper/VolGroup00-LogVol01         partition	1966072	0	-1
[root@localhost ~]# blkid |grep swap
/dev/mapper/VolGroup00-LogVol01: TYPE="swap" 
/dev/VolGroup00/LogVol01: TYPE="swap" 
[root@localhost ~]# grep swap /etc/fstab 
/dev/VolGroup00/LogVol01 swap                   swap    defaults        0 0


I assume it was caused by my upgrade to DeviceKit-power-012-1.fc12.i686

* Mon Oct 19 2009 Richard Hughes <richard@hughsie.com> - 012-1
- Update to 012
- Detect encrypted swap and prevent hibernate in this case.
- When we do a delayed refresh, actually do 5 x 1 second apart rather
  than 1 x 3 seconds which should fix some slow battery devices.

(but other packages - such as the kernel - was updated at the same time, so I'm not 100% sure)


Version-Release number of selected component (if applicable):

DeviceKit-power-012-1.fc12.i686
kernel-PAE-2.6.31.5-96.fc12.i686
Comment 1 Matthias Clasen 2009-10-26 11:31:16 EDT
Well, _is_ your swap space encrypted ?
Comment 2 Mads Kiilerich 2009-10-26 11:37:19 EDT
I have not intentionally made the swap space encrypted. How can I prove that it isn't?

I assume that encrypted swap space requires /etc/crypttab to configure a dm device in /dev/mapper which should be used as swap device? I have no /etc/crypttab and as you can see I use /dev/mapper/VolGroup00-LogVol01 directly.
Comment 3 Matthias Clasen 2009-10-26 11:48:16 EDT
I don't know. It might well be that DK-power is getting it wrong and thinks your swap is encrypted, even though it is not. 

I'll ask Richard to look into this when he's back
Comment 4 Matthias Clasen 2009-10-27 14:26:00 EDT
*** Bug 531226 has been marked as a duplicate of this bug. ***
Comment 5 Matthias Clasen 2009-10-27 14:27:27 EDT
Looks like it is not an isolated incident, putting on F12Blocker just in case
Comment 6 Matthias Clasen 2009-10-28 22:53:56 EDT
*** Bug 531497 has been marked as a duplicate of this bug. ***
Comment 7 Matthias Clasen 2009-10-28 22:56:41 EDT
Fixed in DeviceKit-power-012-2.fc12
Comment 8 Richard Hughes 2009-10-29 06:36:57 EDT
Thanks.
Comment 9 Mads Kiilerich 2009-10-29 07:16:42 EDT
DeviceKit-power-012-2.fc12 works for me - thanks!

Note You need to log in before you can comment on or make changes to this bug.