Bug 531343 - [abrt] crash detected in wallpapoz-0.4.1-11.svn92_trunk.fc12
Summary: [abrt] crash detected in wallpapoz-0.4.1-11.svn92_trunk.fc12
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wallpapoz
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Mamoru TASAKA
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:1732a30b
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-27 19:29 UTC by ROMAN
Modified: 2010-02-20 12:30 UTC (History)
70 users (show)

Fixed In Version: wallpapoz-0.4.1-15.svn92_trunk.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-18 22:19:41 UTC


Attachments (Terms of Use)
File: backtrace (539 bytes, text/plain)
2009-10-27 19:30 UTC, ROMAN
no flags Details
/.wallpapoz/wallpapoz.xml (272 bytes, text/plain)
2009-11-01 17:42 UTC, ROMAN
no flags Details

Description ROMAN 2009-10-27 19:29:59 UTC
abrt detected a crash.


How to reproduce
-----
1.
2.
3.


Additional information
======


Attached files
----
backtrace

cmdline
-----
python /usr/libexec/daemon_wallpapoz 


component
-----
wallpapoz


executable
-----
/usr/libexec/daemon_wallpapoz


kernel
-----
2.6.31.5-96.fc12.i686.PAE


package
-----
wallpapoz-0.4.1-11.svn92_trunk.fc12


uuid
-----
1732a30b

Comment 1 ROMAN 2009-10-27 19:30:02 UTC
Created attachment 366330 [details]
File: backtrace

Comment 2 Mamoru TASAKA 2009-10-27 19:49:14 UTC
Would you please
- write the details how to reproduce this issue
- tell me what desktop environment you are using
  (and whether some additional desktop effects like compiz are enabled
   or not)
- attach ~/.wallpapoz/wallpapoz.xml
- write the result of "$ xprop -root _NET_CURRENT_DESKTOP"
?

Comment 3 Mamoru TASAKA 2009-10-27 20:01:48 UTC
Also would you tell me
- how many workspaces does your desktop has?

Comment 4 ROMAN 2009-10-31 10:33:24 UTC
(In reply to comment #2)
> Would you please
> - write the details how to reproduce this issue
> - tell me what desktop environment you are using
>   (and whether some additional desktop effects like compiz are enabled
>    or not)
> - attach ~/.wallpapoz/wallpapoz.xml
> - write the result of "$ xprop -root _NET_CURRENT_DESKTOP"
> ?  
1.I'm using GNOME desktop. Additional desktop effects not enable.
2. wallpapoz.xml:
<!DOCTYPE Wallpapoz>
<wallpapoz interval="5" random="0" style="2" type="workspace">
<workspace name="rename this" no="1">
<file>
/home/ROMA/Картинки/ABSTRACT-Burning_1600x1200.jpg
</file>
</workspace>
</wallpapoz>
3. result of "$ xprop -root _NET_CURRENT_DESKTOP" "_NET_CURRENT_DESKTOP(CARDINAL) = 0"

Comment 5 ROMAN 2009-10-31 10:34:26 UTC
I have 4 workspace

Comment 6 Mamoru TASAKA 2009-10-31 14:57:07 UTC
And this issue is still reproducible? If so would you
tell me how to reproduce it?

Comment 7 Mamoru TASAKA 2009-10-31 18:14:35 UTC
Well, would you "attach" (not copy and paste) wallpapoz.xml file?

Comment 8 ROMAN 2009-11-01 17:42:34 UTC
Created attachment 367018 [details]
/.wallpapoz/wallpapoz.xml

Comment 9 ROMAN 2009-11-01 17:44:15 UTC
(In reply to comment #6)
> And this issue is still reproducible? If so would you
> tell me how to reproduce it?  

I'm sorry? but i dont know how to reproduce it

Comment 10 Mamoru TASAKA 2009-11-01 18:52:30 UTC
Well, for now I guess that in both cases (i.e. both on bug 531342 and bug 531343)
when wallpapoz crashed "xprop" (in xorg-x11-utils) returned unexpected
result, so this may be a bug in X packages or the desktop environment
being used, however I am not sure...

When you recounter this bug, please let me know it.

Comment 11 Ola Thoresen 2009-11-03 11:01:20 UTC
I have this issue a few times a day.
Not 100% reproducible, but seems to be related to an X-crash (that is not detected by abrtd) happening when viewing some random website in firefox.

Comment 12 Bug Zapper 2009-11-16 14:26:50 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 13 Mamoru TASAKA 2009-11-20 00:59:17 UTC
Once closing this bug as the reporter says this bug
is not reproducible.

Comment 14 Peter Larsen 2009-11-20 14:26:01 UTC
I had this problem with a F12 install (upgrade from F11). It's not rawhide only.

Comment 15 edo 2009-11-20 14:48:23 UTC
I have got this problem (reported by "abrt") after a F12 install (upgrade from F11) also.

Comment 16 Mamoru TASAKA 2009-11-20 15:06:14 UTC
(In reply to comment #15)
> I have got this problem (reported by "abrt") after a F12 install (upgrade from
> F11) also.  

This bug is already closed as the original reporter says that
the bug reported was not reproducible. Even if you see wallpapoz crash,
it does not mean that you and the original reporter are seeing the
same issue. If the crash you see is reproducible, please file
another bug report, then I will triage it.

Comment 17 Mamoru TASAKA 2009-11-23 02:46:35 UTC
Again:

This bug is already closed as the original reporter says that
the bug reported was not reproducible. Even if you see wallpapoz crash,
it does not mean that you and the original reporter are seeing the
same issue. If the crash you see is reproducible, please file
another bug report, then I will triage it.

Comment 18 Ola Thoresen 2009-11-23 07:11:05 UTC
My guess is that these Cc-s are added by abrt (like mine).
I also guess that what the original reporter ment was that he can not reliably reproduce the problem himself, not that the problem had gone away.
In my case abrt reported this bug when X crashed. But if it was wallpapoz that made X crash or vice versa is impossible for me to tell.

In any case, as long as abrt continues to add more people to this bug, I think it needs a closer look.

Comment 19 Mamoru TASAKA 2009-11-23 10:53:59 UTC
The problem is:
- "Abrt reported that this was a bug in wallpapoz" does not
  mean that a bug is really in wallpapoz. For example see
  bug 531342 comment 6. And I already have another cases in
  which abrt reported a bug to wallpapoz but the real bug was
  in nspluginwrapper and the contents of the bug really had
  no relation with wallpapoz.

  So please note that abrt itself may have a bug. That there
  are not a few people included in the CC list of this bug may
  be also due to a bug in abrt. So without any further information
  I cannot understand what is happening any more.

  By the way I don't think people are installing wallpapoz
  by default because wallpapoz is not included in F-12 installation
  DVD.

Comment 20 Mamoru TASAKA 2010-02-03 12:51:32 UTC
Now this issue is reproducible to me, reopening.

Comment 21 Fedora Update System 2010-02-03 20:30:32 UTC
wallpapoz-0.4.1-12.svn92_trunk.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/wallpapoz-0.4.1-12.svn92_trunk.fc12

Comment 22 Fedora Update System 2010-02-03 20:31:01 UTC
wallpapoz-0.4.1-12.svn92_trunk.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/wallpapoz-0.4.1-12.svn92_trunk.fc11

Comment 23 Fedora Update System 2010-02-05 01:39:14 UTC
wallpapoz-0.4.1-12.svn92_trunk.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wallpapoz'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-1483

Comment 24 Fedora Update System 2010-02-08 18:56:30 UTC
wallpapoz-0.4.1-15.svn92_trunk.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/wallpapoz-0.4.1-15.svn92_trunk.fc12

Comment 25 Fedora Update System 2010-02-08 18:58:08 UTC
wallpapoz-0.4.1-15.svn92_trunk.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/wallpapoz-0.4.1-15.svn92_trunk.fc11

Comment 26 Fedora Update System 2010-02-09 21:00:58 UTC
wallpapoz-0.4.1-15.svn92_trunk.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wallpapoz'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-1687

Comment 27 Fedora Update System 2010-02-18 22:18:57 UTC
wallpapoz-0.4.1-15.svn92_trunk.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 28 Fedora Update System 2010-02-18 22:29:36 UTC
wallpapoz-0.4.1-15.svn92_trunk.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.