Bug 53140 - rhn unable to set up conection tunnel thru proxy
rhn unable to set up conection tunnel thru proxy
Status: CLOSED DUPLICATE of bug 54740
Product: Red Hat Linux
Classification: Retired
Component: rhn_register (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-04 10:28 EDT by mike cudmore
Modified: 2015-01-07 18:51 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-05 04:11:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description mike cudmore 2001-09-04 10:28:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
looking for help in setting file /etc/sysconfig/rhn/rhn_register

currently file is
# Automatically generated Red Hat RHN Registration config file, do not
edit.
# Format: 1.0
noSSLServerURL[comment]=Remote server URL without SSL
noSSLServerURL=http://www.rhns.redhat.com/XMLRPC

enableProxy[comment]=Use a HTTP Proxy
enableProxy=1

httpProxy[comment]=HTTP proxy in host:port format, e.g.
squid.redhat.com:3128
httpProxy=http://autoproxy.uk.company.com:80

serverURL[comment]=Remote server URL
serverURL=https://www.rhns.redhat.com/XMLRPC

debug[comment]=Whether or not debugging is enabled
debug=1


Have latest rhn patches from errata 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. set file as shown above
2. run rhn
3.
	

Actual Results:  got error message given

Expected Results:  registered with RHN

Additional info:
Comment 1 Jay Turner 2001-09-04 10:34:29 EDT
What error messages are you getting exactly?
Comment 2 mike cudmore 2001-09-04 10:48:16 EDT
error message is 

Fatal error retrieving welcome message:
unable to set up CONNECTION tunnel

Comment 3 Jay Turner 2001-09-04 11:03:53 EDT
What version of rhn_register is this?
Comment 4 mike cudmore 2001-09-04 11:10:46 EDT
1.3.2-1
Comment 5 Jay Turner 2001-09-04 11:46:31 EDT
Try it without the 'http://' on the proxy declaration.  I think that's the problem.
Comment 6 mike cudmore 2001-09-05 04:11:46 EDT
Thanks.

Now I get 

	Host not found

The file is ........


# Automatically generated Red Hat RHN Registration config file, do not edit.
# Format: 1.0
noSSLServerURL[comment]=Remote server URL without SSL
noSSLServerURL=http://www.rhns.redhat.com/XMLRPC

enableProxy[comment]=Use a HTTP Proxy
enableProxy=1

httpProxy[comment]=HTTP proxy in host:port format, e.g. squid.redhat.com:3128
httpProxy=autoproxy.uk.deuba.com:80

serverURL[comment]=Remote server URL
serverURL=https://www.rhns.redhat.com/XMLRPC

debug[comment]=Whether or not debugging is enabled
debug=1
Comment 7 Adrian Likins 2001-11-01 18:45:24 EST
the config engine for the next version of rhn_register is going
to be more robust about the format of the proxy name. 

This has been fixed in the 7.2 version, and should be available
for 7.1 shortly.

*** This bug has been marked as a duplicate of 54740 ***

Note You need to log in before you can comment on or make changes to this bug.