Bug 54740 - proxy conf mishandles the hostname
Summary: proxy conf mishandles the hostname
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhn_register   
(Show other bugs)
Version: 7.1
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
: 53140 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-17 15:46 UTC by Joe Simmons
Modified: 2015-01-07 23:52 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-27 00:13:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joe Simmons 2001-10-17 15:46:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2)
Gecko/20010726 Netscape6/6.1

Description of problem:
When you define a proxy host in rhn-register --config, it truncates the
first 7 characters of the hostname.  A workaround is to pad the beginning
of the hostname with garbage characters.  This is easily reproducible.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. run rhn-register --config
2. select option 2, httpProxy
3. input hostname
4. run rhn_register
	

Actual Results:  Error: Host not found

Expected Results:  It should have proceeded into the rhn_register setup.

Additional info:

This happens with both the gui and text versions.  If you pad the first 7
characters of the hostname with characters, it works fine.

Comment 1 Adrian Likins 2001-11-01 23:32:33 UTC
This is fixed in the 7.2 version of the client,
and in an errata for 7.1 to be issued soon.

Comment 2 Adrian Likins 2001-11-01 23:44:07 UTC
*** Bug 55055 has been marked as a duplicate of this bug. ***

Comment 3 Adrian Likins 2001-11-01 23:45:17 UTC
*** Bug 53140 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.