Bug 53166 - disagreement about kdmrc location
disagreement about kdmrc location
Status: CLOSED DUPLICATE of bug 52769
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-04 15:55 EDT by James Manning
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-04 16:00:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James Manning 2001-09-04 15:55:21 EDT
Description of Problem:

kdebase puts kdmrc in /etc/kde/kdm
jmm@jmm:/home/jmm> rpm -ql kdebase|grep kdmrc
/etc/kde/kdm/kdmrc

But, kdm_config is looking for it over in /usr/share/config/kdm
jmm@jmm:/home/jmm> strings `which kdm_config`|grep kdmrc
/usr/share/config/kdm/kdmrc

This results in kdm failing to start until I copy over kdmrc to the location 
kdm_config expects it at:
Sep  4 15:37:16 jmm kdm_config[1575]: Cannot open config file 
/usr/share/config/kdm/kdmrc
Sep  4 15:37:16 jmm kdm[1570]: Cannot open access control file 
/usr/share/config/kdm/Xaccess, no XDMCP reqeusts will be granted

(second line prob. not related, just included in case it shows a similar issue 
elsewhere)

Version-Release number of selected component (if applicable):
kdebase-2.2-9

How Reproducible:
100%

Steps to Reproduce:
1. RC1 to RC2 up2date
2. restart X

(I know, inter-beta up2date/upgrade isn't supported, but this is an issue 
internal to the kdebase package by itself, so the method of it getting installed 
would appear to be irrelevant)

Actual Results:
failure of kdm to start due to no config file

Expected Results:
config file in place, kdm starts fine

Additional Information:
Comment 1 James Manning 2001-09-04 16:00:12 EDT
ok, so this was caused by:

* Tue Aug 21 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-6
 
- Move /usr/share/config/kdm to /etc/kde/kdm, fixes #51095
  IF YOU ARE UPDATING FROM A VERSION BETWEEN 2.2-0.alpha1.1 AND 
2.2-5,  REMOVE THE OLD PACKAGE BEFORE INSTALLING, OR rm -rf 
/usr/share/config/kdm  FIRST!

I don't get why kdm_config is built with so many refs to the old location:

jmm@jmm:/home/jmm> strings `which kdm_config`|grep share/config
/usr/share/config/kdm/Xaccess
/usr/share/config/kdm/kdmkeys
/usr/share/config/kdm/Xreset
/usr/share/config/kdm/Xsetup
/usr/share/config/kdm/kdmrc
/usr/share/config/kdm/Xservers
/usr/share/config/kdm/Xsession
/usr/share/config/kdm/Xstartup
Comment 2 Bernhard Rosenkraenzer 2001-09-04 16:01:36 EDT

*** This bug has been marked as a duplicate of 52769 ***
Comment 3 Bernhard Rosenkraenzer 2001-09-04 16:03:25 EDT
This is because kdm refers to KGlobal::locate("config") which will always be 
/usr/share/config.

Ideally, /usr/share/config would be a symlink to /etc/kde, but we can't do 
that because we noticed it too late for 7.1, and we can't break updates from 
7.1 to 7.2.


Note You need to log in before you can comment on or make changes to this bug.