Bug 52769 - /usr/share/config/kdm linked messed up!
Summary: /usr/share/config/kdm linked messed up!
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: kdebase   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
: 53166 53243 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-28 20:39 UTC by Sammy
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-28 20:39:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sammy 2001-08-28 20:39:40 UTC
Description of Problem:

In 2.2-6 I first removed "rm -rf /usr/share/config/kdm"
then I installed the package. The link that was created
contained some special characters! e.g.

kdm;8F340234---> ../../../etc/kde/kdm

something similar to that. I removed it and replaced it with kdm
only and it started to work.

Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:

Comment 1 Bernhard Rosenkraenzer 2001-08-29 10:54:15 UTC
The proper procedure for updating from <= 2.2-6 to >= 2.2-7 is

rpm -e --nodeps kdebase
rpm -ivh kdebase-2.2-8.i386.rpm

The problem is that rpm can't handle replacing a directory with a symlink, 
which is what we're doing. (The fact that it was a directory rather than a 
symlink was a bug in 2.2-1 to 2.2-6, which we never released officially [and 
rawhide is supposed to break occasionally ;)])


Comment 2 Bernhard Rosenkraenzer 2001-09-04 20:01:31 UTC
*** Bug 53166 has been marked as a duplicate of this bug. ***

Comment 3 Bernhard Rosenkraenzer 2001-09-05 13:10:39 UTC
*** Bug 53243 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.