Bug 53168 - crash due to swapon() failure
crash due to swapon() failure
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
: 53330 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2001-09-04 16:22 EDT by kalsow
Modified: 2007-04-18 12:36 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-10-23 00:42:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
anaconda stack dump (9.97 KB, text/plain)
2001-09-04 16:23 EDT, kalsow
no flags Details

  None (edit)
Description kalsow 2001-09-04 16:22:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.12-20 i686)

Description of problem:
Cannot install on new Dell Latitude 810 w/512MB of memory.
The problems seems to be the 1024MB swap partition.  I tried
creating the partition with PartitionMagic 6.0, Disk Druid,
and fdisk.  No difference.  It fails when it tries to enable
swapping.  I tried installing without a swap partition and
then the install fails later during the package installs.
Even when installing "no" packages, it fails with an
"out of memory" error from anaconda.

The system has Win2K installed in a 4GB partition.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Insert 7.1 install CD
2. Create /boot(32MB), /(18GB), <swap>(1GB) partitions
3. answer questions & press [next]

Actual Results:  Anaconda crashed

Expected Results:  Duh?  Install linux.

Additional info:
Comment 1 kalsow 2001-09-04 16:23:31 EDT
Created attachment 30876 [details]
anaconda stack dump
Comment 2 Boris Bronshteyn 2001-09-04 23:03:53 EDT
The same problem occurs on Dell Ispiron 8100.The Red Hat 7.0 does not seem to
have it.
Comment 3 kalsow 2001-09-05 08:59:24 EDT
One of the virtual consoles listed this error:
    Unable to handle swap header version 256
It looks like sys_swapon() in mm/swapfile.c is
expecting a version number of 1.
Comment 4 Matt Wilson 2001-09-05 21:44:35 EDT
This is very odd.  Please try switching to VC2 (Alt+F2) and run:

mknod /tmp/hda
fdisk /tmp/hda
(make sure hda7 is set up for the swap space correctly)
mknod /tmp/hda7
mkswap /tmp/hda7
swapon /tmp/hda7

check VC4 for more errors.

If it still fails, boot with "linux ide=nodma" and see if that helps.
Comment 5 Matt Wilson 2001-09-05 21:45:24 EDT
We have several Inspiron 8000 machines here, we don't see the problem.  I will
also be checking with Dell tomorrow about this.
Comment 6 Boris Bronshteyn 2001-09-05 23:59:40 EDT
It is specifically new Inspiron 8100 that fails. 8000 is just fine
Comment 7 Matt Wilson 2001-09-06 11:05:35 EDT
dell is investigating.
Comment 8 Jeremy Katz 2001-09-06 16:20:36 EDT
*** Bug 53330 has been marked as a duplicate of this bug. ***
Comment 9 Douglas Wilson 2001-09-07 19:06:55 EDT
I had the same problem with a Dell Latitude C800.  The boot with "linux ide=nodma" suggestion made by msw worked for me.  The Latitude C800 
has a DVD-CDRW drive that Dell describes as "313-3156 Internal 6-4-4-24X DVD with Software/CD Read Write Combo"
Comment 10 paul 2001-09-07 19:27:16 EDT
I installed RH7.0 on my Dell I8100, 
 -(P3-1.13, 512 MB Crucial Ram, Geforce 32MB, 20 GB Hitachi DK23CA-20 HHD)
The install was uneventful (no unexpected errors/difficulties).
I have Win2k on another partition.

I then performed an Upgrade to RH7.1:
There were no apparent errors during the upgrade, however afer reboot,
 -fstab was missing (and / was gone)
 -after repairing fstab, there was severe filesystem corruption during boot.

Another scenario I tried: 

With a clean install:
I noticed that if I changed the swap partition during an install of RH7.1 
(deleted an existing one, and created a new one with fdisk or disk druid 
1M,2M,50M,1G in sizes),

I could finish the install (no apparent errors), but after restart, would 
experience similar filesystem corruption during boot as mentioned above.
Comment 11 Mike A. Harris 2001-10-20 18:45:39 EDT
Just a datapoint:

Date: Sat, 20 Oct 2001 14:39:19 -0700 (PDT)
From: Mark Vojkovich <mvojkovich@nvidia.com>
To: XFree86 devel list <devel@xfree86.org>
Content-Type: TEXT/PLAIN; charset=US-ASCII
Subject: Re: Nvidia status document:
On Sat, 20 Oct 2001, Thomas Witzel wrote:
> What means GeForce2 Go is not supported ? XFree runs on mine...
   Some people have said the Toshiba laptops work with the "nv" driver.
I've never seen it work, and frankly, I don't see how it can.  It
certainly doesn't work on the one we have here.  Must be some sort
of bios miracle you are seeing.  The "nv" driver definitely does not
support the GeForce2 Go in terms of having code required to make
it work for the general case.
Comment 12 Boris Bronshteyn 2001-10-22 23:37:46 EDT
We used text mode setup. After configuring and just before
installation began, we switched to VC2 (Alt+F2) and
did a mkswap /tmp/hda6 (or whatever your swap partition is).
The device file was already there (no need to mknod) at that
point. Installation continued normally.
Comment 13 paul 2001-10-23 00:42:47 EDT
RedHat 7.2 did not have this issue. Install was normal.

Note You need to log in before you can comment on or make changes to this bug.