Bug 531769 - DHCPV6C=yes does not work
DHCPV6C=yes does not work
Status: CLOSED DUPLICATE of bug 553017
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
12
All Linux
low Severity high
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-29 09:08 EDT by Catalin BOIE
Modified: 2014-03-16 23:20 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-08 17:13:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
untested patch (2.05 KB, patch)
2009-10-29 21:53 EDT, Bill Nottingham
no flags Details | Diff

  None (edit)
Description Catalin BOIE 2009-10-29 09:08:43 EDT
Description of problem:
In ifcfg-eth?, DHCPV6C=yes does not work. Somewhere, the scripts tests for the existence of /sbin/dhcp6c that is not installed. Trying to install dhcpv6 package is not working (not found).

Version-Release number of selected component (if applicable):
initscripts-9.00-1

How reproducible:
Configure a network device and set DHCPV6C=yes and start the network.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
A new IP from a DHCPv6 server to be assigned to interface.

Additional info:
Probably the initscripts package is not converted to dhclient, yet? If yes, if you give me some directions, I can add that support. Just let me know.
Comment 1 Bill Nottingham 2009-10-29 21:29:09 EDT
Yeah, it never got converted to dhclient for IPv6 usage.
Comment 2 Bill Nottingham 2009-10-29 21:53:07 EDT
Created attachment 366745 [details]
untested patch

Here's an untested patch that uses dhclient. Obviously, if you've specified specific dhcp6c options in your config, they would need migrated.

My one obvious concern is how well this works if you're already running dhclient for ipv4 as well.
Comment 3 Catalin BOIE 2009-10-30 04:58:05 EDT
It is working, meaning that dhclients get an address. But it is not added to the interface becasue dhclient-script is broken! I reported it separately in https://bugzilla.redhat.com/show_bug.cgi?id=531997
I think that this bug can be closed.
Comment 4 Bug Zapper 2009-11-16 09:35:05 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Bill Nottingham 2010-01-08 17:13:07 EST

*** This bug has been marked as a duplicate of bug 553017 ***

Note You need to log in before you can comment on or make changes to this bug.