Bug 53186 - 3ware driver loads but does not work
3ware driver loads but does not work
Status: CLOSED DUPLICATE of bug 51214
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-04 19:07 EDT by csieh
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-04 12:31:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description csieh 2001-09-04 19:07:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-12 i686)

Description of problem:
3ware driver loads but does not work

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install rc2
2.try to access 3ware preexisitng partition
3.
	

Actual Results:  syslog output
--------------------------------------------------------
<4>3w-xxxx: tw_interrupt(): Bad response, status = 0xc1, flags = 0x11, unit
= 0x
0.
<4>3w-xxxx: tw_scsi_eh_reset(): Reset succeeded for card 1.
<4>3w-xxxx: tw_interrupt(): Bad response, status = 0xc1, flags = 0x11, unit
= 0x
0.
<6>scsi: device set offline - not ready or command retry failed after host
reset
: host 1 channel 0 id 0 lun 0
<4>SCSI disk error : host 1 channel 0 id 0 lun 0 return code = 80000
<4> I/O error: dev 08:00, sector 300268800
<4>get_last_sector ioctl: bread returned NULL.

Expected Results:  no error messages in syslog

Additional info:

worked on last beta.  Broke on first rowell.
Comment 1 Owen Taylor 2001-10-04 12:31:36 EDT
I've have a system here that reproduces this; (3ware escalade 6200)
works with 7.1, cannot install 7.2 on it.

The changes between 7.1 and 7.2 in the 3w-xxxx driver seem fairly
small so it shouldn't be that hard to try backing them out and
seeing if that fixes it. (Looks like there is only one change in how
it talks to the card really - the addition of code to deal differently
with RAID5 devices... since I'm trying to use this in a RAID1 
configuration.... but of course, it could be something completely
unrelated in how the card is accessed.)

Comment 2 Owen Taylor 2001-10-04 12:33:17 EDT
should have looked closer at my query before adding comments.

*** This bug has been marked as a duplicate of 51214 ***

Note You need to log in before you can comment on or make changes to this bug.