Bug 51214 - 3ware 3w-xxxx module init of sda fails during installation.
3ware 3w-xxxx module init of sda fails during installation.
Status: CLOSED ERRATA
Product: Red Hat Public Beta
Classification: Retired
Component: kernel (Show other bugs)
roswell
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
http://uwsg.iu.edu/hypermail/linux/ke...
:
: 53186 55657 56643 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-08 11:26 EDT by Bill Rugolsky, Jr.
Modified: 2007-04-18 12:35 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-11 11:03:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Rugolsky, Jr. 2001-08-08 11:26:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010702

Description of problem:
Configuration: Tyan K7 dual 1.2GHz Athlon MP, 1GB ECC RAM
Maxtor 40GB ATA/100
3ware Escalade 7800 w/ 4x41GB IBM ATA/100 configured as hardware RAID10.
Booting the Roswell installation disk with "expert noprobe"
loading the 3ware 3w-xxxx module, and then attempting to
partition sda results in the following:

tw_interrupt: Bad response, status = 0xc1, flags=0x11, unit=0x0.
tw_scsi_eh_reset(): Reset succeeded for card 0.
tw_interrupt: Bad response, status = 0xc1, flags=0x11, unit=0x0.
scsi: device set offline - not ready or command retry failed after host
reset: host 0 channel 0 id 0 lun 0
SCSI disk error: host 0 channel 0 id 0 lun 0 return code = 80000
I/O error: dev 08:00 sector 160832000 get_last_sector ioctl: bread returned
NULL

I currently have RedHat 7.1 + numerous Rawhide updates installed on
/dev/hda, and was attempting to install Roswell on the RAID array.
The machine is currently running kernel-smp-2.4.6-2.4.athlon.rpm from
RawHide w/o issue.  I have also used vanilla 2.4.6-ac5 without issue.

I will try booting the various Roswell kernels on my existing install, and
see whether the problem is common to all, confined to kernel-BOOT, all UP
kernels, etc.  (Unfortunately brownouts and blackouts have taken down my
systems temporarily, so I may not get to this until Monday.)

The URL that I provided points to a thread on linux-kernel regarding
similar problems seen by others running recent kernels.

More to follow ...


How reproducible:
Always

Steps to Reproduce:
1. Boot installion disk with "noprobe"
2. Load the 3w-xxxx module
3. Attempt to partition sda
	

Additional info:
Comment 1 Glen Foster 2001-08-08 15:13:01 EDT
We (Red Hat) should try to fix this before next release.
Comment 2 Arjan van de Ven 2001-08-20 09:12:19 EDT
It would be interesting to know why 2.4.6-2.4 works fine and the Roswell BOOT
doesn't... there's not THAT much difference between them
Comment 3 Bill Rugolsky, Jr. 2001-08-22 09:55:10 EDT
Sorry, I've been delinquent in following up; first blackouts, then vacation.

I installed the kernel-BOOT-2.4.6-3.1 on the IDE partition, and it works fine. 
So my guess is that the problem is connected with using "noprobe".  I was going
to make a quick stab at booting in expert mode with the driver disk, but the
floppy drive that I have for the machine is defective.  I'll transfer another
floppy drive to that box and give it a try, as well as grab the Roswell2 Beta.
Comment 4 Samuli Kärkkäinen 2001-08-24 16:15:16 EDT
I second this bug report. I get the exact same error messages (except sector is
120101152) from kernel with Roswell boot.img DL'd from rawhide.redhat.com today
as following

- I enter "text" to the boot prompt
- 3ware driver is loaded
- English language and us keymap
- "none - none" mouse
- custom install type
- fdisk partitioning
- and now the error messages appear on console 4

My hardware is

Abit KG7, Athlon 1.4 GHz, 512 MB ECC RAM
3ware 6200 with two 60 GB IBM 60GXP configured as RAID1 (mirroring)
Comment 5 Arjan van de Ven 2001-08-24 16:17:14 EDT
skarkkai@woods.iki.fi: is your problem also only with the install floppy but
not with "normal" kernels ?
Comment 6 Bill Rugolsky, Jr. 2001-08-27 08:31:58 EDT
I got my floppy drive working, created a driver disk, and did every possible
combination of options to lilo that I could thing of (dd, noprobe, noapic,...).
I tried it with the aix7xxx driver loaded, and I tried it without.  No good. 
Same with Beta2.

I installed the Roswell -BOOT kernel on my IDE partition.  Again, works fine.
If anyone can think of what is different about booting from the install image,
perhaps I can track this further.  The only thing that springs to my mind is
modules.conf; here's mine:

alias scsi_hostadapter 3w-xxxx
alias parport_lowlevel parport_pc
alias eth0 3c59x
alias eth1 3c59x
alias scsi_hostadapter1 3w-xxxx
alias scsi_hostadapter2 aic7xxx_mod
alias scsi_hostadapter3 ide-scsi
alias char-major-89 i2c-dev

Unfortunately, I need to deliver this machine to the its end-user in the near
future.  I'm preparing to install to the IDE drive, then copy it over to the
3ware and fix up the relevant files.  I can hang onto it another week, so I'm
open to debugging it until then.
Comment 7 Yusuf Goolamabbas 2001-08-30 23:59:42 EDT
Hi, I get the same behaviour with a 3ware 6200 attached to to 20GB Maxtor drives
in raid-1 config. I have RH 7.1 installed on this already



It doesn't matter whether I choose autopartition/disk-druid/fdisk/ I get a
warning message

The partition table on device sda was unreadable. To create new partitions it
must be initialized causing the loss of ALL DATA on this drive

Would you like to initialize this drive.

On console 4, I get the message described by rugolsky

Redhat 7.1 installed perfectly on this.

I will try blowing my raid config and creating a RAID-0 and trying again
Comment 8 Arjan van de Ven 2001-08-31 03:34:53 EDT
Please try installing the 2.4.7-2.18 kernel from
http://people.redhat.com/arjan/testkernels/
in 7.1 or in an installed 7.2 (--nodeps is your friend)
We think it was a compiler bug that triggered in the bootfloppy kernel only
(we used -Os to optimize for size there)
Comment 9 Bill Rugolsky, Jr. 2001-09-01 21:27:28 EDT
Arjan,

I used the 2.4.7-2.19BOOT kernel from your webpage (correct URL is
http://people.redhat.com/arjan/testkernels/) to create an updated installation
boot disk by replacing vmlinuz, modules.cgz, module-info, modules.dep, and
pcitable.  I got rid of all the extraneous scsi drivers except aic7xxx and added
3w-xxxx.  Upon boot everything autoloads correctly, but I get the same error as
first reported when I attempt to partition the disk.

You believe that the bug may be caused by compiling the kernel -Os, but that
does not seem to jive with the fact that I can boot the very same kernel and
load the very same module without issue using my existing IDE installation.

Thinking about what is different, aside from extraneous modules, etc., I come up
syslinux v. lilo, "insmod" (aka "loader") and libc. Perhaps the bug is in
insmod?  I will attempt to eliminate syslinux as a possibility.
Comment 10 Yusuf Goolamabbas 2001-09-03 03:03:17 EDT
Okay, I downloaded

http://people.redhat.com/arjanv/testkernels/i386/kernel-2.4.7-2.19.i386.rpm
and
http://people.redhat.com/arjanv/testkernels/i386/kernel-BOOT-2.4.7-2.19.i386.rpm

and created the appropiate initrd images and different stanza's in lilo for them

With the -BOOT rpm, I couldn't get my IP via DHCP but it picked up my 3ware and
got me to multiuser

With the normal 2.4.7-2.19, everything worked as normal

Arjan, Is this what you were looking for or do I need to do anything else ?

I shall wait for a new Roswell BETA iso to verify if install over a 3ware works
correctly
Comment 11 Yusuf Goolamabbas 2001-09-13 07:50:03 EDT
Is there going to be another ISO release, I would really like to see RH 7.2
install cleanly over a 3ware board
Comment 12 Owen Taylor 2001-10-04 12:33:12 EDT
*** Bug 53186 has been marked as a duplicate of this bug. ***
Comment 13 Owen Taylor 2001-10-04 12:40:14 EDT
This still seems to be happening with a boot disk that should be based on 
kernel-BOOT-2.4.7-10, unfortunately :-(
Comment 14 Owen Taylor 2001-10-04 14:58:34 EDT
The kernel-BOOT-2.4.9-0.15 package does not have the problem.

(With 2.4.7-10, upgrading the 7.1 install to the 2.4.7-10 kernel
did work, so it was definitely something specific to the BOOT image.)
Comment 15 Steven Pritchard 2001-10-07 00:35:23 EDT
I just tried the 7.2 release (I'm a mirror admin - I had to try it) on a
single-processor PIII with a 3ware 6200 and two mirrored disk...  Same problem.
 I'd hate to think that 3ware users won't be able to use 7.2...
Comment 16 Owen Taylor 2001-10-10 20:07:54 EDT
To contradict my earlier report, the 2.4.9-0.15 boot kernel didn't
work in the end either ... it got past reading the partition table,
but attempts to format partitions failed. It seems that either
reading or writing was producing junk... the write/read rountrip
wasn't working.
Comment 17 Jeremy Katz 2001-10-11 11:02:54 EDT
Could you try downloading the updates disk image at
http://people.redhat.com/~katzj/3ware.img, write it to a disk as you do boot
disks, boot with your old boot disk and type 'linux updates' at the syslinux
prompt, putting in the new disk when asked for your updates disk?  This *should*
 fix the problem, but further confirmation that it in fact does would be much
appreciated.
Comment 18 Jeremy Katz 2001-10-25 10:32:08 EDT
Update officially released, see
http://www.redhat.com/support/errata/RHBA-2001-131.html for more information.
Comment 19 Jeremy Katz 2001-11-04 00:41:01 EST
*** Bug 55657 has been marked as a duplicate of this bug. ***
Comment 20 Jeremy Katz 2001-11-23 00:33:48 EST
*** Bug 56643 has been marked as a duplicate of this bug. ***
Comment 21 Jeremy Katz 2001-11-28 19:46:38 EST
*** Bug 56643 has been marked as a duplicate of this bug. ***
Comment 22 Need Real Name 2002-06-07 02:17:59 EDT
It would be very nice when someone would update the link to the place where i 
can download the 3ware.img. as of now it ist linked to a dead end. 
MFG Sheldon
Comment 23 Jeremy Katz 2002-06-10 16:03:58 EDT
The official errata page is http://rhn.redhat.com/errata/RHBA-2001-131.html with
the link to the officially released errata boot disk.

Note You need to log in before you can comment on or make changes to this bug.