Bug 531961 - Satellite services have changed
Summary: Satellite services have changed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Docs Installation Guide
Version: 530
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: John Ha
QA Contact: Joshua Wulf
URL:
Whiteboard:
: 523246 527184 (view as bug list)
Depends On:
Blocks: sat531-docs2
TreeView+ depends on / blocked
 
Reported: 2009-10-30 00:44 UTC by Matthew Davis
Modified: 2014-10-19 22:57 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-17 12:52:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 518930 None None None Never
Red Hat Product Errata RHBA-2010:0413 normal SHIPPED_LIVE Red Hat Network Satellite bug fix update 2010-05-17 12:50:51 UTC

Internal Links: 518930

Description Matthew Davis 2009-10-30 00:44:37 UTC
Chapter 8.1 mentions how to start & stop the satellite.  This assumes the old behavior of the satellite which used SysVinit scripts.

The satellite now is started & stopped with /usr/sbin/rhn-satellite.  While the intent of the blurb is still correct, the commands are not.

Comment 1 John Ha 2009-11-04 05:15:37 UTC
Fixed in the latest upcoming (5.3.1) version of the Satellite Installation Guide. All

Comment 2 John Ha 2009-11-04 06:29:15 UTC
*** Bug 527184 has been marked as a duplicate of this bug. ***

Comment 3 John Ha 2009-11-04 08:53:38 UTC
*** Bug 523246 has been marked as a duplicate of this bug. ***

Comment 5 Brandon Perkins 2010-03-06 05:58:39 UTC
Fails QA.  Although the original issue has been fixed, it is still incomplete.  The documentation I see on:

https://rlx-3-14.rhndev.redhat.com/rhn/help/satellite/en-US/ch-maintenance.jsp#s1-maintenance-rhn-satellite

reads as:

 Since the RHN Satellite consists of a multitude of individual components, Red Hat provides a command-line tool that allows you to stop, start, or retrieve status information from the various services in the appropriate order: rhn-satellite. This tool accepts all of the typical commands:

/usr/sbin/rhn-satellite start
/usr/sbin/rhn-satellite stop
/usr/sbin/rhn-satellite restart
/usr/sbin/rhn-satellite status

Use rhn-satellite to shut down and bring up the entire RHN Satellite and retrieve status messages from all of its services at once. 


However, this is missing reload, enable, and disable.

Comment 6 John Ha 2010-03-23 17:34:49 UTC
Added reload, enable, and disable to the commands list:

http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Network_Satellite/5.3.1/html/Installation_Guide/ch-maintenance.html#s1-maintenance-rhn-satellite

Moving to MODIFIED. Thanks for pointing out the additional commands.

Comment 9 Bryan J Smith 2010-05-13 23:22:01 UTC
Section 8.4 on DB Control is still referencing "service rhn-database" as well.
See BZ518930:  
https://bugzilla.redhat.com/show_bug.cgi?id=518930

Comment 10 Brandon Perkins 2010-05-14 22:12:14 UTC
Release Pending.  Checked on rlx-3-10.rhndev.redhat.com with:

rhn-i18n-guides-5.3.0.16-1.el5sat
rhn-i18n-release-notes-5.3.0.8-1.el5sat
satellite-branding-5.3.0.28-1.el5sat
satellite-doc-indexes-5.3.24-1.el5sat

Comment 11 errata-xmlrpc 2010-05-17 12:52:25 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0413.html


Note You need to log in before you can comment on or make changes to this bug.