Bug 53220 - Boot floppy made by update installation unusable
Boot floppy made by update installation unusable
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
roswell
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-05 02:14 EDT by Joachim Backes
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-06 08:41:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Backes 2001-09-05 02:14:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9 i686)

Description of problem:
I made an update installation from RH 7.1 to Roswell and told the installer
to make a boot diskette. But when booting with this diskette, the kernel
stops after it has been started before mount the root fs with the msg that
it can't be mounted. 

My system has only scsi disks (adaptec 2940), and it seems that aic7xxx is
missing on the boot diskette.

My old kernel (2.4.9) with inbound aic7xxx can boot the roswell edition
without any problem.

I had similar problems when updating fron RH 7.0 to 7.1 (Bug # 31477).

Possibly, this problem occurs only when I make a text based update: A
collegue of me told me that he has not the problem described above when he
updates the system by using the GUI installer.



Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
see above.
	

Actual Results:  VFS: Cannot open root device "sda..." or 08:xx
 Please append a correct "root=" boot option
 Kernel panic: VFS: Unable to mount root fs on 08:xx

Expected Results:  system boots completely.

Additional info:

--
Comment 1 Brent Fox 2001-09-05 12:44:33 EDT
I was not able to reproduce this test.  My test machine with an Apaptec 2940
booted just fine off the boot floppy.  Could something be damaged with your
floppy?  

Try mounting the floppy in the system and post the output of 'ls -al' to Bugzilla.
Comment 2 Joachim Backes 2001-09-06 03:01:06 EDT
There is nothing damaged with the floppy. If I mount it on another
LINUX system, then ls -lR shows tho following:

ls -lR /mnt
/mnt:
total 816
-rwxrwxr-x    1 root     root          203 Sep  6 08:54 boot.msg
-r-xr-xr-x    1 root     root         6192 Sep  6 08:54 ldlinux.sys
-rwxrwxr-x    1 root     root          104 Sep  6 08:54 syslinux.cfg
-rwxrwxr-x    1 root     root       827322 Aug 14 11:27 vmlinuz

Using this floppy (I made the same test on another 7.1 system upgraded to
roswell and failed too), boot stops (after the kernel has benn loaded and
started) with the following msg's:

request_module_[block-major-8]: Root fs not mounted
VFS: Cannot open root device "sda1" or 08:01
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on 08:01

--------------

This behaviour can be reproduced. The problem is an old one (I had it
too when upgrading from 7.0 to 7.1), but not from 6.2 to 7.0.

I think, the aic7xxx module is missing for mounting the root fs. And I
think, if _YOUR_ kernel would have this module inbound, booting would be
possible: I made a boot floppy from my 2.4.9 kernel which has aic7xxx inbound,
and this kernel boots correctly from the floppy.

Comment 3 Matt Wilson 2001-09-06 08:06:36 EDT
this bootdisk was made from the stock kernel?  there is no initrd on it.  could
you attach your /etc/modules.conf from this box?
Comment 4 Joachim Backes 2001-09-06 08:41:41 EDT
The bootdisk was made by anaconda at the end of the update process. The used
Kernel
is vmlinuz-2.4.7-2 (that is your RH7.2 beta roswell kernel!)

/etc/modules.conf:

# alias scsi_hostadapter aic7xxx 
# alias eth0 3c59x 
# alias parport_lowlevel parport_pc 
# alias usb-controller usb-uhci 

This is exactly my /etc/modules.conf  _before_  the upgrade (my kernel 2.4.9
does not need any module, but 2.4.7-2 needs aic7xxx for booting!!).
Comment 5 Matt Wilson 2001-09-06 08:52:53 EDT
you commented out the scsi_hostadaptor line in /etc/modules.conf.  that means
that modular kernels will not load any kernel drivers for your scsi controller
at all.

Even if you have the drivers compiled in, leave the entries in
/etc/modules.conf.
Comment 6 Joachim Backes 2001-09-06 09:39:32 EDT
Ooops! If I understand you correctly, this means: never remove entries in an
/etc/modules.conf which had been produced by the very first RedHat installation?
Even if I compile my own kernel with inbuild drivers? Does this mean, that in
principle RedHat assumes that the user does not modify or exchange the kernel
installed by the RedHat installer? And does this mean, that during upgrade no
hardware recognition is done? :-((

Well, enough of discussions, I think we can close this bug.

Regards

Joachim Backes

Note You need to log in before you can comment on or make changes to this bug.