Bug 532215 - KSM bad_page() issue preventing VM startup
KSM bad_page() issue preventing VM startup
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Justin M. Forbes
Fedora Extras Quality Assurance
:
: 539745 539956 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-31 10:17 EDT by Michael Monreal
Modified: 2009-11-30 23:43 EST (History)
12 users (show)

See Also:
Fixed In Version: 2.6.31.6-145.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-30 23:43:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Monreal 2009-10-31 10:17:23 EDT
Looks like I am not longer able to create new VMs with virt-manager on my F12b+updates system. I tried two install two systems:

a) Windows XP SP3 from ISO
b) Fedora 12 Beta from Live ISO

Both VMs hang at the "ata0" message in bios.

I also noticed that, if I don't add a hard disk (which should not be required to boot the LiveCD for example), the new VM is opened with "Guest not running" and does not even try to boot automatically. After pressing "Run" it stops at the same "ata0" message.

Some relevant package versions:

kernel-PAE-2.6.31.5-105.fc12.i686
qemu-system-x86-0.11.0-9.fc12.i686
qemu-common-0.11.0-9.fc12.i686
qemu-img-0.11.0-9.fc12.i686
libvirt-python-0.7.1-14.fc12.i686
virt-manager-0.8.0-7.fc12.noarch
libvirt-client-0.7.1-14.fc12.i686
python-virtinst-0.500.0-5.fc12.noarch
libvirt-0.7.1-14.fc12.i686
Comment 1 Justin M. Forbes 2009-11-05 17:29:12 EST
Can you attach a dmesg from the system after you have tried running a guest?
Comment 2 Michael Monreal 2009-11-10 07:17:27 EST
I was just able to boot the XP VM once, but got this on the second try:

...
device vnet0 entered promiscuous mode
virbr0: topology change detected, propagating
virbr0: port 1(vnet0) entering forwarding state
vnet0: no IPv6 routers present
BUG: Bad page state in process qemu-kvm  pfn:3f9ce
page:c1d599c0 flags:80000004 count:0 mapcount:0 mapping:(null) index:0 (Tainted: P          )
Pid: 7494, comm: qemu-kvm Tainted: P           2.6.31.5-127.fc12.i686.PAE #1
Call Trace:
 [<c049ecc8>] bad_page+0xdf/0xf4
 [<c049fc51>] get_page_from_freelist+0x28d/0x364
 [<c049fe10>] __alloc_pages_nodemask+0xe8/0x447
 [<c04e3b1c>] ? mark_buffer_dirty+0x70/0x73
 [<c049ace7>] __page_cache_alloc+0x16/0x18
 [<c049bae7>] grab_cache_page_write_begin+0x4b/0x85
 [<c0526abf>] ext4_da_write_begin+0x187/0x252
 [<c049c30b>] generic_file_buffered_write+0xd4/0x263
 [<c049c8d8>] __generic_file_aio_write_nolock+0x258/0x289
 [<c049cbd2>] generic_file_aio_write+0x5f/0xb0
 [<c051f429>] ext4_file_write+0xa3/0x11a
 [<c04c882d>] do_sync_write+0xae/0xe9
 [<c056cf31>] ? file_has_perm+0x89/0xa3
 [<c0450d55>] ? autoremove_wake_function+0x0/0x34
 [<c056d221>] ? selinux_file_permission+0x49/0x4d
 [<c056654b>] ? security_file_permission+0x14/0x16
 [<c04c89ee>] ? rw_verify_area+0x9d/0xc0
 [<c04c877f>] ? do_sync_write+0x0/0xe9
 [<c04c8dc8>] vfs_write+0x85/0xe4
 [<c04c8e6f>] sys_pwrite64+0x48/0x5e
 [<c0408f7b>] sysenter_do_call+0x12/0x28
BUG: Bad page state in process Xorg  pfn:3d0ab
page:c1d07560 flags:80000004 count:0 mapcount:0 mapping:(null) index:0 (Tainted: P    B     )
Pid: 1502, comm: Xorg Tainted: P    B      2.6.31.5-127.fc12.i686.PAE #1
Call Trace:
 [<c049ecc8>] bad_page+0xdf/0xf4
 [<c049fc51>] get_page_from_freelist+0x28d/0x364
 [<c049fe10>] __alloc_pages_nodemask+0xe8/0x447
 [<c04c59b7>] ? __mem_cgroup_try_charge+0x3d/0x14f
 [<c04af062>] alloc_pages_node.clone.0+0x16/0x18
 [<c04afd63>] handle_mm_fault+0x1d7/0x8f2
 [<c077a829>] do_page_fault+0x282/0x298
 [<c077a5a7>] ? do_page_fault+0x0/0x298
 [<c0778d3b>] error_code+0x73/0x78
virbr0: port 1(vnet0) entering disabled state
device vnet0 left promiscuous mode
virbr0: port 1(vnet0) entering disabled state


Is this another selinux problem?

Note that "Tainted" has to be the nvidia driver which I am using now for a few days, the problem clearly showed before that though.
Comment 3 Justin M. Forbes 2009-11-10 09:04:22 EST
Unfortunately not.  If you stop the ksm and ksmtuned services, can you run virtual machines without issue?
Comment 4 Michael Monreal 2009-11-10 10:31:04 EST
(In reply to comment #3)
> If you stop the ksm and ksmtuned services, can you run
> virtual machines without issue?  

Seems to work after stopping both services!
Comment 5 Justin M. Forbes 2009-11-10 10:45:49 EST
Great.  I should have a fix in an update kernel once F12 is out. In the meantime you cannot just turn off the services, you can chkconfig ksmtuned off, but ksm needs to actually run the stop script.  Perhaps just add '/sbin/service ksm stop' from rc.local.  Once the kernel update is available, this ticket will be updated and you can revert these changes to make use of the ksm feature.
Comment 6 Justin M. Forbes 2009-11-11 12:20:11 EST
This patch has been posted in cvs as 2.6.31.5-128 and should appear in the first update kernel for F-12.
Comment 7 Bug Zapper 2009-11-16 09:45:37 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Fedora Update System 2009-11-18 07:20:09 EST
kernel-2.6.31.6-134.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/kernel-2.6.31.6-134.fc12
Comment 9 Fedora Update System 2009-11-20 00:13:13 EST
kernel-2.6.31.6-134.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-11731
Comment 10 Justin M. Forbes 2009-11-22 10:11:59 EST
*** Bug 539956 has been marked as a duplicate of this bug. ***
Comment 11 Fedora Update System 2009-11-23 08:03:45 EST
kernel-2.6.31.6-145.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/kernel-2.6.31.6-145.fc12
Comment 12 Justin M. Forbes 2009-11-23 13:28:32 EST
*** Bug 539745 has been marked as a duplicate of this bug. ***
Comment 13 Fedora Update System 2009-11-25 10:29:16 EST
kernel-2.6.31.6-145.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12166
Comment 14 Wylie Edwards 2009-11-26 16:26:24 EST
kernel-2.6.31.6-145.fc12 fixed this issue for me.
Comment 15 Fedora Update System 2009-11-30 23:42:48 EST
kernel-2.6.31.6-145.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.