Bug 53226 - Gnome Tasklist Focus Problem while Restoring Windows
Gnome Tasklist Focus Problem while Restoring Windows
Status: CLOSED DUPLICATE of bug 49785
Product: Red Hat Linux
Classification: Retired
Component: sawfish (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
Depends On:
  Show dependency treegraph
Reported: 2001-09-05 03:54 EDT by Ecmel Ercan
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-03-04 17:41:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ecmel Ercan 2001-09-05 03:54:02 EDT
Description of Problem:

When you try to restore a minimized window by single clicking on its icon
on the Gnome Tasklist applet, the window restores but not get the focus. 
You should click again to focus it.

Version-Release number of selected component (if applicable):

How Reproducible:
Every time

Steps to Reproduce:
1.Open a window (e.g. mozilla)
2.Minimize it
3.Single click on its icon on the tasklist applet

Actual Results:
Window restores but not get focus.

Expected Results:
Window should get focus.

Additional Information:
You may say this is not a bug but a feature :)  I am really surprised about
the inconsistencies of tasklist and window manager behaviour between 7.0,
7.1 and the upcoming 7.2 versions.
Comment 1 Havoc Pennington 2001-12-07 16:23:27 EST
No, not a feature. It should be focusing the window.
Comment 2 Havoc Pennington 2002-02-25 16:08:55 EST
Probably not happening in latest packages, but needs testing.
Comment 3 Havoc Pennington 2002-03-01 17:50:59 EST
See http://bugzilla.gnome.org/show_bug.cgi?id=73168
Comment 4 Havoc Pennington 2002-03-04 17:40:59 EST
Apparently sawfish has a config option to not focus unminimized windows, and 
we have the default setting wrong for that.
Comment 5 Havoc Pennington 2002-03-08 14:12:56 EST

*** This bug has been marked as a duplicate of 49785 ***

Note You need to log in before you can comment on or make changes to this bug.