Bug 49785 - Windows should focus after being uniconified
Windows should focus after being uniconified
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: sawfish (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
:
: 53226 60430 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-23 17:15 EDT by Anders Carlsson
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-08 14:14:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anders Carlsson 2001-07-23 17:15:30 EDT
IMO, the default setting for sawfish should be to focus windows when
they're uniconified. This way, you can click on an iconified window in the
tasklist to uniconify it and click on it again to iconify it. Otherwise you
need an extra click to focus the window.

The setting is located under the minimizing part of the "Minimizing and
Maximizing" capplet.
Comment 1 Havoc Pennington 2002-03-04 16:00:15 EST
This is a dup of one of my bugs, I need to look.

I didn't realize it was a config option, need to fix the default.
Comment 2 Havoc Pennington 2002-03-08 14:12:52 EST
*** Bug 53226 has been marked as a duplicate of this bug. ***
Comment 3 Havoc Pennington 2002-03-08 14:14:29 EST
*** Bug 60430 has been marked as a duplicate of this bug. ***
Comment 4 Havoc Pennington 2002-03-08 15:01:13 EST
1.0.1-5 should contain a fix.

Note You need to log in before you can comment on or make changes to this bug.