Bug 53232 - why is CONFIG_PNPBIOS disabled ?
Summary: why is CONFIG_PNPBIOS disabled ?
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-05 09:41 UTC by Fabrice Bellet
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-05 09:41:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Fabrice Bellet 2001-09-05 09:41:55 UTC
Description of Problem:
CONFIG_PNPBIOS has been disabled from kernel configuration since 
kernel version > 2.4.6-2.

This feature is valuable for thinkpad users for example.
When combined with the setpnp tool from the pcmcia package,
it allows us to change some hardware resources, without 
the dos-only PS2.EXE tool provided by IBM. So my wish is
to re-enable this feature, and to add setpnp in the
kernel-pcmcia package too. (bug #50486).

Fabrice

Comment 1 Arjan van de Ven 2001-09-05 09:54:59 UTC
The problem with this feature is that a LOT of machines have a defective bios
that made the 2.4.6 kernels which had PNPBIOS oops. a LOT. Until there is a
reliable way to catch such oopses in the kernel and THEN disable PNPBIOS at
runtime, we have no choice other than to disable it. (Windows uses this method;
but that has the sideeffect of bios writers not noticing their bios is buggy, or
at least not having it as critical bug, hence the large number of broken
bioses).

Alan is working on getting the "catch" part working, but so far it doesn't; as
soon as it does I'll enable the option.

I'm closing this as "deferred" as I do agree it should be enabled, but only once
it has become actually usable.


Note You need to log in before you can comment on or make changes to this bug.