Bug 532369 - loading the ssb driver for b43 wireless adapter causes machine to lock up
Summary: loading the ssb driver for b43 wireless adapter causes machine to lock up
Keywords:
Status: CLOSED DUPLICATE of bug 533746
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-01 21:32 UTC by Andrew Cathrow
Modified: 2014-09-07 22:53 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-12 18:57:07 UTC


Attachments (Terms of Use)
lspci output (1.53 KB, application/octet-stream)
2009-11-01 21:32 UTC, Andrew Cathrow
no flags Details

Description Andrew Cathrow 2009-11-01 21:32:55 UTC
Created attachment 367038 [details]
lspci output

Anaconda locks up during boot after "waiting for hardware to initialize..."

Hardware : HP Mini 1030NR
Smolt profile : http://www.smolts.org/client/show/pub_f18f6d10-4cde-4e12-9b17-dd879de8e0f2

Machine is running F11 i686 and I'm using preupgrade to upgrade to rawhide. Latest stage1/2 installer as of Nov 1st downloaded through preupgrade.

I see the same error with F12 beta live USB key

Last log likes I see are 

detecting hardware...
waiting for hardware to initialize...

Tried changing boot params to disable mode setting, I wasn't 100% sure on which would apply so I tried, individually, nomodeset, intel.modeset=0 and i915.modeset=0 

No difference, still see the error

I added "ignore_loglevel" to see if anything useful came up 

Sometimes it stops at 

   atl1c 0000:02:00.0: version 1.0.0.1-NAPI

other times I get more before it stops.


   atl1c 0000:02:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
   atl1c 0000:02:00.0: setting latency timer to 64
   atl1c 0000:02:00.0: PME# disabled
   atl1c 0000:02:00.0: PME# disabled

sometimes I get entries from BCM before atl1c, sometimes after.

   b43-pci-bridge 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
   b43-pci-bridge 0000:01:00.0: Psetting latency timer to 64

I've tried blacklisting atl1c and b43 (individually and together) incase it's related to those modules but again, no difference.

While I had no problems with this hardware on Fedora 11 there's a BZ that may be related, it was entered on F11 and the reporter was asked to reproduce on rawhide but this bug seems stale now
https://bugzilla.redhat.com/show_bug.cgi?id=521840

Comment 1 Chuck Ebbert 2009-11-02 18:00:09 UTC
Where does it stop with both the atl1c and b43 drivers blacklisted?

Comment 2 Andrew Cathrow 2009-11-02 19:52:37 UTC
(In reply to comment #1)
> Where does it stop with both the atl1c and b43 drivers blacklisted?  

It stops in the same place I don't see any difference in behaviour

Comment 4 Chuck Ebbert 2009-11-02 20:29:46 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > Where does it stop with both the atl1c and b43 drivers blacklisted?  
> 
> It stops in the same place I don't see any difference in behaviour  

Some other message should be the last thing on the screen if atl1c and b43 are blacklisted. Also, is it completely locked up?

Comment 5 Andrew Cathrow 2009-11-02 21:02:03 UTC
added ssb to the blacklist in addition to b43 and now the install is proceeding.

Comment 6 Andrew Cathrow 2009-11-03 02:29:04 UTC
After installation unable to boot, machine locks up during boot.

Booted from F11 live usb and added blacklist for ssb and b43.
Machine now boots but loading those modules cause it to lock hard, unable to even sysrq to get data.

Comment 7 John W. Linville 2009-11-04 21:48:44 UTC
What kernel version is this?  What is the F11 kernel that is working?

Comment 8 Andrew Cathrow 2009-11-06 01:47:57 UTC
Latest kernel I see this in is 2.6.31.5-96
I'm afraid I blew away the F11 install when preupgrade ran.

Comment 9 Andrew Cathrow 2009-11-06 12:48:45 UTC
updated to 2.6.31-5.117 this morning and still seeing the issue.

Comment 10 Bug Zapper 2009-11-16 14:50:49 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 11 Slobodan Sredojevic 2009-11-18 09:52:11 UTC
I believe I have also experienced this (probably a broadcom wireless driver loading hang/lock, as disabling wi-fi in BIOS actually boots the machine after that). 

I see reporter's computer is HP Mini 1030NR , mine is HP Compaq 615,
and here is one HP 2133 affected:
https://bugzilla.redhat.com/show_bug.cgi?id=533667

Comment 12 Slobodan Sredojevic 2009-11-18 11:15:06 UTC
Another one "HP compaq 615" dupe:
https://bugzilla.redhat.com/show_bug.cgi?id=530942

Comment 13 Andrew Cathrow 2010-01-02 00:18:54 UTC
Looks like some Acer Aspire laptops are also affected
https://bugzilla.redhat.com/show_bug.cgi?id=533746

Comment 14 John W. Linville 2010-01-27 16:11:02 UTC
Have you tried a 2.6.32-based kernel from Koji?

   http://koji.fedoraproject.org/koji/buildinfo?buildID=152968

Comment 15 Andrew Cathrow 2010-02-03 14:16:12 UTC
(In reply to comment #14)
> Have you tried a 2.6.32-based kernel from Koji?
> 
>    http://koji.fedoraproject.org/koji/buildinfo?buildID=152968    

Tested with kernel-2.6.32.6-36.fc12
Hard lock as before

Comment 18 John W. Linville 2010-02-03 14:24:21 UTC
Odd...I thought there was code added specifically to avoid those hangs.  I'll have to check again...

Comment 20 Ahmed Medhat 2010-03-05 15:06:57 UTC
Confirmed on - HP Pavilion DV6t-2000 and all HP Pavilion DV6-2020 series,

Locks up on the following lines after adding ignore_loglevel ..

ACPI: Video Device [VGA] (multi-head: yes  rom: no  post)
waiting for hardware to initialize...

b43-pci-bridge 000:02:00.0: PCI INT A -> GSI 16 (level, low) ->
IRQ 16

b43-pci-bridge 000:02:00.0: setting latency timer to 64

Comment 21 Ahmed Medhat 2010-03-05 16:25:09 UTC
Confirmed when installing Fedora on - HP Pavilion DV6t-2000 and all HP Pavilion DV6-2020 series, this is a blocking bug!

Locks up on the following lines after adding ignore_loglevel ..

ACPI: Video Device [VGA] (multi-head: yes  rom: no  post)
waiting for hardware to initialize...

b43-pci-bridge 000:02:00.0: PCI INT A -> GSI 16 (level, low) ->
IRQ 16

b43-pci-bridge 000:02:00.0: setting latency timer to 64

Comment 28 John W. Linville 2010-03-12 18:57:07 UTC

*** This bug has been marked as a duplicate of bug 533746 ***


Note You need to log in before you can comment on or make changes to this bug.