Bug 532493 - guestfish doesn't accept target parameter with space in it
guestfish doesn't accept target parameter with space in it
Status: CLOSED DUPLICATE of bug 507810
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-02 11:18 EST by Ray Van Dolson
Modified: 2010-03-16 13:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-02 12:01:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ray Van Dolson 2009-11-02 11:18:17 EST
Description of problem:
Passing a target filename with a space in it to guestfish fails.

Version-Release number of selected component (if applicable):
guestfish-1.0.72-1.fc11.i586

How reproducible:
Always

Steps to Reproduce:
1. Run guestfish <params> -i <file name with spaces.vmdk>
2. Observe errors
  
Actual results:
$ guestfish --ro -i "New Virtual Machine-flat.vmdk"
open /dev/kvm: No such file or directory
Could not initialize KVM, will disable KVM support
New: No such file or directory


Expected results:
No errors.

Additional info:
Also fails with backslashes in front of the spaces (no double quotes used).
Comment 1 Ray Van Dolson 2009-11-02 11:37:50 EST
Hmm, perhaps you already had filed a bug for this :)

  https://bugzilla.redhat.com/show_bug.cgi?id=507810
Comment 2 Richard W.M. Jones 2009-11-02 12:01:55 EST
Sorry about that ... it does indeed appear to be a duplicate.

*** This bug has been marked as a duplicate of bug 507810 ***

Note You need to log in before you can comment on or make changes to this bug.