Bug 5326 - texmf.cnf value for VARTEXFONTS broken
texmf.cnf value for VARTEXFONTS broken
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: tetex (Show other bugs)
6.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
: 5249 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-09-23 11:08 EDT by Norman Gray
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-15 17:43:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Norman Gray 1999-09-23 11:08:54 EDT
Greetings,

In the kpathsea library configuration file in
/usr/share/texmf/web2c/texmf.cnf, the value for VARTEXFONTS
is initialised using the $SELFAUTOPARENT variable, which is
in turn initialised using the location of the _executable_
which is compiled against the library.

This works OK for executables which are installed in
/usr/bin, since their SELFAUTOPARENT is / (this includes all
of the dviware which the tetex component installs), but it
means that applications which use the kpathsea library but
are _not_ installed here, fail, because they cannot find the
cache of generated fonts.  In other words, the file is such
that two applications using the same library and the same
configuration file can behave differently depending on their
installation location.

I mentioned this on the tex-k mailing list[1], and the
current web2c maintainer Olaf Weber agreed that this
configuration was broken.

Fix: set `VARTEXFONTS = /var/lib/texmf'.  Since
SELFAUTOPARENT will resolve to / for the current
installation, this change would not break current
installations. There is no problem with the dependence of
TEXMFMAIN on SELFAUTODIR -- that is what the variable is
for.

User/sysadmin workarounds: (1) make this change (safe for
the reason mentioned above); (2) install all new executables
linked against the library in /usr/bin (may be undesirable
for assorted reasons); (3) hack source code to get it to lie
about its location (this is what I've done because I've been
writing the application, but this is rather ugly, and
obviously doesn't help everyone).

By the way, the RH teTeX distribution seems to be one of the
few which actually installs the kpathsea library and include
files.  This is a Good Thing -- thanks, and can I encourage
you to keep doing that....

All the best,

Norman



[1] ftp://ftp.tug.org/mail/archives/tex-k/
Comment 1 Jeff Johnson 2000-01-15 17:43:59 EST
The file /usr/share/texmf/web2c/texmf.cnf already has
	VARTEXFONTS = /var/lib/texmf
in the Red Hat 6.1 tetex-1.0.6-7 package.
Comment 2 Jeff Johnson 2000-01-15 17:56:59 EST
*** Bug 5249 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.