Bug 533029 (ff-notification) - [abrt] crash detected in firefox & Jetpack [@ nsAlertsIconListener::SendClosed() ]
Summary: [abrt] crash detected in firefox & Jetpack [@ nsAlertsIconListener::SendClose...
Keywords:
Status: CLOSED UPSTREAM
Alias: ff-notification
Product: Fedora
Classification: Fedora
Component: firefox
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:d1f749d23e2fd84c5472108994f...
: 528812 537722 538611 539610 539752 539801 539942 540000 540007 540017 540025 540078 540160 540221 540405 540449 540610 540779 540947 541362 541458 542554 542901 543123 543675 543950 544292 544643 544644 544751 545257 545287 545383 545721 546132 546643 546824 547130 547502 549313 549409 550684 550827 551163 551275 551431 551760 553164 553701 554168 558075 569522 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-04 18:14 UTC by Matěj Cepl
Modified: 2018-04-11 14:41 UTC (History)
29 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-16 15:03:28 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (43.60 KB, text/plain)
2009-11-04 18:14 UTC, Matěj Cepl
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Mozilla Foundation 516124 0 None None None Never
Mozilla Foundation 530921 0 None None None Never

Description Matěj Cepl 2009-11-04 18:14:41 UTC
abrt detected a crash.


How to reproduce
-----
1.
2.
3.


Comment
-----
Testing Jetpack

Additional information
======


Attached files
----
backtrace

cmdline
-----
/usr/lib64/firefox-3.5.4/firefox 


component
-----
firefox


executable
-----
/usr/lib64/firefox-3.5.4/firefox


kernel
-----
2.6.31.5-115.fc12.x86_64


package
-----
firefox-3.5.4-1.fc12


reason
-----
Process was terminated by signal 11

Comment 1 Matěj Cepl 2009-11-04 18:14:44 UTC
Created attachment 367516 [details]
File: backtrace

Comment 2 Matěj Cepl 2009-11-04 18:22:32 UTC
We don't carry jetpack.

Comment 3 Martin Stransky 2009-11-05 08:07:49 UTC
We want to support jetpack as one of core mozilla feature...

Comment 5 Matěj Cepl 2009-11-05 23:14:42 UTC
Upstream upgraded to 0.6 release, but the crash is still the same.

Comment 6 Martin Stransky 2009-11-16 14:36:58 UTC
(gdb) p mAlertListener
$7 = {<nsCOMPtr_base> =	{mRawPtr = 0x0}, <No data fields>}

260     void
261     nsAlertsIconListener::SendClosed()
262     {
263       mAlertListener->Observe(NULL, "alertfinished", mAlertCookie.get());
264     }

Looks like nsAlertsIconListener is already released...

Comment 7 Martin Stransky 2009-11-16 14:38:56 UTC
*** Bug 528812 has been marked as a duplicate of this bug. ***

Comment 8 Martin Stransky 2009-11-16 14:46:15 UTC
Breakpoint 1, nsAlertsIconListener::InitAlertAsync (this=0xafe90f40, aImageUrl=..., aAlertTitle=..., aAlertText=..., 
    aAlertTextClickable=0, aAlertCookie=..., aAlertListener=0x0) at nsAlertsIconListener.cpp:273

Looks like the aAlertListener is initialized as NULL here (if jet-pack is installed).

Comment 9 Martin Stransky 2009-11-16 15:03:28 UTC
upstream bug - https://bugzilla.mozilla.org/show_bug.cgi?id=528930

Comment 10 Bug Zapper 2009-11-16 15:06:03 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 11 Matěj Cepl 2009-11-20 18:31:35 UTC
*** Bug 538611 has been marked as a duplicate of this bug. ***

Comment 12 Matěj Cepl 2009-11-20 23:09:05 UTC
*** Bug 539610 has been marked as a duplicate of this bug. ***

Comment 13 Matěj Cepl 2009-11-20 23:09:37 UTC
*** Bug 537722 has been marked as a duplicate of this bug. ***

Comment 14 Matěj Cepl 2009-11-23 17:24:53 UTC
*** Bug 539752 has been marked as a duplicate of this bug. ***

Comment 15 Matěj Cepl 2009-11-23 17:25:14 UTC
*** Bug 539801 has been marked as a duplicate of this bug. ***

Comment 16 Matěj Cepl 2009-11-23 17:25:33 UTC
*** Bug 539942 has been marked as a duplicate of this bug. ***

Comment 17 Matěj Cepl 2009-11-23 17:25:56 UTC
*** Bug 540000 has been marked as a duplicate of this bug. ***

Comment 18 Matěj Cepl 2009-11-23 17:26:15 UTC
*** Bug 540007 has been marked as a duplicate of this bug. ***

Comment 19 Matěj Cepl 2009-11-23 17:26:32 UTC
*** Bug 540017 has been marked as a duplicate of this bug. ***

Comment 20 Matěj Cepl 2009-11-23 17:26:54 UTC
*** Bug 540025 has been marked as a duplicate of this bug. ***

Comment 21 Matěj Cepl 2009-11-23 17:27:09 UTC
*** Bug 540078 has been marked as a duplicate of this bug. ***

Comment 22 Matěj Cepl 2009-11-23 17:27:27 UTC
*** Bug 540160 has been marked as a duplicate of this bug. ***

Comment 23 Matěj Cepl 2009-11-23 17:28:14 UTC
*** Bug 540221 has been marked as a duplicate of this bug. ***

Comment 24 Matěj Cepl 2009-11-23 17:28:33 UTC
*** Bug 540405 has been marked as a duplicate of this bug. ***

Comment 25 Matěj Cepl 2009-11-23 17:28:52 UTC
*** Bug 540449 has been marked as a duplicate of this bug. ***

Comment 26 Matěj Cepl 2009-11-23 21:11:59 UTC
*** Bug 540610 has been marked as a duplicate of this bug. ***

Comment 27 Matěj Cepl 2009-11-25 17:13:25 UTC
*** Bug 540779 has been marked as a duplicate of this bug. ***

Comment 28 Matěj Cepl 2009-11-25 17:15:23 UTC
*** Bug 540947 has been marked as a duplicate of this bug. ***

Comment 29 Matěj Cepl 2009-11-25 18:07:24 UTC
#2  <signal handler called>
No symbol table info available.
#3  nsAlertsIconListener::SendClosed (this=<value optimized out>)
    at nsAlertsIconListener.cpp:263
No locals.
#4  0x00007f18a16f6cca in notify_closed_cb (
    notification=<value optimized out>, user_data=0x7f187d009100)
    at nsAlertsIconListener.cpp:66
        alert = 0x7f187d009100
#5  0x000000331460ba8e in IA__g_closure_invoke (closure=0x7f189004ad30, 
    return_value=0x0, n_param_values=1, param_values=0x7f188904ebc0, 
    invocation_hint=0x7fff30951da0) at gclosure.c:767
        marshal = <value optimized out>
        marshal_data = <value optimized out>
        in_marshal = <value optimized out>
        __PRETTY_FUNCTION__ = "IA__g_closure_invoke"
#6  0x0000003314620ec3 in signal_emit_unlocked_R (node=<value optimized out>, 
    detail=<value optimized out>, instance=<value optimized out>, 
    emission_return=<value optimized out>, 
    instance_and_params=<value optimized out>) at gsignal.c:3247
        tmp = <value optimized out>
        handler = 0x7f189004ad00
        accumulator = 0x0
        emission = {next = 0x7fff30952230, instance = 0x7f1878894ee0, ihint = {
            signal_id = 255, detail = 0, run_type = G_SIGNAL_RUN_FIRST}, 
          state = EMISSION_RUN, chain_type = 4}
        class_closure = 0x7f1878894dc0
        handler_list = 0x7f189004ad00
        return_accu = 0x0
        accu = {g_type = 0, data = {{v_int = 0, v_uint = 0, v_long = 0, 
              v_ulong = 0, v_int64 = 0, v_uint64 = 0, v_float = 0, v_double = 
    0, v_pointer = 0x0}, {v_int = 0, v_uint = 0, v_long = 0, v_ulong = 0, 
              v_int64 = 0, v_uint64 = 0, v_float = 0, v_double = 0, 
              v_pointer = 0x0}}}
        signal_id = <value optimized out>
        max_sequential_handler_number = <value optimized out>
        return_value_altered = <value optimized out>
#7  0x0000003314622259 in IA__g_signal_emit_valist (
    instance=<value optimized out>, signal_id=<value optimized out>, 
    detail=<value optimized out>, var_args=0x7fff30951f90) at gsignal.c:2980
        instance_and_params = <value optimized out>
        signal_return_type = 4
        param_values = 0x7f188904ebd8
        node = 0x7f186cdf1d30
        i = <value optimized out>
        n_params = 0
        __PRETTY_FUNCTION__ = "IA__g_signal_emit_valist"
#8  0x00000033146227a3 in IA__g_signal_emit (instance=<value optimized out>, 
    signal_id=<value optimized out>, detail=<value optimized out>)
    at gsignal.c:3037
        var_args = {{gp_offset = 24, fp_offset = 48, overflow_arg_area = 
    0x7fff30952070, reg_save_area = 0x7fff30951fb0}}
#9  0x0000003309a03a06 in _close_signal_handler (proxy=<value optimized out>, 
    id=<value optimized out>, reason=<value optimized out>, notification=
    0x7f1878894ee0 [NotifyNotification]) at notification.c:740
No locals.
#10 0x0000003317611c7f in marshal_dbus_message_to_g_marshaller (
    closure=<value optimized out>, return_value=0x0, 
    n_param_values=<value optimized out>, param_values=<value optimized out>, 
    invocation_hint=0x7fff30952240, marshal_data=0x0) at dbus-gproxy.c:1681
        value_array = <value optimized out>
        c_marshaller = <value optimized out>
        proxy = 0x7f188b3b2080 [DBusGProxy]
        __PRETTY_FUNCTION__ = "marshal_dbus_message_to_g_marshaller"
#11 0x000000331460ba8e in IA__g_closure_invoke (closure=0x7f189004ad90, 
    return_value=0x0, n_param_values=3, param_values=0x7f186bca3470, 
    invocation_hint=0x7fff30952240) at gclosure.c:767
        marshal = <value optimized out>
        marshal_data = <value optimized out>
        in_marshal = <value optimized out>
        __PRETTY_FUNCTION__ = "IA__g_closure_invoke"
#12 0x0000003314620ec3 in signal_emit_unlocked_R (node=<value optimized out>,

Comment 30 Matěj Cepl 2009-11-25 18:07:48 UTC
*** Bug 541362 has been marked as a duplicate of this bug. ***

Comment 31 Matěj Cepl 2009-11-25 23:49:23 UTC
*** Bug 541458 has been marked as a duplicate of this bug. ***

Comment 32 Matěj Cepl 2009-12-10 00:43:04 UTC
*** Bug 542554 has been marked as a duplicate of this bug. ***

Comment 33 Matěj Cepl 2009-12-10 00:43:04 UTC
*** Bug 543675 has been marked as a duplicate of this bug. ***

Comment 34 Matěj Cepl 2009-12-10 00:43:04 UTC
*** Bug 543950 has been marked as a duplicate of this bug. ***

Comment 35 Matěj Cepl 2009-12-10 00:43:04 UTC
*** Bug 542901 has been marked as a duplicate of this bug. ***

Comment 36 Matěj Cepl 2009-12-10 00:43:04 UTC
*** Bug 543123 has been marked as a duplicate of this bug. ***

Comment 37 Matěj Cepl 2009-12-10 00:43:04 UTC
*** Bug 544292 has been marked as a duplicate of this bug. ***

Comment 38 Matěj Cepl 2009-12-10 00:43:08 UTC
*** Bug 544643 has been marked as a duplicate of this bug. ***

Comment 39 Matěj Cepl 2009-12-10 00:43:08 UTC
*** Bug 544644 has been marked as a duplicate of this bug. ***

Comment 40 Matěj Cepl 2009-12-10 00:43:08 UTC
*** Bug 545257 has been marked as a duplicate of this bug. ***

Comment 41 Matěj Cepl 2009-12-10 00:43:08 UTC
*** Bug 544751 has been marked as a duplicate of this bug. ***

Comment 42 Matěj Cepl 2009-12-10 00:43:09 UTC
*** Bug 545383 has been marked as a duplicate of this bug. ***

Comment 43 Matěj Cepl 2009-12-10 00:43:09 UTC
*** Bug 545287 has been marked as a duplicate of this bug. ***

Comment 44 Matěj Cepl 2009-12-10 00:43:10 UTC
*** Bug 545721 has been marked as a duplicate of this bug. ***

Comment 45 Chris Campbell 2009-12-14 19:20:57 UTC
*** Bug 546824 has been marked as a duplicate of this bug. ***

Comment 46 Chris Campbell 2009-12-14 19:21:46 UTC
*** Bug 546643 has been marked as a duplicate of this bug. ***

Comment 47 Chris Campbell 2009-12-15 13:56:56 UTC
*** Bug 547502 has been marked as a duplicate of this bug. ***

Comment 48 Chris Campbell 2009-12-15 14:46:36 UTC
*** Bug 547130 has been marked as a duplicate of this bug. ***

Comment 49 Matěj Cepl 2009-12-21 17:23:56 UTC
*** Bug 546132 has been marked as a duplicate of this bug. ***

Comment 50 Matěj Cepl 2009-12-21 17:23:56 UTC
*** Bug 549409 has been marked as a duplicate of this bug. ***

Comment 51 Matěj Cepl 2009-12-21 17:23:57 UTC
*** Bug 549313 has been marked as a duplicate of this bug. ***

Comment 52 Chris Campbell 2009-12-26 20:21:39 UTC
*** Bug 550684 has been marked as a duplicate of this bug. ***

Comment 53 Chris Campbell 2009-12-27 17:42:56 UTC
*** Bug 550827 has been marked as a duplicate of this bug. ***

Comment 54 Chris Campbell 2009-12-29 13:43:35 UTC
*** Bug 551163 has been marked as a duplicate of this bug. ***

Comment 55 Chris Campbell 2009-12-30 13:04:46 UTC
*** Bug 551275 has been marked as a duplicate of this bug. ***

Comment 56 Chris Campbell 2009-12-30 20:16:01 UTC
*** Bug 551431 has been marked as a duplicate of this bug. ***

Comment 57 Chris Campbell 2010-01-01 22:12:24 UTC
*** Bug 551760 has been marked as a duplicate of this bug. ***

Comment 58 Chris Campbell 2010-01-07 13:19:25 UTC
*** Bug 553164 has been marked as a duplicate of this bug. ***

Comment 59 Chris Campbell 2010-01-08 20:00:24 UTC
*** Bug 553701 has been marked as a duplicate of this bug. ***

Comment 60 Chris Campbell 2010-01-10 21:50:00 UTC
*** Bug 554168 has been marked as a duplicate of this bug. ***

Comment 61 Chris Campbell 2010-01-23 15:39:55 UTC
*** Bug 558075 has been marked as a duplicate of this bug. ***

Comment 62 Chris Campbell 2010-03-02 19:45:08 UTC
*** Bug 569522 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.