Bug 533146 - OpenOffice Calc notes are not saved
Summary: OpenOffice Calc notes are not saved
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 547014 553664 555032 558167 560443 561166 567499 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-05 11:09 UTC by pposc
Modified: 2010-02-23 06:36 UTC (History)
8 users (show)

Fixed In Version: 3.1.1-19.8.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-18 14:10:14 UTC
Type: ---


Attachments (Terms of Use)
spreadsheet containing 1 cell with a note. The note has disappeared after the file has been saved in ODS format (7.39 KB, application/vnd.oasis.opendocument.spreadsheet)
2009-11-05 11:09 UTC, pposc
no flags Details
Same spreadsheet, saved in Excel format. The note is visible. (6.50 KB, application/vnd.ms-excel)
2009-11-05 11:10 UTC, pposc
no flags Details


Links
System ID Private Priority Status Summary Last Updated
OpenOffice.org 102061 0 None None None Never
OpenOffice.org 106619 0 None None None Never

Description pposc 2009-11-05 11:09:22 UTC
Created attachment 367595 [details]
spreadsheet containing 1 cell with a note. The note has disappeared after the file has been saved in ODS format

Description of problem:
Notes inserted in cells of a Calc sheet are not saved when using native format
(ODF) to save the document.

Version-Release number of selected component (if applicable):
OOO310m19 (Build 9420)
3.1.1-19.2.fc11

Steps to Reproduce:
1. Open a new calc sheet.
2. In a cell, insert a note (by right-clicking or by using the Menu Insert / Note). Save the document in OpenDocument format.
3. Close the file and re-open it
  
Actual results:
The note has disappeared, it has not been saved.

Expected results:

The note should be saved and visible when the spreadsheet is re-opened.

Additional info:
If the spreadsheet is saved in MS Excel format, the note is correctly saved!

Comment 1 pposc 2009-11-05 11:10:18 UTC
Created attachment 367596 [details]
Same spreadsheet, saved in Excel format. The note is visible.

Comment 2 pposc 2009-11-05 11:13:44 UTC
I discover this bug using Fedora 11 on a 64 bits Intel Platform.

I've also tested on a 32 bits Intel platform : same behaviour.

The latest builts of OOo (3.1.1-19.4.fc11 and 3.1.1-19.5.fc11) have also the same behaviour.

Comment 3 Caolan McNamara 2009-11-05 11:26:30 UTC
hmm, might be the object positioning code

Comment 4 Caolan McNamara 2009-11-05 13:45:21 UTC
indeed, those notes are cell anchored, but their positions should be relative to the little red dot, not the edge of the caption box itself, which is always should outside the cell, and so is falling out of the exportable area.

Fix will be in >= 3.1.1-19.6.fc11

Comment 5 pposc 2009-11-05 18:06:17 UTC
Just to let you know that we did test with the same OOo version (3.1.1) on other operating systems: the bug DOESN'T exist with OOo 3.1.1 on Windows XP nor on Debian.

Comment 6 Caolan McNamara 2009-11-05 18:16:48 UTC
Yes, its a side-effect of the fix for upstream issue 102061

Comment 7 Fedora Update System 2009-11-07 12:59:24 UTC
openoffice.org-3.1.1-19.7.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/openoffice.org-3.1.1-19.7.fc11

Comment 8 Fedora Update System 2009-11-10 17:57:39 UTC
openoffice.org-3.1.1-19.7.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-11295

Comment 9 Fedora Update System 2009-11-17 11:11:10 UTC
openoffice.org-3.1.1-19.8.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/openoffice.org-3.1.1-19.8.fc11

Comment 10 Fedora Update System 2009-11-18 14:09:45 UTC
openoffice.org-3.1.1-19.8.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 David Tardon 2009-12-13 09:02:36 UTC
*** Bug 547014 has been marked as a duplicate of this bug. ***

Comment 12 David Tardon 2010-01-13 18:18:58 UTC
*** Bug 555032 has been marked as a duplicate of this bug. ***

Comment 13 David Tardon 2010-01-13 18:26:27 UTC
*** Bug 553664 has been marked as a duplicate of this bug. ***

Comment 14 David Tardon 2010-01-24 06:58:05 UTC
*** Bug 558167 has been marked as a duplicate of this bug. ***

Comment 15 Tim Taiwanese Liim 2010-01-24 18:01:49 UTC
Copy Comment#2, #3 from bug547014, which has more up-to-date info than
this bug: it's fixed in 3.1.1-19.15.fc12.


bug547014 Comment #2
    Jorge Fábregas      2010-01-05 12:00:50 EST

    Hi,
    I just faced this issue and I'm using the latest packages on Fedora 12
    (openoffice.org-calc-3.1.1-19.14.fc12.i686).  

    Why hasn't package 3.1.1-19.15.fc12 been pushed forward for F12?

    Thanks,
    Jorge    

bug547014 Comment #3
    A S Alam 2010-01-07 04:13:33 EST

    please check latest updated package for F12 from updates-testing
    (yum update --enablerepo=updates-testing openoffice*)

Comment 16 David Tardon 2010-01-31 18:37:22 UTC
*** Bug 560443 has been marked as a duplicate of this bug. ***

Comment 17 David Tardon 2010-02-03 06:00:32 UTC
*** Bug 561166 has been marked as a duplicate of this bug. ***

Comment 18 David Tardon 2010-02-23 06:36:30 UTC
*** Bug 567499 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.