Bug 53322 - "rpm -ta" on tarball without .spec litters filesystem
"rpm -ta" on tarball without .spec litters filesystem
Status: CLOSED DUPLICATE of bug 8527
Product: Red Hat Public Beta
Classification: Retired
Component: rpm (Show other bugs)
roswell
All Linux
medium Severity low
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-06 12:10 EDT by Ed Marshall
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-06 12:10:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Marshall 2001-09-06 12:10:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010803

Description of problem:
If you perform an "rpm -ta <package>.tar.gz" on a tarball that doesn't
contain a spec file, you'll end up with a file name "tar: *.spec: Not found
in archive" in  %_topdir/SPECS.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. wget http://prdownloads.sourceforge.net/abiword/abiword-0.9.3.tar.gz
2. rpm -ta abiword-0.9.3.tar.gz
3. ls /usr/src/redhat/SPECS ;-)

Additional info:

Just a cosmetic annoyance, really, but should probably be fixed.
Comment 1 Jeff Johnson 2001-09-06 12:50:32 EDT
Yup, my favorite rpm bug. I use it to qualify rpm hackers :-)

*** This bug has been marked as a duplicate of 8527 ***

Note You need to log in before you can comment on or make changes to this bug.