Bug 8527 - rpm creates file named 'tar: *.spec: Not found in archive'
rpm creates file named 'tar: *.spec: Not found in archive'
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: rpm-build (Show other bugs)
9
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jeff Johnson
:
: 53322 68857 80975 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-17 04:31 EST by Edward J. Huff
Modified: 2007-04-18 12:25 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 17:39:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edward J. Huff 2000-01-17 04:31:21 EST
The man page doesn't give any hints about what a SPEC file is
or where it might be found. I had to guess.  In doing that,
I discovered this feature:  rpm creates file named
'tar: *.spec: Not found in archive' instead of printing the
error to stderr.

[root@desk /root]# ls -al /usr/src/redhat/SPECS/
total 24
drwxr-xr-x   2 root     root         4096 Jan 16 01:13 .
drwxr-xr-x   7 root     root         4096 Jan  9 13:43 ..
-rw-rw-r--   1 root     root        13622 Dec 14 10:38 linuxconf.spec
[root@desk /root]# rpm -tc
/usr/src/redhat/SOURCES/linuxconf-1.16r10.src.tar.gz
Name field must be present in package: (main package)
Version field must be present in package: (main package)
Release field must be present in package: (main package)
Summary field must be present in package: (main package)
Group field must be present in package: (main package)
License field must be present in package: (main package)
[root@desk /root]# ls -al /usr/src/redhat/SPECS/
total 24
drwxr-xr-x   2 root     root         4096 Jan 16 01:14 .
drwxr-xr-x   7 root     root         4096 Jan  9 13:43 ..
-rw-rw-r--   1 root     root        13622 Dec 14 10:38 linuxconf.spec
-rw-r--r--   1 root     root            0 Jan 16 01:14 tar: *.spec: Not
found in archive
[root@desk /root]#
Comment 1 Jeff Johnson 2000-01-17 14:38:59 EST
My favorite rpm wartlet, thanks for reporting :-)
Comment 2 Rodrigo Barbosa 2000-12-13 15:30:13 EST
lah lah lah lah lah :-) Jeff has a patch ! :-) lah lah lah lah lah :-)
Comment 3 Jeff Johnson 2001-02-22 16:41:37 EST
Changing component.
Comment 4 Jeff Johnson 2001-09-06 12:50:28 EDT
*** Bug 53322 has been marked as a duplicate of this bug. ***
Comment 5 Jeff Johnson 2002-07-15 11:51:45 EDT
*** Bug 68857 has been marked as a duplicate of this bug. ***
Comment 6 Jeff Johnson 2003-01-02 17:23:43 EST
*** Bug 80975 has been marked as a duplicate of this bug. ***
Comment 7 Gerald Teschl 2003-07-27 17:34:37 EDT
Still present in rpm-4.2-1.
Comment 8 Need Real Name 2004-09-09 08:59:29 EDT
Still present in rpm-4.3.1-0.3 (Fedora Core 2).
Comment 9 John Ellson 2005-02-22 11:00:50 EST
Still present in rpm-build-4.4.1-2, more than 5 years after the original report!!!

I suggest increasing the priority on this in the hope that the developer will
take notice.
Comment 10 Bill Nottingham 2005-09-29 17:39:35 EDT
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

For RPM issues, please try a current release such as Fedora Core 4; if bugs
persist, please open a new issue.

Note You need to log in before you can comment on or make changes to this bug.