Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 53323 - Nautilus segfaults if LANG != EN
Nautilus segfaults if LANG != EN
Status: CLOSED DUPLICATE of bug 51068
Product: Red Hat Public Beta
Classification: Retired
Component: nautilus (Show other bugs)
roswell
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-06 14:06 EDT by Martin Wilck
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-06 14:07:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Wilck 2001-09-06 14:06:05 EDT
Description of Problem:
In the Gnome desktop, Nautilus causes a segmentation fault if the selected
desktop language is other than english (I tried german, italian, korean). 

Version-Release number of selected component (if applicable):
1.0.4-34

How Reproducible:
Always

Steps to Reproduce:
1. select language = german in gdm (or other non-english, I didn't try all) 
2. log in
3. 

Actual Results:
No desktop icons, trying to start nautilus from terminal gives seg fault

Expected Results:
Desktop icons show up, nautilus can be started

Additional Information:
I did a complete install.
	
A quick backtrace in gdb shows the call stack:

strlen ()
g_strconcat()
eel_font_manager_get_default_font()
global_preference_install_one_default
(preference_name="preferences/default-smooth-font", 	  
preference_type=PREFERENCE_STRING, 
   user_level_default=0x20000000007372e8)
...
Comment 1 Martin Wilck 2001-09-06 14:30:22 EDT
Oops - just discovered that this  was Bug 51068 duplicated.
Must have escaped my attention. Sorry for that.


*** This bug has been marked as a duplicate of 51068 ***

Note You need to log in before you can comment on or make changes to this bug.