Bug 533236 - X server failure with xorg-x11-server-Xorg-1.7.1-6 and Radeon X300
X server failure with xorg-x11-server-Xorg-1.7.1-6 and Radeon X300
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
: 533301 533363 (view as bug list)
Depends On:
Blocks: fedora-x-blocker
  Show dependency treegraph
 
Reported: 2009-11-05 13:36 EST by James Laska
Modified: 2013-09-02 02:42 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-06 11:33:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/Xorg.0.log (66.15 KB, text/plain)
2009-11-05 13:36 EST, James Laska
no flags Details
nouveau traceback from Warren Togami (34.95 KB, text/plain)
2009-11-05 16:19 EST, Adam Williamson
no flags Details
Another Xorg log (168.04 KB, text/plain)
2009-11-05 17:50 EST, Gordon Messmer
no flags Details

  None (edit)
Description James Laska 2009-11-05 13:36:37 EST
Created attachment 367679 [details]
/var/log/Xorg.0.log

Description of problem:

After installing the latest rawhide, gdm seems to start ... but X keeps crashing.  I'm able to 

$ echo "xterm" > $HOME/.xinitrc
$ startx -- :1 -logverbose 9

Version-Release number of selected component (if applicable):

 * kernel-2.6.31.5-117.fc12.i686
 * xorg-x11-server-Xorg-1.7.1-6ssp2.fc12.i386
 * xorg-x11-drv-ati-6.13.0-0.10.20091006git457646d73.fc12.i686

How reproducible:

100%.  Anytime I boot into runlevel 5, or try startx (with gnome-session)

Steps to Reproduce:
1. echo "xterm" > $HOME/.xinitrc
2. startx
3. run 'gnome-session' from xterm
  
Actual results:

 * X crashes ... see attached Xorg.0.log

Backtrace:
0: /usr/bin/X (xorg_backtrace+0x39) [0x80c3399]
1: /usr/bin/X (0x8048000+0x77bc0) [0x80bfbc0]
2: (vdso) (__kernel_rt_sigreturn+0x0) [0xb9240c]
3: /usr/lib/libpixman-1.so.0 (0x63d000+0x4d236) [0x68a236]
4: /usr/lib/libpixman-1.so.0 (0x63d000+0x4d401) [0x68a401]
5: /usr/lib/libpixman-1.so.0 (0x63d000+0x15384) [0x652384]
6: /usr/lib/libpixman-1.so.0 (pixman_blt+0x79) [0x677609]
7: /usr/lib/xorg/modules/libfb.so (fbCopyNtoN+0x230) [0x1dbf0f]
8: /usr/bin/X (miCopyRegion+0x294) [0x81eddcc]
9: /usr/bin/X (miDoCopy+0x47b) [0x81ee275]
10: /usr/lib/xorg/modules/libfb.so (fbCopyArea+0x92) [0x1dc9b9]
11: /usr/lib/xorg/modules/libfb.so (0x1c8000+0x1a286) [0x1e2286]
12: /usr/lib/xorg/modules/libfb.so (0x1c8000+0x1a2f4) [0x1e22f4]
13: /usr/lib/xorg/modules/libfb.so (image_from_pict+0x98) [0x1e2779]
14: /usr/lib/xorg/modules/libfb.so (fbComposite+0xe8) [0x1e1d26]
15: /usr/lib/xorg/modules/libexa.so (0xa6c000+0x129ab) [0xa7e9ab]
16: /usr/lib/xorg/modules/libexa.so (0xa6c000+0x1079f) [0xa7c79f]
17: /usr/bin/X (0x8048000+0x1051f2) [0x814d1f2]
18: /usr/bin/X (CompositePicture+0x18b) [0x813c7f0]
19: /usr/bin/X (0x8048000+0xc2d2c) [0x810ad2c]
20: /usr/bin/X (0x8048000+0xc2df9) [0x810adf9]
21: /usr/bin/X (0x8048000+0x16cdd0) [0x81b4dd0]
22: /usr/bin/X (0x8048000+0x16d096) [0x81b5096]
23: /usr/bin/X (0x8048000+0x20078) [0x8068078]
24: /usr/bin/X (MapWindow+0x253) [0x80683e4]
25: /usr/bin/X (0x8048000+0x3d7a1) [0x80857a1]
26: /usr/bin/X (0x8048000+0x3c83b) [0x808483b]
27: /usr/bin/X (0x8048000+0x1a903) [0x8062903]
28: /lib/libc.so.6 (__libc_start_main+0xe6) [0x32bbb6]
29: /usr/bin/X (0x8048000+0x1a361) [0x8062361]
Segmentation fault at address (nil)

Fatal server error:
Caught signal 11 (Segmentation fault). Server aborting

Expected results:

 * A working X

Additional info:

 * 01:00.0 VGA compatible controller: ATI Technologies Inc M22 [Mobility Radeon X300]

 * X backtrace - http://pastie.org/685242
 * dmesg - http://pastie.org/685206
 * /proc/$X_PID/maps - http://pastie.org/685218
Comment 1 Adam Williamson 2009-11-05 13:41:08 EST
I'm going to throw this on the blocker list for now, easier to track what's going on that way. If glisse and ssp agree that it's not actually blocker-worthy we will drop it off again.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 James Laska 2009-11-05 14:00:06 EST
= Workarounds =

Two workarounds exist at this time.  

 1) Boot with 'nomodeset'

 2) Or, boot without an external monitor
Comment 3 Gordon Messmer 2009-11-05 14:14:57 EST
I'm getting what looks like an identical crash even when using "nomodeset".

[gordon@herald:~]$ cat /proc/cmdline 
ro root=/dev/mapper/vg_herald-lv_root  LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us rhgb quiet nomodeset

[gordon@herald:~]$ rpm -q xorg-x11-server-Xorg xorg-x11-server-common
xorg-x11-server-Xorg-1.7.1-6.fc12.x86_64
xorg-x11-server-common-1.7.1-6.fc12.x86_64

[gordon@herald:~]$ uname -a
Linux herald.private.dragonsdawn.net 2.6.31.5-117.fc12.x86_64 #1 SMP Wed Nov 4 11:15:52 EST 2009 x86_64 x86_64 x86_64 GNU/Linux

[gordon@herald:~]$ lspci | grep ATI
02:00.0 VGA compatible controller: ATI Technologies Inc RV370 [Sapphire X550 Silent]
02:00.1 Display controller: ATI Technologies Inc RV370 secondary [Sapphire X550 Silent]

Backtrace:
0: /usr/bin/Xorg (xorg_backtrace+0x28) [0x49e898]
1: /usr/bin/Xorg (0x400000+0x619c9) [0x4619c9]
2: /lib64/libpthread.so.0 (0x7f61739e1000+0xefa0) [0x7f61739effa0]
3: /usr/lib64/libpixman-1.so.0 (0x3976400000+0x43a04) [0x3976443a04]
4: /usr/lib64/libpixman-1.so.0 (0x3976400000+0x43c18) [0x3976443c18]
5: /usr/lib64/libpixman-1.so.0 (pixman_blt+0x78) [0x3976430238]
6: /usr/lib64/xorg/modules/libfb.so (fbCopyNtoN+0x1bd) [0x7f6170dddbfd]
7: /usr/bin/Xorg (miCopyRegion+0x28d) [0x54571d]
8: /usr/bin/Xorg (miDoCopy+0x44a) [0x545c2a]
9: /usr/lib64/xorg/modules/libfb.so (fbCopyArea+0x4c) [0x7f6170ddd22c]
10: /usr/lib64/xorg/modules/libfb.so (image_from_pict+0x2e9) [0x7f6170de19d9]
11: /usr/lib64/xorg/modules/libfb.so (fbComposite+0xd4) [0x7f6170de1cb4]
12: /usr/lib64/xorg/modules/libexa.so (0x7f6170bb7000+0x10746) [0x7f6170bc7746]
13: /usr/lib64/xorg/modules/libexa.so (0x7f6170bb7000+0xdb9a) [0x7f6170bc4b9a]
14: /usr/bin/Xorg (0x400000+0xd1c40) [0x4d1c40]
15: /usr/bin/Xorg (0x400000+0x15e419) [0x55e419]
16: /usr/bin/Xorg (0x400000+0x15e6e5) [0x55e6e5]
17: /usr/bin/Xorg (0x400000+0xa2326) [0x4a2326]
18: /usr/bin/Xorg (0x400000+0x4edde) [0x44edde]
19: /usr/bin/Xorg (MapWindow+0x179) [0x452ec9]
20: /usr/bin/Xorg (0x400000+0x2bdc6) [0x42bdc6]
21: /usr/bin/Xorg (0x400000+0x2c69c) [0x42c69c]
22: /usr/bin/Xorg (0x400000+0x21cfa) [0x421cfa]
23: /lib64/libc.so.6 (__libc_start_main+0xfd) [0x7f6172ff7b1d]
24: /usr/bin/Xorg (0x400000+0x218a9) [0x4218a9]
Segmentation fault at address (nil)

Fatal server error:
Caught signal 11 (Segmentation fault). Server aborting
Comment 4 Gordon Messmer 2009-11-05 14:17:10 EST
Slightly different backtrace later and an additional error in the log:

EXA bug: pPixmap->devPrivate.ptr was 0x3efec30, but should have been NULL.

Backtrace:
0: /usr/bin/Xorg (xorg_backtrace+0x28) [0x49e898]
1: /usr/bin/Xorg (0x400000+0x619c9) [0x4619c9]
2: /lib64/libpthread.so.0 (0x7f50345d1000+0xefa0) [0x7f50345dffa0]
3: /usr/lib64/libpixman-1.so.0 (0x3976400000+0x43686) [0x3976443686]
4: /usr/lib64/libpixman-1.so.0 (0x3976400000+0x4381e) [0x397644381e]
5: /usr/lib64/libpixman-1.so.0 (pixman_fill+0x3d) [0x397643016d]
6: /usr/lib64/xorg/modules/libfb.so (fbFill+0x2b6) [0x7f50315a61c6]
7: /usr/lib64/xorg/modules/libfb.so (fbPolyFillRect+0x1d2) [0x7f50315a6662]
8: /usr/lib64/xorg/modules/libexa.so (0x7f503137f000+0xfd11) [0x7f503138ed11]
9: /usr/lib64/xorg/modules/libexa.so (0x7f503137f000+0x8f71) [0x7f5031387f71]
10: /usr/bin/Xorg (0x400000+0xd256b) [0x4d256b]
11: /usr/bin/Xorg (miClearDrawable+0x72) [0x457022]
12: /usr/lib64/xorg/modules/libfb.so (image_from_pict+0x2aa) [0x7f50315a999a]
13: /usr/lib64/xorg/modules/libfb.so (fbComposite+0xd4) [0x7f50315a9cb4]
14: /usr/lib64/xorg/modules/libexa.so (0x7f503137f000+0x10746) [0x7f503138f746]
15: /usr/lib64/xorg/modules/libexa.so (0x7f503137f000+0xdb9a) [0x7f503138cb9a]
16: /usr/bin/Xorg (0x400000+0xd1c40) [0x4d1c40]
17: /usr/bin/Xorg (0x400000+0x15e419) [0x55e419]
18: /usr/bin/Xorg (0x400000+0x15e6e5) [0x55e6e5]
19: /usr/bin/Xorg (0x400000+0xa2326) [0x4a2326]
20: /usr/bin/Xorg (0x400000+0x4edde) [0x44edde]
21: /usr/bin/Xorg (MapWindow+0x179) [0x452ec9]
22: /usr/bin/Xorg (0x400000+0x2bdc6) [0x42bdc6]
23: /usr/bin/Xorg (0x400000+0x2c69c) [0x42c69c]
24: /usr/bin/Xorg (0x400000+0x21cfa) [0x421cfa]
25: /lib64/libc.so.6 (__libc_start_main+0xfd) [0x7f5033be7b1d]
26: /usr/bin/Xorg (0x400000+0x218a9) [0x4218a9]
Segmentation fault at address (nil)

Fatal server error:
Caught signal 11 (Segmentation fault). Server aborting
Comment 5 James Laska 2009-11-05 15:35:06 EST
Additional information on which versions of xorg-x11-server-Xorg appear to break.

PASS - xorg-x11-server-Xorg-1.7.0-5.fc12.i686
PASS - xorg-x11-server-Xorg-1.7.1-1.fc12.i686
PASS - xorg-x11-server-Xorg-1.7.1-2.fc12.i686
PASS - xorg-x11-server-Xorg-1.7.1-3.fc12.i686
FAIL - xorg-x11-server-Xorg-1.7.1-5.fc12.i686
FAIL - xorg-x11-server-Xorg-1.7.1-6.fc12.i686
Comment 6 Adam Williamson 2009-11-05 16:06:09 EST
gordon: do you have more than one monitor attached?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Adam Williamson 2009-11-05 16:17:14 EST
On jlaska's initial manifestation of this issue: jglisse and soren believed it to be affecting any Radeon with multiple heads, but I cannot reproduce on a desktop Radeon HD 4770 with two DVI monitors attached, even after using radeon.vramlimit=64 (as recommended by glisse) to limit video RAM to 64MB. using today's rawhide, it boots, displays correctly on both heads, and continues to work with no crashes, hangs, excess CPU usage or errors in any logs, through launching applications, switching workspaces, and switching to virtual consoles and back to X.

Warren Togami managed to hit a similar issue with the nouveau driver. I will attach the traceback he provided to this bug.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Adam Williamson 2009-11-05 16:19:03 EST
Created attachment 367724 [details]
nouveau traceback from Warren Togami
Comment 9 Gordon Messmer 2009-11-05 17:49:01 EST
Yes, I have two displays.  I'll attach a full Xorg.log file in case it's useful.
Comment 10 Gordon Messmer 2009-11-05 17:50:49 EST
Created attachment 367753 [details]
Another Xorg log
Comment 11 Adam Williamson 2009-11-05 19:14:53 EST
For the record: both radeon reproducers have dual heads, the nouveau reproducer does *not* (single-head laptop configuration).

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Adam Williamson 2009-11-05 19:50:11 EST
An xorg-x11-server build which should fix this is currently in progress:

http://koji.fedoraproject.org/koji/buildinfo?buildID=140035

please test it and report whether it resolves this issue. Testing ASAP would be really appreciated, we're on a tight deadline for F12. Thanks a lot!

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 13 Ben Skeggs 2009-11-05 20:01:35 EST
Hacked up nouveau locally to forcibly reproduce the issue here, and the new server fixes it for me.
Comment 14 Adam Williamson 2009-11-05 20:23:52 EST
retrospectively plonking this back on server as that's where it turned out to be.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 15 James Laska 2009-11-06 11:32:26 EST
No longer observing the reported failure in my ATI dual monitor setup (LVDS + VGA-0) using kernel-2.6.31.5-122.fc12.i686 and xorg-x11-server-Xorg-1.7.1-7.fc12.i686
Comment 16 James Laska 2009-11-06 11:33:56 EST
Thanks for the excellent detective work and resolution on this issue.  I'm moving this to CLOSED RAWHIDE.  Please feel free to reopen the report if you still experience the failure using the packages listed in comment#15
Comment 17 Orion Poplawski 2009-11-06 13:04:16 EST
*** Bug 533301 has been marked as a duplicate of this bug. ***
Comment 18 Peter Robinson 2009-11-07 08:55:59 EST
*** Bug 533363 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.