This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 533363 - Latest rawhide x server crashing
Latest rawhide x server crashing
Status: CLOSED DUPLICATE of bug 533236
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-11-06 06:40 EST by Peter Robinson
Modified: 2009-11-07 08:55 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-07 08:55:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
x log (86.83 KB, text/plain)
2009-11-06 06:40 EST, Peter Robinson
no flags Details

  None (edit)
Description Peter Robinson 2009-11-06 06:40:35 EST
Created attachment 367815 [details]
x log 

The rawhide from 5th November introduced a crash in X server. The back trace is in the xorg log files. I had to revert back to the following to get a working X

xorg-x11-server-devel-1.7.1-3.fc12.x86_64
xorg-x11-server-Xorg-1.7.1-3.fc12.x86_64
xorg-x11-server-common-1.7.1-3.fc12.x86_64

Machine is a Dell D630C laptop with the following card

[root@neo ~]# lspci |grep VGA
01:00.0 VGA compatible controller: nVidia Corporation Quadro NVS 135M (rev a1)
Comment 1 Yanko Kaneti 2009-11-06 07:04:55 EST
looks like bug 533236. perhaps try 1.7.1-7 from koji
Comment 2 Peter Robinson 2009-11-06 07:11:15 EST
Similar but in this case there's 3 main differences. Graphics card is Nvidia not ATI, I didn't have a second monitor attached (although when in the office I do have one) and I'm already running with the nomodeset option due to RHBZ bug 529883
Comment 3 James Laska 2009-11-06 07:36:09 EST
I'm not an X-pert, but I seem to recall someone also hitting bug#533236 who was using nouveau with a single monitor (see https://bugzilla.redhat.com/show_bug.cgi?id=533236#c11).  I've confirmed that my dual-monitor ATI issue is resolved using the latest kernel (http://koji.fedoraproject.org/koji/buildinfo?buildID=139823) and xorg-x11-server (http://koji.fedoraproject.org/koji/buildinfo?buildID=140035).  I believe you'll also want the latest nouveau (http://koji.fedoraproject.org/koji/buildinfo?buildID=139811).

Can you please retest with those packages and provide feedback?
Comment 4 Peter Robinson 2009-11-06 07:40:51 EST
Thanks James, I'll need to investigate this tomorrow as today I need a working machine.
Comment 5 Bill Nottingham 2009-11-06 10:26:48 EST
Please do try a later version; 1.7.1-3 is known bad.
Comment 6 Peter Robinson 2009-11-06 11:21:42 EST
Known bad in what way? I seem to have a US keyboard back again but at least I have what otherwise seems to be a working system. The others wouldn't give me X and I need a stable system tonight for work.
Comment 7 Adam Williamson 2009-11-06 11:53:35 EST
that actually makes sense, because the thing that broke it for you was introduced in 1.7.1-5. (as a fix for a different bug introduced by 1.7.1-3).

this is 99.99% certainly a duplicate of 533236, the traceback is identical and the bug was somewhat unpredictable, i.e., it's not certain you needed KMS or dual displays to hit it, it depended on your exact circumstances.

Please test 1.7.1-7, I am sure it will work for you, and since this was placed on the blocker list we need to be sure.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Peter Robinson 2009-11-07 08:55:58 EST
I can confirm now that 1.7.1-7 fixes the problem

*** This bug has been marked as a duplicate of bug 533236 ***

Note You need to log in before you can comment on or make changes to this bug.